Fix building with Clang.

This commit is contained in:
adam 2011-03-17 13:26:04 +00:00
parent 4fbd91bd63
commit d412fddae7
6 changed files with 56 additions and 14 deletions

View file

@ -1,10 +1,10 @@
$NetBSD: distinfo,v 1.14 2011/03/08 14:06:43 taca Exp $
$NetBSD: distinfo,v 1.15 2011/03/17 13:26:04 adam Exp $
SHA1 (mysql-5.1.56.tar.gz) = 8665c76ab4ab36e8d2379ddf6d678c89b95d9321
RMD160 (mysql-5.1.56.tar.gz) = c2ff6eb06d0797d4b56630b783d4ad2d1add1422
Size (mysql-5.1.56.tar.gz) = 24795624 bytes
SHA1 (patch-aa) = 344bc9ab7013fbf64be6adbe8a9fc6279887beb1
SHA1 (patch-ab) = 66ea5217d98d33e1be44e4dda754a94496f1ea44
SHA1 (patch-ab) = e61528fc6590deee16fcd7ad3eeeb96ed44a831d
SHA1 (patch-ac) = a250b9797fbaad51d054cbb324feb0f7c29096d4
SHA1 (patch-ad) = 4e98f696b8b5098456e53a8de710a6bcd547997c
SHA1 (patch-ae) = 5373aeea5d67d8d1cbee1fa4d04c03227b544e3d

View file

@ -1,4 +1,4 @@
# $NetBSD: options.mk,v 1.3 2010/03/21 14:40:15 taca Exp $
# $NetBSD: options.mk,v 1.4 2011/03/17 13:26:04 adam Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.mysql5

View file

@ -1,6 +1,7 @@
$NetBSD: patch-ab,v 1.3 2010/12/16 03:42:49 taca Exp $
$NetBSD: patch-ab,v 1.4 2011/03/17 13:26:04 adam Exp $
* process directories in client package.
* Fix building with Clang (precompiler output doesn't print #include)
--- Makefile.in.orig 2010-11-29 10:42:58.000000000 +0000
+++ Makefile.in
@ -20,3 +21,12 @@ $NetBSD: patch-ab,v 1.3 2010/12/16 03:42:49 taca Exp $
DIST_SUBDIRS = . include Docs zlib \
cmd-line-utils sql-common scripts \
@@ -1145,7 +1140,7 @@ do_abi_check:
-e '/^#pragma GCC set_debug_pwd/d' \
-e '/^#ident/d' > \
$(top_builddir)/abi_check.out; \
- @DIFF@ -I '#include' -w $$file.pp $(top_builddir)/abi_check.out; \
+ @DIFF@ -w $$file.pp $(top_builddir)/abi_check.out; \
@RM@ $(top_builddir)/abi_check.out; \
done

View file

@ -1,10 +1,10 @@
$NetBSD: distinfo,v 1.16 2011/03/08 14:06:44 taca Exp $
$NetBSD: distinfo,v 1.17 2011/03/17 13:26:04 adam Exp $
SHA1 (mysql-5.1.56.tar.gz) = 8665c76ab4ab36e8d2379ddf6d678c89b95d9321
RMD160 (mysql-5.1.56.tar.gz) = c2ff6eb06d0797d4b56630b783d4ad2d1add1422
Size (mysql-5.1.56.tar.gz) = 24795624 bytes
SHA1 (patch-aa) = 2a5321738e637a56e57cd6b1b40908d2bf275506
SHA1 (patch-ab) = 1fc6939bb3021153b72479aa2413e50940878c98
SHA1 (patch-ab) = 4c485a74d55553d63fc3dbc0350d0aa0068e1fcf
SHA1 (patch-ac) = bfb6eec77d7c5aa8d2b849632769005dcf2e272c
SHA1 (patch-ad) = 5fd4db0e04a97289f38a5467bbae5041f4082b51
SHA1 (patch-ae) = e682e8c7a260706cbfd802885bfe100c0e0d31be
@ -14,6 +14,7 @@ SHA1 (patch-ah) = a608060cee7aadaf8bcde84016a73131a75dea32
SHA1 (patch-ai) = 4c5acf2b0e05765a1fe9e30558d163886e1aa492
SHA1 (patch-aj) = b8f35d3a1bc45eb5336ae6a842898b257d2660db
SHA1 (patch-ak) = 3c740b78afacfe05aa082c5b235c10c51ac94641
SHA1 (patch-al) = 72def54c14d3736c49b50e599528311a2d97f9c7
SHA1 (patch-am) = 2cf10915f5dc3caf11bb8c7c7255842da646b247
SHA1 (patch-an) = 7b627ceb6212641b7e0de9fd7142bc95e4dcb8cb
SHA1 (patch-ao) = 7895abad117d5c6901c2241209c5747e6c490e7d

View file

@ -1,6 +1,6 @@
$NetBSD: patch-ab,v 1.3 2010/12/16 03:42:50 taca Exp $
$NetBSD: patch-ab,v 1.4 2011/03/17 13:26:05 adam Exp $
--- Makefile.in.orig 2010-11-29 10:42:58.000000000 +0000
--- Makefile.in.orig 2011-02-11 19:24:28.000000000 +0000
+++ Makefile.in
@@ -407,13 +407,10 @@ AUTOMAKE_OPTIONS = foreign
EXTRA_DIST = INSTALL-SOURCE INSTALL-WIN-SOURCE \
@ -20,3 +20,12 @@ $NetBSD: patch-ab,v 1.3 2010/12/16 03:42:50 taca Exp $
DIST_SUBDIRS = . include Docs zlib \
cmd-line-utils sql-common scripts \
@@ -1145,7 +1142,7 @@ do_abi_check:
-e '/^#pragma GCC set_debug_pwd/d' \
-e '/^#ident/d' > \
$(top_builddir)/abi_check.out; \
- @DIFF@ -w $$file.pp $(top_builddir)/abi_check.out; \
+ @DIFF@ -I '#include' -w $$file.pp $(top_builddir)/abi_check.out; \
@RM@ $(top_builddir)/abi_check.out; \
done

View file

@ -0,0 +1,22 @@
$NetBSD: patch-al,v 1.3 2011/03/17 13:26:05 adam Exp $
Avoid C++ error (needed for Clang).
--- work/mysql-5.1.56//storage/ndb/include/util/Parser.hpp.orig 2011-03-17 13:15:30.000000000 +0000
+++ work/mysql-5.1.56//storage/ndb/include/util/Parser.hpp
@@ -148,12 +148,12 @@ public:
static const DummyRow* matchArg(Context*, const char *, const DummyRow *);
static bool parseArg(Context*, char*, const DummyRow*, Properties*);
static bool checkMandatory(Context*, const Properties*);
-private:
- const DummyRow * const m_rows;
- class ParseInputStream & input;
bool m_breakOnEmpty;
bool m_breakOnCmd;
bool m_breakOnInvalidArg;
+private:
+ const DummyRow * const m_rows;
+ class ParseInputStream & input;
};
template<class T>