Changes 0.4.3:
- UTF8 internationalization of filenames, volumes and servers - proper uid/gid mapping to enable environments with a common or different user directory - DHX2 UAM from Derrik Pates - fixes to deal with the Apple Airport Extreme quirks - fixes to deal with netatalk quirks - improved status output for debugging - various small bug fixes
This commit is contained in:
parent
06fa469d56
commit
d4130b31c2
10 changed files with 17 additions and 146 deletions
|
@ -1,7 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2007/07/09 19:03:22 agc Exp $
|
||||
#
|
||||
# $NetBSD: Makefile,v 1.2 2007/11/03 13:04:40 adam Exp $
|
||||
|
||||
DISTNAME= afpfs-ng-0.4.1
|
||||
DISTNAME= afpfs-ng-0.4.3a
|
||||
PKGNAME= fuse-${DISTNAME}
|
||||
CATEGORIES= filesystems
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=afpfs-ng/}
|
||||
|
@ -14,7 +13,7 @@ COMMENT= FUSE filesystem for network mounting using AFP
|
|||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= gmake
|
||||
USE_LANGUAGES+= c c++
|
||||
USE_LANGUAGES= c c++
|
||||
|
||||
.include "../../devel/gmp/buildlink3.mk"
|
||||
.include "../../devel/ncurses/buildlink3.mk"
|
||||
|
|
|
@ -1,13 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2007/07/09 19:03:22 agc Exp $
|
||||
$NetBSD: distinfo,v 1.2 2007/11/03 13:04:40 adam Exp $
|
||||
|
||||
SHA1 (afpfs-ng-0.4.1.tar.bz2) = e813aac7b1f7008361c5bd2e1c5e39f3f553f21a
|
||||
RMD160 (afpfs-ng-0.4.1.tar.bz2) = 9e4482bf13d319f31bdd7460f6afa5aa95c6fc2c
|
||||
Size (afpfs-ng-0.4.1.tar.bz2) = 226349 bytes
|
||||
SHA1 (patch-aa) = 0fdb8cd797cf12a4cbec4664372dc54ec0dc65a3
|
||||
SHA1 (patch-ab) = 5becc7816a6fb12ff4491f893075a6b6ab487faf
|
||||
SHA1 (patch-ac) = 7ad8df6d1890399313c03971624530161c45590a
|
||||
SHA1 (patch-ad) = 94b17a236d47cd0b31f1bfd34d0197391555cfc6
|
||||
SHA1 (patch-ae) = d2b711db7dd65465c93e8fdc3d0d31b674672be4
|
||||
SHA1 (patch-af) = 19f6c5e5665bce3db1104ee04d1e5bb6e51f74d1
|
||||
SHA1 (patch-ag) = 2a1cbd0a6a6b323b5f140d4c238d7421b1ecae49
|
||||
SHA1 (patch-ah) = 51b24087031441344e9cdda766c582490bfa100b
|
||||
SHA1 (afpfs-ng-0.4.3a.tar.bz2) = 1384af971f97781433f7268209f3c187c7b3d9e7
|
||||
RMD160 (afpfs-ng-0.4.3a.tar.bz2) = 6ec53de3d1e7e3a237a71c1535401639ac819a67
|
||||
Size (afpfs-ng-0.4.3a.tar.bz2) = 314402 bytes
|
||||
SHA1 (patch-af) = 68b506cf4f21e5bcbf462decb3dc7133c9dceaf5
|
||||
SHA1 (patch-ag) = 2249aec268266ad46c58fed8dfe6a40ca2ebcc0a
|
||||
|
|
|
@ -1,14 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2007/07/09 19:03:22 agc Exp $
|
||||
|
||||
--- commands.c 2007/07/09 17:42:19 1.1
|
||||
+++ commands.c 2007/07/09 17:43:06
|
||||
@@ -6,7 +6,9 @@
|
||||
*/
|
||||
|
||||
#include <fuse.h>
|
||||
+#ifdef __linux__
|
||||
#include <fuse/fuse_opt.h>
|
||||
+#endif
|
||||
#include <stdio.h>
|
||||
#include <string.h>
|
||||
#include <errno.h>
|
|
@ -1,14 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2007/07/09 19:03:22 agc Exp $
|
||||
|
||||
--- daemon.c 2007/07/09 18:25:27 1.1
|
||||
+++ daemon.c 2007/07/09 18:26:36
|
||||
@@ -6,7 +6,9 @@
|
||||
*/
|
||||
|
||||
#include <fuse.h>
|
||||
+#ifdef __linux__
|
||||
#include <fuse/fuse_opt.h>
|
||||
+#endif
|
||||
#include <stdio.h>
|
||||
#include <string.h>
|
||||
#include <errno.h>
|
|
@ -1,14 +0,0 @@
|
|||
$NetBSD: patch-ac,v 1.1.1.1 2007/07/09 19:03:22 agc Exp $
|
||||
|
||||
--- meta.c 2007/07/09 18:25:27 1.1
|
||||
+++ meta.c 2007/07/09 18:26:36
|
||||
@@ -9,7 +9,9 @@
|
||||
*/
|
||||
|
||||
#include <fuse.h>
|
||||
+#ifdef __linux__
|
||||
#include <fuse/fuse_opt.h>
|
||||
+#endif
|
||||
#include <stdio.h>
|
||||
#include <string.h>
|
||||
#include <errno.h>
|
|
@ -1,14 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.1.1.1 2007/07/09 19:03:22 agc Exp $
|
||||
|
||||
--- volinfo.c 2007/07/09 18:25:27 1.1
|
||||
+++ volinfo.c 2007/07/09 18:26:36
|
||||
@@ -10,7 +10,9 @@
|
||||
*/
|
||||
|
||||
#include <fuse.h>
|
||||
+#ifdef __linux__
|
||||
#include <fuse/fuse_opt.h>
|
||||
+#endif
|
||||
#include <stdio.h>
|
||||
#include <string.h>
|
||||
#include <errno.h>
|
|
@ -1,51 +0,0 @@
|
|||
$NetBSD: patch-ae,v 1.1.1.1 2007/07/09 19:03:22 agc Exp $
|
||||
|
||||
--- fuse_int.c 2007/07/09 18:28:21 1.1
|
||||
+++ fuse_int.c 2007/07/09 18:35:16
|
||||
@@ -21,7 +21,11 @@
|
||||
#include <stdio.h>
|
||||
#include <string.h>
|
||||
#include <errno.h>
|
||||
+#ifdef __linux__
|
||||
#include <asm/fcntl.h>
|
||||
+#else
|
||||
+#include <fcntl.h>
|
||||
+#endif
|
||||
|
||||
#include <utime.h>
|
||||
#include <stdlib.h>
|
||||
@@ -270,8 +274,13 @@
|
||||
fp.unixprivs.uid,&stbuf->st_uid,
|
||||
fp.unixprivs.gid,&stbuf->st_gid)) return -EIO;
|
||||
|
||||
+#ifdef __linux__
|
||||
stbuf->st_ctim.tv_sec=fp.creation_date;
|
||||
stbuf->st_mtim.tv_sec=fp.modification_date;
|
||||
+#else
|
||||
+ stbuf->st_ctime=fp.creation_date;
|
||||
+ stbuf->st_mtime=fp.modification_date;
|
||||
+#endif
|
||||
|
||||
if (resource==AFP_RESOURCE_TYPE_PARENT2) {
|
||||
stbuf->st_mode |= S_IFDIR;
|
||||
@@ -890,7 +899,10 @@
|
||||
}
|
||||
}
|
||||
|
||||
- if ((fi->flags & O_LARGEFILE) &&
|
||||
+ if (
|
||||
+#ifdef __linux__
|
||||
+ (fi->flags & O_LARGEFILE) &&
|
||||
+#endif
|
||||
(volume->server->using_version->av_number<30)) {
|
||||
switch(get_directory_entry(volume,fp->basename,dirid,
|
||||
kFPParentDirIDBit|kFPNodeIDBit|
|
||||
@@ -2039,7 +2051,7 @@
|
||||
{
|
||||
global_volume=vol;
|
||||
|
||||
-#if FUSE_VERSION < 26
|
||||
+#if FUSE_USE_VERSION < 26
|
||||
return fuse_main(fuseargc, fuseargv, &afp_oper);
|
||||
#else
|
||||
return fuse_main(fuseargc, fuseargv, &afp_oper,(void *) vol);
|
|
@ -1,17 +1,12 @@
|
|||
$NetBSD: patch-af,v 1.1.1.1 2007/07/09 19:03:22 agc Exp $
|
||||
$NetBSD: patch-af,v 1.2 2007/11/03 13:04:43 adam Exp $
|
||||
|
||||
--- resource.c 2007/07/09 18:36:19 1.1
|
||||
+++ resource.c 2007/07/09 18:37:11
|
||||
@@ -1,7 +1,12 @@
|
||||
--- resource.c.orig 2007-09-04 06:27:41.000000000 +0200
|
||||
+++ resource.c
|
||||
@@ -1,5 +1,7 @@
|
||||
|
||||
#include <strings.h>
|
||||
#include <string.h>
|
||||
+#ifdef __linux__
|
||||
#include <linux/limits.h>
|
||||
+#else
|
||||
+#include <sys/types.h>
|
||||
+#include <sys/param.h>
|
||||
+#endif
|
||||
#include "afp.h"
|
||||
|
||||
#define appledouble ".AppleDouble"
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ag,v 1.1.1.1 2007/07/09 19:03:22 agc Exp $
|
||||
$NetBSD: patch-ag,v 1.2 2007/11/03 13:04:43 adam Exp $
|
||||
|
||||
--- Makefile.in 2007/07/09 18:46:36 1.1
|
||||
+++ Makefile.in 2007/07/09 18:48:15
|
||||
@@ -139,7 +139,7 @@
|
||||
--- Makefile.in.orig 2007-10-08 04:27:06.000000000 +0200
|
||||
+++ Makefile.in
|
||||
@@ -153,7 +153,7 @@ LIBGCRYPT_CONFIG = @LIBGCRYPT_CONFIG@
|
||||
LIBGCRYPT_LIBS = @LIBGCRYPT_LIBS@
|
||||
LIBOBJS = @LIBOBJS@
|
||||
LIBS = @LIBS@
|
||||
|
|
|
@ -1,10 +0,0 @@
|
|||
$NetBSD: patch-ah,v 1.1.1.1 2007/07/09 19:03:22 agc Exp $
|
||||
|
||||
--- client.c 2007/07/09 18:56:20 1.1
|
||||
+++ client.c 2007/07/09 18:56:45
|
||||
@@ -1,4 +1,5 @@
|
||||
#include <sys/types.h>
|
||||
+#include <sys/param.h>
|
||||
#include <sys/socket.h>
|
||||
#include <sys/stat.h>
|
||||
#include <strings.h>
|
Loading…
Reference in a new issue