Add support for DragonFly. While we have sys/statvfs.h, we don't have
all the fields used by fam. It's easier to use the statfs interface for now. Don't explicitly link against libstdc++, it is the job of the C++ compiler to do that.
This commit is contained in:
parent
8922a3d85f
commit
d425cddbb7
3 changed files with 22 additions and 9 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.22 2005/05/07 08:31:15 recht Exp $
|
||||
$NetBSD: distinfo,v 1.23 2005/10/10 22:06:51 joerg Exp $
|
||||
|
||||
SHA1 (fam-2.7.0.tar.gz) = 6c2316f02acf89a41c42ffc3d7fd9cf5eada83a8
|
||||
RMD160 (fam-2.7.0.tar.gz) = 1895b578d6a141c36d5bee4e3fbbc2a298a91430
|
||||
|
@ -18,7 +18,7 @@ SHA1 (patch-al) = e0b4c3ca447f42573def07e8b47209ec6e6ad016
|
|||
SHA1 (patch-am) = 4fa488940675c5283806819288f7674f4634e038
|
||||
SHA1 (patch-an) = 7aa54fb1f90e3b2eb767d41fd842f7f4a0561b81
|
||||
SHA1 (patch-ao) = 161160f121e9338e807bfe0c5df6cf14457fec62
|
||||
SHA1 (patch-ap) = a129d1ad687f5690430001276bba9afa721f80d7
|
||||
SHA1 (patch-ap) = de9e2bf3004556206e53fc60cd8433518a6f774a
|
||||
SHA1 (patch-aq) = a54ba100b779fa13b35c962ba734ee11e093cb28
|
||||
SHA1 (patch-ar) = 37a8fe2e70d4cbc669a0c853b3404d8c0354235a
|
||||
SHA1 (patch-as) = ff23d2425587e08cac1344884d3557c7761adcef
|
||||
|
@ -31,3 +31,4 @@ SHA1 (patch-ay) = 081b4bc7cf25a8e30b3680b6df7599570ea0db86
|
|||
SHA1 (patch-az) = 13901fdef8c13318d585e36820c5e0aa4c28f889
|
||||
SHA1 (patch-ba) = 2f41331994a56eb70364beab70d40ac0bbd1b050
|
||||
SHA1 (patch-bb) = aef31edd9715c8aa0be2f02ebe663bad30e0791a
|
||||
SHA1 (patch-bc) = 6265e9739013a5303aa98173a6792df924c4c964
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: patch-ap,v 1.9 2005/05/07 08:31:16 recht Exp $
|
||||
$NetBSD: patch-ap,v 1.10 2005/10/10 22:06:51 joerg Exp $
|
||||
|
||||
--- src/mntent_compat.c++.orig 2005-05-07 10:22:00.000000000 +0200
|
||||
+++ src/mntent_compat.c++ 2005-05-07 10:26:09.000000000 +0200
|
||||
--- src/mntent_compat.c++.orig 2005-07-24 02:27:46.000000000 +0000
|
||||
+++ src/mntent_compat.c++
|
||||
@@ -0,0 +1,191 @@
|
||||
+/*
|
||||
+ * Copyright (c) 1980, 1989, 1993, 1994
|
||||
|
@ -48,7 +48,7 @@ $NetBSD: patch-ap,v 1.9 2005/05/07 08:31:16 recht Exp $
|
|||
+#include <sys/param.h>
|
||||
+#include <sys/ucred.h>
|
||||
+#include <sys/mount.h>
|
||||
+#if defined(HAVE_SYS_STATVFS_H) && !defined(__APPLE__)
|
||||
+#if defined(HAVE_SYS_STATVFS_H) && !defined(__APPLE__) && !defined(__DragonFly__)
|
||||
+# include <sys/statvfs.h>
|
||||
+#endif
|
||||
+
|
||||
|
@ -144,7 +144,7 @@ $NetBSD: patch-ap,v 1.9 2005/05/07 08:31:16 recht Exp $
|
|||
+}
|
||||
+
|
||||
+static struct mntent *
|
||||
+#if defined(HAVE_SYS_STATVFS_H) && !defined(__APPLE__)
|
||||
+#if defined(HAVE_SYS_STATVFS_H) && !defined(__APPLE__) && !defined(__DragonFly__)
|
||||
+statfs_to_mntent (struct statvfs *mntbuf)
|
||||
+#else
|
||||
+statfs_to_mntent (struct statfs *mntbuf)
|
||||
|
@ -155,7 +155,7 @@ $NetBSD: patch-ap,v 1.9 2005/05/07 08:31:16 recht Exp $
|
|||
+ _mntent.mnt_fsname = mntbuf->f_mntfromname;
|
||||
+ _mntent.mnt_dir = mntbuf->f_mntonname;
|
||||
+ _mntent.mnt_type = mntbuf->f_fstypename;
|
||||
+#if defined(HAVE_SYS_STATVFS_H) && !defined(__APPLE__)
|
||||
+#if defined(HAVE_SYS_STATVFS_H) && !defined(__APPLE__) && !defined(__DragonFly__)
|
||||
+ tmp = flags2opts (mntbuf->f_flag);
|
||||
+#else
|
||||
+ tmp = flags2opts (mntbuf->f_flags);
|
||||
|
@ -175,7 +175,7 @@ $NetBSD: patch-ap,v 1.9 2005/05/07 08:31:16 recht Exp $
|
|||
+struct mntent *
|
||||
+getmntent (FILE *fp)
|
||||
+{
|
||||
+#if defined(HAVE_SYS_STATVFS_H) && !defined(__APPLE__)
|
||||
+#if defined(HAVE_SYS_STATVFS_H) && !defined(__APPLE__) && !defined(__DragonFly__)
|
||||
+ static struct statvfs *mntbuf;
|
||||
+#else
|
||||
+ static struct statfs *mntbuf;
|
||||
|
|
12
sysutils/fam/patches/patch-bc
Normal file
12
sysutils/fam/patches/patch-bc
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-bc,v 1.1 2005/10/10 22:06:51 joerg Exp $
|
||||
|
||||
--- lib/Makefile.in.orig 2005-08-16 20:08:48.000000000 +0000
|
||||
+++ lib/Makefile.in
|
||||
@@ -99,7 +99,6 @@ libfam_la_SOURCES = \
|
||||
|
||||
|
||||
libfam_la_LDFLAGS = -export-symbols fam.sym
|
||||
-libfam_la_LIBADD = -lstdc++
|
||||
|
||||
EXTRA_DIST = fam.sym
|
||||
subdir = lib
|
Loading…
Reference in a new issue