Upgrade to the latest and greatest version (6.3.2) of PostgreSQL.

They told me to say that.

Use addnerd to create the user.
This commit is contained in:
agc 1998-06-10 13:55:34 +00:00
parent 7c2d3bc631
commit d42b222d9f
13 changed files with 145 additions and 396 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.11 1998/06/03 12:43:25 agc Exp $
# $NetBSD: Makefile,v 1.12 1998/06/10 13:55:34 agc Exp $
# FreeBSD Id: Makefile,v 1.22 1997/12/24 01:21:37 alex Exp
DISTNAME= postgresql-6.2.1
DISTNAME= postgresql-6.3.2
CATEGORIES= databases
MASTER_SITES= ftp://ftp.PostgreSQL.org/pub/ \
ftp://ftp.jaist.ac.jp/pub/dbms/postgres95/
@ -10,26 +10,28 @@ MAINTAINER= packages@netbsd.org
DEPENDS+= tk-8.0p2:../../x11/tk80
DEPENDS+= tcl-8.0p2:../../lang/tcl80
DEPENDS+= addnerd-1.5:../../sysutils/addnerd
NO_PACKAGE= "Requires pgsql uid"
WRKSRC= ${WRKDIR}/${DISTNAME}/src
ONLY_FOR_ARCHS= i386
PGUSER?= pgsql
PGGROUP?= ingres
USE_GMAKE= YES
USE_PERL5= yes
USE_GMAKE= yes
MAKEFILE= GNUmakefile
MAKE_ENV+= USE_TCL=true
HAS_CONFIGURE= YES
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX}/pgsql \
--enable-locale \
--with-tcl \
--with-includes=${PREFIX}/include \
--with-libs=${PREFIX}/lib \
--with-template=`uname -s | ${TR} '[A-Z]' '[a-z]'`
MAN1= cleardbdir.1 createdb.1 createuser.1 destroydb.1 \
destroyuser.1 initdb.1 ipcclean.1 monitor.1 pg_dump.1 \
destroyuser.1 initdb.1 ipcclean.1 pg_dump.1 \
pg_dumpall.1 pg_passwd.1 pgintro.1 postgres.1 \
postmaster.1 psql.1
postmaster.1 psql.1 initlocation.1 ecpg.1
MAN3= catalogs.3 large_objects.3 libpq.3 oracle_compat.3 pgbuiltin.3
MAN5= bki.5 page.5 pg_hba.conf.5
MANL= abort.l alter_table.l begin.l close.l cluster.l \
@ -41,9 +43,10 @@ MANL= abort.l alter_table.l begin.l close.l cluster.l \
drop_database.l drop_function.l drop_index.l drop_operator.l \
drop_rule.l drop_sequence.l drop_table.l drop_trigger.l \
drop_type.l drop_view.l end.l explain.l fetch.l grant.l \
insert.l listen.l load.l move.l notify.l purge.l rename.l \
insert.l listen.l load.l move.l notify.l \
reset.l revoke.l rollback.l select.l set.l show.l sql.l \
update.l vacuum.l
update.l vacuum.l lock.l drop_user.l drop_language.l \
create_user.l create_language.l alter_user.l
MANPREFIX= ${PREFIX}/pgsql
@ -59,8 +62,8 @@ pre-install:
.if defined(PACKAGE_BUILDING)
${RM} -rf ${PREFIX}/pgsql
.endif
@ ${MKDIR} ${PREFIX}/pgsql
@ ${SETENV} ${MAKE_ENV} perl ${SCRIPTDIR}/createuser ${PGUSER}
@${MKDIR} ${PREFIX}/pgsql
@${SETENV} ${MAKE_ENV} addnerd -g ${PGGROUP} ${PGUSER}
post-install:
@ if [ ! -f ${PREFIX}/pgsql/.profile ]; then \
@ -85,14 +88,14 @@ post-install:
${ECHO} "#export TZ" \
>> ${PREFIX}/pgsql/.profile; \
fi
@/usr/sbin/chown -R ${PGUSER}:${PGUSER} ${PREFIX}/pgsql
@/usr/sbin/chown -R ${PGUSER}:${PGGROUP} ${PREFIX}/pgsql
@${ECHO} 'Initializing PostgreSQL Databases - this may take a few minutes...'
@${LDCONFIG} -m ${PREFIX}/pgsql/lib || ${TRUE}
@${ECHO} '${PREFIX}/pgsql/bin/initdb --pglib=${PREFIX}/pgsql/lib --pgdata=${PREFIX}/pgsql/data' | su -l ${PGUSER}
@${ECHO} '${SETENV} PATH=${PREFIX}/pgsql/bin:$$PATH ${PREFIX}/pgsql/bin/initdb --pglib=${PREFIX}/pgsql/lib --pgdata=${PREFIX}/pgsql/data' | su -l ${PGUSER}
@${SED} -e "s=!!PREFIX!!=${PREFIX}=g" < ${FILESDIR}/pgsql.sh.tmpl \
> ${PREFIX}/etc/rc.d/pgsql.sh
@/bin/chmod 554 ${PREFIX}/etc/rc.d/pgsql.sh
@/usr/sbin/chown root.${PGUSER} ${PREFIX}/etc/rc.d/pgsql.sh
@/usr/sbin/chown root.${PGGROUP} ${PREFIX}/etc/rc.d/pgsql.sh
@${INSTALL_DATA} ${FILESDIR}/post-install-notes ${PREFIX}/pgsql
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/pgsql

View file

@ -1 +1 @@
MD5 (postgresql-6.2.1.tar.gz) = bd606dcab6b09a3a3d276d88b504a1d3
MD5 (postgresql-6.3.2.tar.gz) = 8902842461c9a42854ba9883bee56a4c

View file

@ -1,6 +1,6 @@
--- bin/initdb/initdb.sh.orig Wed Apr 2 07:09:13 1997
+++ bin/initdb/initdb.sh Wed Apr 2 07:09:33 1997
@@ -289,7 +289,7 @@
--- bin/initdb/initdb.orig Mon Apr 6 02:05:52 1998
+++ bin/initdb/initdb Wed Jun 10 13:13:18 1998
@@ -286,7 +286,7 @@
#----------------------------------------------------------------------------
if [ $template_only -eq 0 ]; then
@ -9,11 +9,3 @@
echo "Running: postgres $BACKENDARGS template1"
cat $GLOBAL \
@@ -346,6 +346,5 @@
if [ $debug -eq 0 ]; then
echo "vacuuming template1"
- echo "vacuum" | postgres -F -Q -D$PGDATA template1 2>&1 > /dev/null |\
- grep -v "^DEBUG:"
+ echo "vacuum" | postgres -o /dev/null -F -Q -D$PGDATA template1 > /dev/null
fi

View file

@ -1,20 +0,0 @@
--- configure.orig Sat Jun 14 20:05:55 1997
+++ configure Sat Jun 14 20:06:34 1997
@@ -685,7 +685,7 @@
echo "enter 'none' or new directories to override default"
echo ""
$ECHO_N "Additional directories to search for include files { $SRCH_INC }: $ECHO_C"
-read a
+a=$SRCH_INC
if test "$a." = "none."
then
SRCH_INC=
@@ -702,7 +702,7 @@
echo "- setting CPPFLAGS=$CPPFLAGS"
$ECHO_N "Additional directories to search for library files { $SRCH_LIB }: $ECHO_C"
-read a
+a=$SRCH_LIB
if test "$a." = "none."
then
SRCH_LIB=

View file

@ -1,29 +0,0 @@
--- template/freebsd.orig Sat Jun 14 20:12:51 1997
+++ template/freebsd Sat Jun 14 20:13:06 1997
@@ -1,9 +1,9 @@
AROPT:cq
SHARED_LIB:-fpic -DPIC
-CFLAGS:-O2 -m486 -pipe
+CFLAGS:-pipe -O2
SRCH_INC:/usr/local/include
SRCH_LIB:/usr/local/lib
-USE_LOCALE:no
+USE_LOCALE:yes
DLSUFFIX:.so
YFLAGS:-d
YACC:bison -y
--- template/netbsd 1998/02/16 15:09:26 1.1
+++ template/netbsd 1998/02/16 15:09:57
@@ -1,9 +1,9 @@
AROPT:cq
SHARED_LIB:-fpic -DPIC
CFLAGS:-O2 -pipe
-SRCH_INC:/usr/local/include
-SRCH_LIB:/usr/local/lib
-USE_LOCALE:no
+SRCH_INC:${PREFIX}/include
+SRCH_LIB:${PREFIX}/lib
+USE_LOCALE:yes
DLSUFFIX:.so
YFLAGS:-d
YACC:

View file

@ -1,26 +0,0 @@
--- Makefile.global.in.orig Sat Oct 4 23:21:46 1997
+++ Makefile.global.in Sat Oct 4 23:27:22 1997
@@ -162,15 +162,15 @@
# USE_TCL= true
# customize these to your site's needs
#
-TCL_INCDIR= /home/tools/include
-TCL_LIBDIR= /home/tools/lib
-TCL_LIB= -ltcl7.5
-TK_INCDIR= /home/tools/include
-TK_LIBDIR= /home/tools/lib
-TK_LIB= -ltk4.1
+TCL_INCDIR= ${PREFIX}/include/tcl8.0
+TCL_LIBDIR= ${PREFIX}/lib
+TCL_LIB= -ltcl80
+TK_INCDIR= ${PREFIX}/include/tk8.0
+TK_LIBDIR= ${PREFIX}/lib
+TK_LIB= -ltk80
-X11_INCDIR= /usr/include
-X11_LIBDIR= /usr/lib
+X11_INCDIR= ${X11BASE}/include
+X11_LIBDIR= ${X11BASE}/lib
X11_LIB= -lX11 @SOCKET_LIB@ @NSL_LIB@

View file

@ -1,65 +0,0 @@
--- interfaces/libpgtcl/Makefile.orig Mon Sep 29 23:02:46 1997
+++ interfaces/libpgtcl/Makefile Sun Oct 5 02:12:00 1997
@@ -39,6 +39,14 @@
endif
endif
+ifeq ($(PORTNAME), BSD44_derived)
+ CFLAGS += $(CFLAGS_SL)
+ shlib := libpgtcl.so.1.0
+ install-shlib-dep := install-shlib
+ LDFLAGS_SL = -x -Bshareable -Bforcearchive
+ LDFLAGS += -L $(SRCDIR)/interfaces/libpq -lpq
+endif
+
ifeq ($(PORTNAME), i386_solaris)
CFLAGS+= -fPIC
endif
@@ -56,10 +64,9 @@
endif
$(RANLIB) libpgtcl.a
-libpgtcl.so.1: $(OBJS)
- $(CC) $(LDFLAGS) -shared $(OBJS) -o libpgtcl.so.1
- rm -f libpgtcl.so
- ln -s libpgtcl.so.1 libpgtcl.so
+$(shlib): $(OBJS)
+ $(LD) $(LDFLAGS_SL) -o $@ $(OBJS)
+ ln -sf libpgtcl.so.1.0 libpgtcl.so
.PHONY: beforeinstall-headers install-headers
.PHONY: install install-libpgtcl
@@ -75,11 +82,11 @@
install-libpgtcl: libpgtcl.a
$(INSTALL) $(INSTL_LIB_OPTS) libpgtcl.a $(DESTDIR)$(LIBDIR)/libpgtcl.a
-install-shlib: libpgtcl.so.1
- $(INSTALL) $(INSTL_LIB_OPTS) libpgtcl.so.1 \
- $(DESTDIR)$(LIBDIR)/libpgtcl.so.1
+install-shlib: libpgtcl.so.1.0
+ $(INSTALL) $(INSTL_LIB_OPTS) libpgtcl.so.1.0 \
+ $(DESTDIR)$(LIBDIR)/libpgtcl.so.1.0
rm -f $(DESTDIR)$(LIBDIR)/libpgtcl.so
- ln -s libpgtcl.so.1 $(DESTDIR)$(LIBDIR)/libpgtcl.so
+ ln -s libpgtcl.so.1.0 $(DESTDIR)$(LIBDIR)/libpgtcl.so
.PHONY: clean
clean:
--- bin/Makefile 1998/02/18 15:50:27 1.1
+++ bin/Makefile 1998/02/18 15:50:40
@@ -36,4 +36,5 @@
#
ifeq ($(USE_TCL), true)
$(MAKE) -C pgtclsh $@
+ $(MAKE) -C pgaccess $@
endif
--- /dev/null Wed Feb 18 15:53:20 1998
+++ bin/pgaccess/Makefile Wed Feb 18 16:12:13 1998
@@ -0,0 +1,7 @@
+BIN=${PREFIX}/pgsql/bin/pgaccess
+
+all: ;
+
+install:
+ sed -e 's|^#!/usr/bin/wish|#! '${PREFIX}'/pgsql/bin/pgtksh -f|' < pgaccess.tcl > ${BIN}
+ chmod 755 ${BIN}

View file

@ -1,11 +0,0 @@
--- interfaces/libpq/Makefile.orig Sun Oct 5 02:00:11 1997
+++ interfaces/libpq/Makefile Sun Oct 5 02:00:31 1997
@@ -151,7 +151,7 @@
install-shlib: $(shlib)
$(INSTALL) $(INSTL_LIB_OPTS) $(shlib) $(DESTDIR)$(LIBDIR)/$(shlib)
rm -f $(DESTDIR)$(LIBDIR)/libpq.so
- ln -s libpq.so.1 $(DESTDIR)$(LIBDIR)/libpq.so
+ ln -s libpq.so.1.0 $(DESTDIR)$(LIBDIR)/libpq.so
depend dep:
$(CC) -MM $(INCLUDE_OPT) *.c >depend

View file

@ -1,11 +0,0 @@
--- GNUmakefile.in.orig Wed Oct 8 22:30:13 1997
+++ GNUmakefile.in Wed Oct 8 22:31:14 1997
@@ -65,7 +65,7 @@
ifneq ($(wildcard man), )
$(MAKE) -C man install
endif
- more -e ../register.txt
+ cat ../register.txt
clean:
@if test $(PORTNAME) = UNDEFINED; then \

View file

@ -1,27 +0,0 @@
--- backend/libpq/password.c.orig Sat Sep 13 07:20:14 1997
+++ backend/libpq/password.c Sat Jan 31 17:02:42 1998
@@ -24,7 +24,7 @@
char *p,
*test_user,
*test_pw;
- char salt[3];
+ char salt[10];
find_hba_entry(DataDir, port->raddr.sin_addr, database,
&host_ok, &userauth, pw_file_name, true);
@@ -90,7 +90,14 @@
if (test_pw[strlen(test_pw) - 1] == '\n')
test_pw[strlen(test_pw) - 1] = '\0';
- strNcpy(salt, test_pw, 2);
+ if (strncmp(test_pw, "$1$", 3)) {
+ /* DES */
+ strNcpy(salt, test_pw, 2);
+ }
+ else {
+ /* MD5 */
+ strncpy(salt, test_pw, 9);
+ }
if (strcmp(user, test_user) == 0)
{

View file

@ -1,69 +0,0 @@
--- bin/pg_passwd/pg_passwd.c.orig Sat Jan 31 19:09:26 1998
+++ bin/pg_passwd/pg_passwd.c Sat Jan 31 19:15:43 1998
@@ -23,12 +23,16 @@
#endif
+#ifndef _POSIX_SOURCE
+# define _PASSWORD_LEN 128 /* max length, not containing NULL */
+#endif
+
char *comname;
void usage(FILE *stream);
void read_pwd_file(char *filename);
void write_pwd_file(char *filename, char *bkname);
-void encrypt_pwd(char key[9], char salt[3], char passwd[14]);
-int check_pwd(char key[9], char passwd[14]);
+void encrypt_pwd(char key[9], char salt[3], char passwd[_PASSWORD_LEN+1]);
+int check_pwd(char key[9], char passwd[_PASSWORD_LEN+1]);
void prompt_for_username(char *username);
void prompt_for_password(char *prompt, char *password);
@@ -148,7 +152,7 @@
if (q != NULL)
*(q++) = '\0';
- if (strlen(p) != 13)
+ if (strlen(p) > _PASSWORD_LEN)
{
fprintf(stderr, "WARNING: %s: line %d: illegal password length.\n",
filename, npwds + 1);
@@ -208,7 +212,7 @@
}
void
-encrypt_pwd(char key[9], char salt[3], char passwd[14])
+encrypt_pwd(char key[9], char salt[3], char passwd[_PASSWORD_LEN+1])
{
int n;
@@ -242,9 +246,9 @@
}
int
-check_pwd(char key[9], char passwd[14])
+check_pwd(char key[9], char passwd[_PASSWORD_LEN+1])
{
- char shouldbe[14];
+ char shouldbe[_PASSWORD_LEN+1];
char salt[3];
salt[0] = passwd[0];
@@ -252,7 +256,7 @@
salt[2] = '\0';
encrypt_pwd(key, salt, shouldbe);
- return strncmp(shouldbe, passwd, 13) == 0 ? 1 : 0;
+ return strncmp(shouldbe, passwd, _PASSWORD_LEN) == 0 ? 1 : 0;
}
void
@@ -326,7 +330,7 @@
char salt[3];
char key[9],
key2[9];
- char e_passwd[14];
+ char e_passwd[_PASSWORD_LEN+1];
int i;
comname = argv[0];

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.4 1998/05/09 18:32:57 hubertf Exp $
@comment $NetBSD: PLIST,v 1.5 1998/06/10 13:55:35 agc Exp $
etc/rc.d/pgsql.sh
pgsql/.profile
pgsql/bin/cleardbdir
@ -6,7 +6,10 @@ pgsql/bin/createdb
pgsql/bin/createuser
pgsql/bin/destroydb
pgsql/bin/destroyuser
pgsql/bin/ecpg
pgsql/bin/initdb
pgsql/bin/initlocation
pgsql/bin/ipcclean
pgsql/bin/pg_dump
pgsql/bin/pg_dumpall
pgsql/bin/pg_id
@ -24,15 +27,9 @@ pgsql/data/base/template1/pg_aggregate
pgsql/data/base/template1/pg_am
pgsql/data/base/template1/pg_amop
pgsql/data/base/template1/pg_amproc
pgsql/data/base/template1/pg_attnameind
pgsql/data/base/template1/pg_attnumind
pgsql/data/base/template1/pg_attrdef
pgsql/data/base/template1/pg_attrdefind
pgsql/data/base/template1/pg_attrelidind
pgsql/data/base/template1/pg_attribute
pgsql/data/base/template1/pg_class
pgsql/data/base/template1/pg_classnameind
pgsql/data/base/template1/pg_classoidind
pgsql/data/base/template1/pg_index
pgsql/data/base/template1/pg_inheritproc
pgsql/data/base/template1/pg_inherits
@ -44,35 +41,41 @@ pgsql/data/base/template1/pg_opclass
pgsql/data/base/template1/pg_operator
pgsql/data/base/template1/pg_parg
pgsql/data/base/template1/pg_proc
pgsql/data/base/template1/pg_procidind
pgsql/data/base/template1/pg_procnameind
pgsql/data/base/template1/pg_procsrcind
pgsql/data/base/template1/pg_relcheck
pgsql/data/base/template1/pg_relcheckind
pgsql/data/base/template1/pg_rewrite
pgsql/data/base/template1/pg_statistic
pgsql/data/base/template1/pg_trigger
pgsql/data/base/template1/pg_trigrelidind
pgsql/data/base/template1/pg_type
pgsql/data/base/template1/pg_typeidind
pgsql/data/base/template1/pg_typenameind
pgsql/data/base/template1/pg_version
pgsql/data/base/template1/pg_description
pgsql/data/base/template1/pg_attribute_relid_attnam_index
pgsql/data/base/template1/pg_proc_oid_index
pgsql/data/base/template1/pg_attribute_relid_attnum_index
pgsql/data/base/template1/pg_attribute_attrelid_index
pgsql/data/base/template1/pg_proc_proname_index
pgsql/data/base/template1/pg_proc_prosrc_index
pgsql/data/base/template1/pg_type_oid_index
pgsql/data/base/template1/pg_type_typname_index
pgsql/data/base/template1/pg_class_oid_index
pgsql/data/base/template1/pg_class_relname_index
pgsql/data/base/template1/pg_attrdef_adrelid_index
pgsql/data/base/template1/pg_relcheck_rcrelid_index
pgsql/data/base/template1/pg_trigger_tgrelid_index
pgsql/data/base/template1/pg_description_objoid_index
pgsql/data/base/template1/pg_user
pgsql/data/pg_shadow
pgsql/data/pg_pwd
pgsql/data/pg_database
pgsql/data/pg_defaults
pgsql/data/pg_demon
pgsql/data/pg_geqo.sample
pgsql/data/pg_group
pgsql/data/pg_hba.conf
pgsql/data/pg_hosts
pgsql/data/pg_log
pgsql/data/pg_magic
pgsql/data/pg_server
pgsql/data/pg_time
pgsql/data/pg_user
pgsql/data/pg_variable
pgsql/include/access/attnum.h
pgsql/include/c.h
pgsql/include/config.h
pgsql/include/commands/trigger.h
pgsql/include/executor/spi.h
pgsql/include/fmgr.h
pgsql/include/lib/dllist.h
@unexec rm -f %D/pgsql/include/libpgtcl.h
@ -85,16 +88,24 @@ pgsql/include/postgres_ext.h
pgsql/include/utils/elog.h
pgsql/include/utils/geo_decls.h
pgsql/include/utils/palloc.h
pgsql/include/ecpglib.h
pgsql/include/ecpgtype.h
pgsql/include/sqlca.h
pgsql/lib/global1.bki.source
@unexec rm -f %D/pgsql/lib/libpgtcl.a
@unexec rm -f %D/pgsql/lib/libpgtcl.so
@unexec rm -f %D/pgsql/lib/libpgtcl.so.1.0
pgsql/lib/libpq.a
pgsql/lib/libpq.so
pgsql/lib/libpq.so.1.0
pgsql/lib/local1_template1.bki.source
pgsql/lib/pg_geqo.sample
pgsql/lib/pg_hba.conf.sample
pgsql/lib/global1.description
pgsql/lib/local1_template1.description
pgsql/lib/libpq.so.1.1
pgsql/lib/libecpg.so.1.1
pgsql/lib/libecpg.so
pgsql/lib/libecpg.a
pgsql/man/man1/cleardbdir.1.gz
pgsql/man/man1/createdb.1.gz
pgsql/man/man1/createuser.1.gz
@ -102,7 +113,6 @@ pgsql/man/man1/destroydb.1.gz
pgsql/man/man1/destroyuser.1.gz
pgsql/man/man1/initdb.1.gz
pgsql/man/man1/ipcclean.1.gz
pgsql/man/man1/monitor.1.gz
pgsql/man/man1/pg_dump.1.gz
pgsql/man/man1/pg_dumpall.1.gz
pgsql/man/man1/pg_passwd.1.gz
@ -160,8 +170,6 @@ pgsql/man/manl/listen.l.gz
pgsql/man/manl/load.l.gz
pgsql/man/manl/move.l.gz
pgsql/man/manl/notify.l.gz
pgsql/man/manl/purge.l.gz
pgsql/man/manl/rename.l.gz
pgsql/man/manl/reset.l.gz
pgsql/man/manl/revoke.l.gz
pgsql/man/manl/rollback.l.gz
@ -171,6 +179,14 @@ pgsql/man/manl/show.l.gz
pgsql/man/manl/sql.l.gz
pgsql/man/manl/update.l.gz
pgsql/man/manl/vacuum.l.gz
pgsql/man/man1/initlocation.1
pgsql/man/man1/ecpg.1
pgsql/man/manl/lock.l
pgsql/man/manl/drop_user.l
pgsql/man/manl/drop_language.l
pgsql/man/manl/create_user.l
pgsql/man/manl/create_language.l
pgsql/man/manl/alter_user.l
pgsql/post-install-notes
share/doc/pgsql/FAQ
share/doc/pgsql/FAQ_Irix
@ -181,44 +197,98 @@ share/doc/pgsql/README.support
share/doc/pgsql/TODO
share/doc/pgsql/TODO.GEQO
share/doc/pgsql/bug.template
share/doc/pgsql/libpgtcl.doc
share/doc/pgsql/manual/admin.html
share/doc/pgsql/manual/advanced.html
share/doc/pgsql/manual/appenda.html
share/doc/pgsql/manual/architec.html
share/doc/pgsql/manual/copy.html
share/doc/pgsql/manual/extend.html
share/doc/pgsql/manual/figure01.gif
share/doc/pgsql/manual/figure02.gif
share/doc/pgsql/manual/figure03.gif
share/doc/pgsql/manual/intro.html
share/doc/pgsql/manual/libpq.html
share/doc/pgsql/manual/lobj.html
share/doc/pgsql/manual/pg95user.html
share/doc/pgsql/manual/query.html
share/doc/pgsql/manual/refs.html
share/doc/pgsql/manual/rules.html
share/doc/pgsql/manual/start.html
share/doc/pgsql/manual/xaggr.html
share/doc/pgsql/manual/xfunc.html
share/doc/pgsql/manual/xindex.html
share/doc/pgsql/manual/xoper.html
share/doc/pgsql/manual/xtypes.html
share/doc/pgsql/spi.txt
share/doc/pgsql/trigger.txt
share/doc/pgsql/userguide.ps
share/doc/pgsql/FAQ_FreeBSD
share/doc/pgsql/Makefile
share/doc/pgsql/README.mb
share/doc/pgsql/README.mb.jp
share/doc/pgsql/admin.ps.gz
share/doc/pgsql/admin.tar.gz
share/doc/pgsql/postgres.tar.gz
share/doc/pgsql/programmer.ps.gz
share/doc/pgsql/programmer.tar.gz
share/doc/pgsql/tutorial.ps.gz
share/doc/pgsql/tutorial.tar.gz
share/doc/pgsql/user.ps.gz
share/doc/pgsql/user.tar.gz
share/doc/pgsql/src/Makefile
share/doc/pgsql/src/graphics/
share/doc/pgsql/src/graphics/catalogs.gif
share/doc/pgsql/src/graphics/clientserver.ag
share/doc/pgsql/src/graphics/clientserver.gif
share/doc/pgsql/src/graphics/connections.ag
share/doc/pgsql/src/graphics/connections.gif
share/doc/pgsql/src/graphics/layout.ag
share/doc/pgsql/src/graphics/layout.gif
share/doc/pgsql/src/sgml/Makefile
share/doc/pgsql/src/sgml/admin.sgml
share/doc/pgsql/src/sgml/advanced.sgml
share/doc/pgsql/src/sgml/arch-dev.sgml
share/doc/pgsql/src/sgml/arch-pg.sgml
share/doc/pgsql/src/sgml/arch.sgml
share/doc/pgsql/src/sgml/array.sgml
share/doc/pgsql/src/sgml/biblio.sgml
share/doc/pgsql/src/sgml/compiler.sgml
share/doc/pgsql/src/sgml/contacts.sgml
share/doc/pgsql/src/sgml/datatype.sgml
share/doc/pgsql/src/sgml/dfunc.sgml
share/doc/pgsql/src/sgml/docguide.sgml
share/doc/pgsql/src/sgml/ecpg.sgml
share/doc/pgsql/src/sgml/environ.sgml
share/doc/pgsql/src/sgml/extend.sgml
share/doc/pgsql/src/sgml/func-ref.sgml
share/doc/pgsql/src/sgml/geqo.sgml
share/doc/pgsql/src/sgml/gist.sgml
share/doc/pgsql/src/sgml/inherit.sgml
share/doc/pgsql/src/sgml/install.sgml
share/doc/pgsql/src/sgml/intro-pg.sgml
share/doc/pgsql/src/sgml/intro.sgml
share/doc/pgsql/src/sgml/jdbc.sgml
share/doc/pgsql/src/sgml/libpgtcl.sgml
share/doc/pgsql/src/sgml/libpq.sgml
share/doc/pgsql/src/sgml/lobj.sgml
share/doc/pgsql/src/sgml/manage.sgml
share/doc/pgsql/src/sgml/odbc.sgml
share/doc/pgsql/src/sgml/pgaccess.sgml
share/doc/pgsql/src/sgml/ports.sgml
share/doc/pgsql/src/sgml/postgres.sgml
share/doc/pgsql/src/sgml/programmer.sgml
share/doc/pgsql/src/sgml/protocol.sgml
share/doc/pgsql/src/sgml/psql.sgml
share/doc/pgsql/src/sgml/query-ug.sgml
share/doc/pgsql/src/sgml/query.sgml
share/doc/pgsql/src/sgml/recovery.sgml
share/doc/pgsql/src/sgml/regress.sgml
share/doc/pgsql/src/sgml/release.sgml
share/doc/pgsql/src/sgml/rules.sgml
share/doc/pgsql/src/sgml/spi.sgml
share/doc/pgsql/src/sgml/start-ag.sgml
share/doc/pgsql/src/sgml/start.sgml
share/doc/pgsql/src/sgml/storage.sgml
share/doc/pgsql/src/sgml/trigger.sgml
share/doc/pgsql/src/sgml/tutorial.sgml
share/doc/pgsql/src/sgml/user.sgml
share/doc/pgsql/src/sgml/xaggr.sgml
share/doc/pgsql/src/sgml/xfunc.sgml
share/doc/pgsql/src/sgml/xindex.sgml
share/doc/pgsql/src/sgml/xoper.sgml
share/doc/pgsql/src/sgml/xtypes.sgml
@unexec /sbin/ldconfig || /usr/bin/true
@dirrm share/doc/pgsql/manual
@dirrm share/doc/pgsql/src/graphics
@dirrm share/doc/pgsql/src/sgml
@dirrm share/doc/pgsql/src
@dirrm share/doc/pgsql
@dirrm pgsql/bin
@dirrm pgsql/data/base/template1
@dirrm pgsql/data/base
@dirrm pgsql/data
@dirrm pgsql/include/access
@dirrm pgsql/include/commands
@dirrm pgsql/include/executor
@dirrm pgsql/include/include
@dirrm pgsql/include/lib
@dirrm pgsql/include/libpq
@dirrm pgsql/include/port/BSD44_derived
@dirrm pgsql/include/port/bsd
@dirrm pgsql/include/port
@dirrm pgsql/include/utils
@dirrm pgsql/include

View file

@ -1,58 +0,0 @@
#!/usr/bin/perl
#
eval '(exit $?0)' && eval 'exec /usr/bin/perl -S $0 ${1+"$@"}'
& eval 'exec /usr/bin/perl -S $0 $argv:q'
if 0;
if( $> ) {
print "\nYou must be root to run this step!\n\n";
exit 1;
}
@ARGV = "pgsql" unless @ARGV;
$pgsql = $ARGV[0];
if( getpwnam( $pgsql ) ) {
( $null, $null, $pgUID ) = getpwnam( $pgsql );
$addname = 0;
} else {
$pgUID = 70;
while( getpwuid( $pgUID ) ) {
$pgUID++;
}
$addname = 1;
}
if( getgrnam( $pgsql ) ) {
( $null, $null, $pgGID ) = getgrnam( $pgsql );
} else {
$pgGID = 70;
while( getgrgid( $pgGID ) ) {
$pgGID++;
}
&append_file( "/etc/group", "${pgsql}:*:${pgGID}:" );
}
print "pgsql user $pgsql using uid $pgUID\n";
print "pgsql user $pgsql using gid $pgGID\n";
if ($addname) {
system( "/usr/bin/chpass -l -a \"$pgsql:*************:${pgUID}:${pgGID}::0:0:PostgreSQL pseudo-user:$ENV{'PREFIX'}/$pgsql:/bin/sh\"" );
}
sub append_file {
local($file,@list) = @_;
local($LOCK_EX) = 2;
local($LOCK_NB) = 4;
local($LOCK_UN) = 8;
open(F, ">> $file") || die "$file: $!\n";
while( ! flock( F, $LOCK_EX | $LOCK_NB ) ) {
exit 1;
}
print F join( "\n", @list) . "\n";
close F;
flock( F, $LOCK_UN );
}