seamonkey: fix build
There is one issue due to newer rust not allowing RUSTC_BOOTSTRAP any longer, fixed by setting magic variables in the build environment, and another issue where something (not sure what) defines "CLEANUP" to nothing. Add a patch that works around he latter.
This commit is contained in:
parent
d6a8c9ec98
commit
d43e2b2fde
4 changed files with 27 additions and 5 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.235 2021/05/24 19:55:57 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.236 2021/06/02 15:39:55 wiz Exp $
|
||||
|
||||
DISTNAME= seamonkey-${SM_VER}.source
|
||||
PKGNAME= seamonkey-${SM_VER:S/b/beta/}
|
||||
|
@ -16,7 +16,7 @@ LICENSE= mpl-2.0
|
|||
BUILD_DEPENDS+= nasm>=2.13:../../devel/nasm
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME:S/.source//}
|
||||
MOZILLA_DIR=
|
||||
MOZILLA_DIR=
|
||||
PLIST_SRC+= ${PLIST_SRC_DFLT}
|
||||
USE_LANGUAGES+= c c++
|
||||
USE_TOOLS+= unzip pax
|
||||
|
@ -77,6 +77,11 @@ INSTALLATION_DIRS+= lib/seamonkey/extensions
|
|||
INSTALLATION_DIRS+= share/applications
|
||||
INSTALLATION_DIRS+= share/icons/hicolor/32x32/apps
|
||||
|
||||
# error: Cannot set `RUSTC_BOOTSTRAP=1` from build script of `packed_simd v0.3.4 (https://github.com/hsivonen/packed_simd?rev=0917fe780032a6bbb23d71be545f9c1834128d75#0917fe78)`.
|
||||
# note: Crates cannot set `RUSTC_BOOTSTRAP` themselves, as doing so would subvert the stability guarantees of Rust for your project.
|
||||
# help: If you're sure you want to do this in your project, set the environment variable `RUSTC_BOOTSTRAP=packed_simd` before running cargo instead.
|
||||
MAKE_ENV+= RUSTC_BOOTSTRAP="packed_simd,encoding_rs"
|
||||
|
||||
post-extract:
|
||||
${CP} ${FILESDIR}/cubeb_sun.c ${WRKSRC}/${MOZILLA_DIR}/media/libcubeb/src
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.67 2021/03/23 13:03:16 ryoon Exp $
|
||||
@comment $NetBSD: PLIST,v 1.68 2021/06/02 15:39:55 wiz Exp $
|
||||
bin/seamonkey
|
||||
lib/seamonkey/application.ini
|
||||
lib/seamonkey/blocklist.xml
|
||||
|
@ -3683,6 +3683,7 @@ lib/seamonkey/components/NetworkGeolocationProvider.js
|
|||
lib/seamonkey/components/NotificationStorage.js
|
||||
lib/seamonkey/components/PageIconProtocolHandler.js
|
||||
lib/seamonkey/components/PageThumbsProtocol.js
|
||||
${PLIST.webrtc}lib/seamonkey/components/PeerConnection.js
|
||||
lib/seamonkey/components/PlacesCategoriesStarter.js
|
||||
lib/seamonkey/components/PresentationControlService.js
|
||||
lib/seamonkey/components/ProcessSelector.js
|
||||
|
@ -4444,7 +4445,6 @@ lib/seamonkey/modules/lz4_internal.js
|
|||
lib/seamonkey/modules/mailServices.js
|
||||
lib/seamonkey/modules/mailnewsMigrator.js
|
||||
lib/seamonkey/modules/media/IdpSandbox.jsm
|
||||
${PLIST.webrtc}lib/seamonkey/components/PeerConnection.js
|
||||
lib/seamonkey/modules/media/PeerConnectionIdp.jsm
|
||||
lib/seamonkey/modules/media/RTCStatsReport.jsm
|
||||
lib/seamonkey/modules/microformat-shiv.js
|
||||
|
|
|
@ -1,10 +1,11 @@
|
|||
$NetBSD: distinfo,v 1.170 2021/02/08 12:26:20 ryoon Exp $
|
||||
$NetBSD: distinfo,v 1.171 2021/06/02 15:39:55 wiz Exp $
|
||||
|
||||
SHA1 (seamonkey-2.53.6.source.tar.xz) = ff5cb7701acc7487d094c8d04ecabe0aa486eae9
|
||||
RMD160 (seamonkey-2.53.6.source.tar.xz) = fdedcb9419ff598ad9e18e94115ed9d5e3624116
|
||||
SHA512 (seamonkey-2.53.6.source.tar.xz) = 1854862b5b4781e21cb14bdb6be95e219195459202f55cde3800594174307a9ff23e8b29304494489e947a2749765cdb75ca56633f2fcff8afaf277da972a573
|
||||
Size (seamonkey-2.53.6.source.tar.xz) = 283905464 bytes
|
||||
SHA1 (patch-build_moz.configure_rust.configure) = 38ba5e8a0e41352afc4e767c25388c3c772b0457
|
||||
SHA1 (patch-dom_indexedDB_IDBTransaction.h) = 7882f1264889d5f17af0bafa68bfa5aff5b57634
|
||||
SHA1 (patch-ldap_c-sdk_include_portable.h) = b742b070a45507678f592428110477e484c52659
|
||||
SHA1 (patch-mailnews_base_search_src_nsMsgSearchTerm.cpp) = 5a5890c5347cdb1a0899eebe4f014584fa460c10
|
||||
SHA1 (patch-mozilla_browser_branding_unofficial_locales_en-US_brand.dtd) = 5c6074fb8e0baf4e7dc2dd49718bfd285e65e3e1
|
||||
|
|
16
www/seamonkey/patches/patch-dom_indexedDB_IDBTransaction.h
Normal file
16
www/seamonkey/patches/patch-dom_indexedDB_IDBTransaction.h
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-dom_indexedDB_IDBTransaction.h,v 1.1 2021/06/02 15:39:55 wiz Exp $
|
||||
|
||||
This is mostly a hack, but something else defines CLEANUP to ''
|
||||
which breaks compilation.
|
||||
|
||||
--- dom/indexedDB/IDBTransaction.h.orig 2020-02-17 23:37:49.000000000 +0000
|
||||
+++ dom/indexedDB/IDBTransaction.h
|
||||
@@ -43,6 +43,8 @@ class OpenCursorParams;
|
||||
class RequestParams;
|
||||
}
|
||||
|
||||
+#define CLEANUP mozilla_dom_idbtransaction_h__CLEANUP
|
||||
+
|
||||
class IDBTransaction final
|
||||
: public IDBWrapperCache
|
||||
, public nsIRunnable
|
Loading…
Reference in a new issue