Make this package compile with gcc 2.95 too.

Patch provided by Roland Illig on tech-pkg.
This commit is contained in:
kristerw 2004-09-11 21:29:22 +00:00
parent a1877b04b3
commit d44d7a5a88
2 changed files with 15 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.5 2004/08/14 21:36:22 hubertf Exp $
$NetBSD: distinfo,v 1.6 2004/09/11 21:29:22 kristerw Exp $
SHA1 (scribus-1.1.7.tar.gz) = 144a8d1c29c173b83023e9bb8f83db1924a1cf96
Size (scribus-1.1.7.tar.gz) = 2555298 bytes
@ -7,3 +7,4 @@ SHA1 (patch-ab) = 34bf150818f1fa9a53d23691a4f577f211750c02
SHA1 (patch-ac) = 3478bbc02a41c955fb820048beb6935567d19a54
SHA1 (patch-ad) = 9203829ecfb4d8da4ebf185fcd446f1ecbb044c1
SHA1 (patch-ae) = 9b79846bd5ceb93ed04bf9ec86e3c1fc89a086ee
SHA1 (patch-af) = dd909856719c957a6d593eb81da2b7a928c5ca8c

View file

@ -0,0 +1,13 @@
$NetBSD: patch-af,v 1.1 2004/09/11 21:29:22 kristerw Exp $
--- scribus/plugins/pixmapexport/export.cpp.orig Sat Sep 11 22:53:07 2004
+++ scribus/plugins/pixmapexport/export.cpp Sat Sep 11 22:58:30 2004
@@ -116,7 +116,7 @@
QObject::tr("No"),
QObject::tr("Yes"),
// hack for multiple overwritting (petr)
- (single==TRUE) ? 0 : QObject::tr("Yes all"),
+ (single==TRUE) ? QString::null : QObject::tr("Yes all"),
0, 0);
QApplication::setOverrideCursor(QCursor(Qt::WaitCursor));
if (over == 1)