devel/pystring: import pystring-1.1.4

Pystring is a collection of C++ functions which match the interface and
behavior of python's string class methods using std::string.

Originally developed at Sony Pictures Imageworks.
This commit is contained in:
ryoon 2023-10-16 12:55:56 +00:00
parent dd5c26c1e2
commit d4861a04c6
6 changed files with 71 additions and 0 deletions

4
devel/pystring/DESCR Normal file
View file

@ -0,0 +1,4 @@
Pystring is a collection of C++ functions which match the interface and
behavior of python's string class methods using std::string.
Originally developed at Sony Pictures Imageworks.

24
devel/pystring/Makefile Normal file
View file

@ -0,0 +1,24 @@
# $NetBSD: Makefile,v 1.1 2023/10/16 12:55:56 ryoon Exp $
DISTNAME= pystring-1.1.4
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GITHUB:=imageworks/}
GITHUB_PROJECT= pystring
GITHUB_TAG= v${PKGVERSION_NOREV}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://github.com/imageworks/pystring/
COMMENT= Pythons string methods for C++ std::string
LICENSE= mit
USE_LIBTOOL= yes
USE_LANGUAGES= c++
USE_TOOLS+= gmake
INSTALLATION_DIRS+= include/pystring lib
post-install:
${RUN} ${INSTALL_DATA} ${WRKSRC}/pystring.h \
${DESTDIR}${PREFIX}/include/pystring
.include "../../mk/bsd.pkg.mk"

3
devel/pystring/PLIST Normal file
View file

@ -0,0 +1,3 @@
@comment $NetBSD: PLIST,v 1.1 2023/10/16 12:55:56 ryoon Exp $
include/pystring/pystring.h
lib/libpystring.la

View file

@ -0,0 +1,12 @@
# $NetBSD: buildlink3.mk,v 1.1 2023/10/16 12:55:56 ryoon Exp $
BUILDLINK_TREE+= pystring
.if !defined(PYSTRING_BUILDLINK3_MK)
PYSTRING_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.pystring+= pystring>=1.1.4
BUILDLINK_PKGSRCDIR.pystring?= ../../devel/pystring
.endif # PYSTRING_BUILDLINK3_MK
BUILDLINK_TREE+= -pystring

6
devel/pystring/distinfo Normal file
View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1 2023/10/16 12:55:56 ryoon Exp $
BLAKE2s (pystring-1.1.4.tar.gz) = 1fb80b5ddcfd017c9c62093d9d5f24604e47e9e86ab4d9efadccfc43b9af20c5
SHA512 (pystring-1.1.4.tar.gz) = 9c0460fea67885492f9b0d29a9ba312d960fd5e43577cdcfd47faf04397ff4b7e456ed68f1948b923d2f63f9922d576b93e4ca1a27376bcb6d29c683828acb01
Size (pystring-1.1.4.tar.gz) = 19184 bytes
SHA1 (patch-Makefile) = 712b30f612f0885a8b8a47a93554828da1216302

View file

@ -0,0 +1,22 @@
$NetBSD: patch-Makefile,v 1.1 2023/10/16 12:55:56 ryoon Exp $
* Support DESTDIR install.
--- Makefile.orig 2022-09-27 00:28:46.000000000 +0000
+++ Makefile
@@ -1,5 +1,5 @@
LIBTOOL ?= libtool
-LIBDIR ?= /usr/lib
+LIBDIR ?= ${PREFIX}/lib
CXX ?= g++
CXXFLAGS ?= -g -O3 -Wall -Wextra -Wshadow -Wconversion -Wcast-qual -Wformat=2
@@ -12,7 +12,7 @@ libpystring.la: pystring.lo
$(LIBTOOL) --mode=link --tag=CXX $(CXX) -o $@ $< -rpath $(LIBDIR)
install: libpystring.la
- $(LIBTOOL) --mode=install install -c $< $(LIBDIR)/$<
+ $(LIBTOOL) --mode=install install -c $< ${DESTDIR}$(LIBDIR)/$<
clean:
$(RM) -fr pystring.lo pystring.o libpystring.la .libs