Update to version 0.13.0. New features include plugin support and cover art
support [via external plugins]. Reviewed by jlam@
This commit is contained in:
parent
0f29e84b78
commit
d4d4e25aae
7 changed files with 91 additions and 89 deletions
|
@ -1,10 +1,9 @@
|
|||
# $NetBSD: Makefile,v 1.14 2006/03/06 00:18:14 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.15 2006/04/07 17:40:22 rpaulo Exp $
|
||||
#
|
||||
|
||||
DISTNAME= gmpc-0.12.0
|
||||
PKGREVISION= 4
|
||||
DISTNAME= gmpc-0.13.0
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://download.qballcow.nl/programs/gmpc/
|
||||
MASTER_SITES= http://download.qballcow.nl/programs/gmpc-0.13/
|
||||
|
||||
MAINTAINER= pkg@burningsoda.com
|
||||
HOMEPAGE= http://qballcow.nl/?name=gmpc
|
||||
|
|
|
@ -1,5 +1,9 @@
|
|||
@comment $NetBSD: PLIST,v 1.5 2005/11/22 19:27:46 wiz Exp $
|
||||
@comment $NetBSD: PLIST,v 1.6 2006/04/07 17:40:22 rpaulo Exp $
|
||||
bin/gmpc
|
||||
include/gmpc/config1.h
|
||||
include/gmpc/cover-art.h
|
||||
include/gmpc/plugin.h
|
||||
include/gmpc/qthread.h
|
||||
share/applications/gmpc.desktop
|
||||
share/gmpc/add-browser.glade
|
||||
share/gmpc/gmpc-tray.png
|
||||
|
@ -23,6 +27,7 @@ share/gmpc/playlist3.glade
|
|||
${PKGLOCALEDIR}/locale/fr/LC_MESSAGES/gmpc.mo
|
||||
${PKGLOCALEDIR}/locale/ru/LC_MESSAGES/gmpc.mo
|
||||
share/pixmaps/gmpc.png
|
||||
lib/pkgconfig/gmpc.pc
|
||||
@comment in xdg-dirs: @dirrm share/pixmaps
|
||||
@dirrm share/gmpc
|
||||
@comment in xdg-dirs: @dirrm share/applications
|
||||
|
|
|
@ -1,10 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.6 2005/12/18 20:24:46 rillig Exp $
|
||||
$NetBSD: distinfo,v 1.7 2006/04/07 17:40:22 rpaulo Exp $
|
||||
|
||||
SHA1 (gmpc-0.12.0.tar.gz) = 89f4ac5e1bd1c89cf2e7a8d1d8a3ed16f8931cfa
|
||||
RMD160 (gmpc-0.12.0.tar.gz) = 8061590dc633633a09bf64662ae06c35e4e1a3ca
|
||||
Size (gmpc-0.12.0.tar.gz) = 452390 bytes
|
||||
SHA1 (patch-aa) = 6223ea3d0fa230b28900885cdb9d00e8533eb8a2
|
||||
SHA1 (patch-ab) = de883be7b1ec93041530ab0ef5d6b7a06bc43b1d
|
||||
SHA1 (gmpc-0.13.0.tar.gz) = 587adeb34786cad639dd426be864fe6be4398db1
|
||||
RMD160 (gmpc-0.13.0.tar.gz) = bcc9444346406d6a22a72e994bd183c6ede7c437
|
||||
Size (gmpc-0.13.0.tar.gz) = 476926 bytes
|
||||
SHA1 (patch-ab) = 91ed0e58cc8403f7e65df6ed5245b4e1e27ebfb3
|
||||
SHA1 (patch-ac) = a88c2782233136e4ad50ba183e5b53278a69b755
|
||||
SHA1 (patch-ad) = 712040c9303532cbf08d299023468789f497f222
|
||||
SHA1 (patch-af) = 6b86c55f44b12073439c822e50b960ff390e3fbb
|
||||
SHA1 (patch-ad) = 5685d0065100b3dcfe96aec773d38d8c70dad783
|
||||
SHA1 (patch-af) = c6993d734c1ac8e8dd41376f50bf31c2abd74036
|
||||
|
|
|
@ -1,18 +1,12 @@
|
|||
$NetBSD: patch-aa,v 1.3 2005/12/18 20:24:46 rillig Exp $
|
||||
$NetBSD: patch-aa,v 1.4 2006/04/07 17:40:22 rpaulo Exp $
|
||||
|
||||
Keywords: c90
|
||||
|
||||
--- src/edit_markup.c.orig Sun Jun 19 11:58:50 2005
|
||||
+++ src/edit_markup.c Sun Dec 18 21:11:14 2005
|
||||
@@ -121,8 +121,10 @@ char * edit_song_markup(char *format)
|
||||
{
|
||||
char *str_format = NULL;
|
||||
GtkTextIter start_iter, stop_iter;
|
||||
+ GtkWidget *dialog;
|
||||
+
|
||||
xml_esf= glade_xml_new(GLADE_PATH"gmpc.glade", "esf_dialog",NULL);
|
||||
- GtkWidget *dialog = glade_xml_get_widget(xml_esf, "esf_dialog");
|
||||
+ dialog = glade_xml_get_widget(xml_esf, "esf_dialog");
|
||||
buffer= gtk_text_view_get_buffer(GTK_TEXT_VIEW(glade_xml_get_widget(xml_esf, "textview_markup")));
|
||||
glade_xml_signal_autoconnect (xml_esf);
|
||||
g_signal_connect(G_OBJECT(buffer), "changed", G_CALLBACK(esf_render_example), NULL);
|
||||
--- src/Makefile.in.orig 2006-04-07 18:20:35.000000000 +0100
|
||||
+++ src/Makefile.in 2006-04-07 18:20:45.000000000 +0100
|
||||
@@ -198,6 +198,7 @@ LIBS = \
|
||||
|
||||
|
||||
LDFLAGS = \
|
||||
+ @LDFLAGS@ \
|
||||
@EXTRA_LDFLAGS@
|
||||
|
||||
|
||||
|
|
|
@ -1,34 +1,47 @@
|
|||
$NetBSD: patch-ab,v 1.1 2005/12/18 20:24:46 rillig Exp $
|
||||
$NetBSD: patch-ab,v 1.2 2006/04/07 17:40:22 rpaulo Exp $
|
||||
|
||||
Keywords: c90
|
||||
|
||||
--- src/main.c.orig Sun Aug 14 18:43:45 2005
|
||||
+++ src/main.c Sun Dec 18 21:01:32 2005
|
||||
@@ -333,6 +333,7 @@ int update_interface ()
|
||||
void playlist_changed(MpdObj *mi, int old_playlist_id, int new_playlist_id)
|
||||
--- src/main.c.orig 2006-02-14 18:04:43.000000000 +0000
|
||||
+++ src/main.c 2006-04-06 21:53:15.000000000 +0100
|
||||
@@ -378,6 +378,7 @@ int update_interface ()
|
||||
void playlist_changed(MpdObj *mi)
|
||||
{
|
||||
MpdData *data = NULL;
|
||||
+ char *string;
|
||||
|
||||
long long new_playlist_id = mpd_playlist_get_playlist_id(connection);
|
||||
/*
|
||||
* so I don't have to check all the time
|
||||
@@ -342,7 +343,7 @@ void playlist_changed(MpdObj *mi, int ol
|
||||
* so I don't have to check all the time
|
||||
@@ -387,7 +388,7 @@ void playlist_changed(MpdObj *mi)
|
||||
gchar buffer[1024];
|
||||
debug_printf(DEBUG_INFO, "playlist_changed_callback: playlist changed\n");
|
||||
debug_printf(DEBUG_INFO, "playlist changed length: %i %i\n",info.playlist_length, mpd_playlist_get_playlist_length(mi));
|
||||
old_length = info.playlist_length;
|
||||
- char *string = cfg_get_single_value_as_string_with_default(config, "playlist","markup", DEFAULT_PLAYLIST_MARKUP);
|
||||
+ string = cfg_get_single_value_as_string_with_default(config, "playlist","markup", DEFAULT_PLAYLIST_MARKUP);
|
||||
- char *string = cfg_get_single_value_as_string_with_default(config,
|
||||
+ string = cfg_get_single_value_as_string_with_default(config,
|
||||
"playlist","markup", DEFAULT_PLAYLIST_MARKUP);
|
||||
|
||||
data = mpd_ob_playlist_get_changes(mi,info.playlist_id);
|
||||
|
||||
@@ -608,8 +609,9 @@ void error_callback(MpdObj *mi, int erro
|
||||
if (xml_error_window == NULL)
|
||||
data = mpd_playlist_get_changes(mi,info.playlist_id);
|
||||
@@ -804,6 +805,7 @@ void password_dialog(int failed)
|
||||
void error_callback(MpdObj *mi, int error_id, char *error_msg, gpointer data)
|
||||
{
|
||||
int autoconnect = cfg_get_single_value_as_int_with_default(config, "connection","autoconnect", DEFAULT_AUTOCONNECT);
|
||||
+ GtkWidget *dialog;
|
||||
/* if we are not connected we show a reconnect */
|
||||
if(!mpd_check_connected(mi))
|
||||
{
|
||||
gchar *str = g_strdup_printf("error code %i: %s", error_id, error_msg);
|
||||
+ GtkWidget *dialog;
|
||||
xml_error_window = glade_xml_new(GLADE_PATH"gmpc.glade", "error_dialog",NULL);
|
||||
- GtkWidget *dialog = glade_xml_get_widget(xml_error_window, "error_dialog");
|
||||
+ dialog = glade_xml_get_widget(xml_error_window, "error_dialog");
|
||||
gtk_label_set_markup(GTK_LABEL(glade_xml_get_widget(xml_error_window,"em_label")), str);
|
||||
gtk_widget_show_all(dialog);
|
||||
g_signal_connect(G_OBJECT(dialog), "response", G_CALLBACK(error_window_destroy), GINT_TO_POINTER(autoconnect));
|
||||
@@ -816,7 +818,7 @@ void error_callback(MpdObj *mi, int erro
|
||||
gchar *path = gmpc_get_full_glade_path("gmpc.glade");
|
||||
xml_error_window = glade_xml_new(path,"error_dialog",NULL);
|
||||
g_free(path);
|
||||
- GtkWidget *dialog = glade_xml_get_widget(xml_error_window, "error_dialog");
|
||||
+ dialog = glade_xml_get_widget(xml_error_window, "error_dialog");
|
||||
gtk_label_set_markup(GTK_LABEL(glade_xml_get_widget(xml_error_window,"em_label")), str);
|
||||
gtk_widget_show_all(dialog);
|
||||
g_signal_connect(G_OBJECT(dialog), "response", G_CALLBACK(error_window_destroy), GINT_TO_POINTER(autoconnect));
|
||||
@@ -842,7 +844,7 @@ void error_callback(MpdObj *mi, int erro
|
||||
}
|
||||
else {
|
||||
|
||||
- GtkWidget *dialog = gtk_message_dialog_new_with_markup(NULL,
|
||||
+ dialog = gtk_message_dialog_new_with_markup(NULL,
|
||||
GTK_DIALOG_MODAL,
|
||||
GTK_MESSAGE_ERROR,
|
||||
GTK_BUTTONS_CLOSE,
|
||||
|
|
|
@ -1,19 +1,22 @@
|
|||
$NetBSD: patch-ad,v 1.1 2005/12/18 20:24:46 rillig Exp $
|
||||
$NetBSD: patch-ad,v 1.2 2006/04/07 17:40:22 rpaulo Exp $
|
||||
|
||||
Keywords: c90
|
||||
|
||||
--- src/player.c.orig Sat Aug 6 22:25:32 2005
|
||||
+++ src/player.c Sun Dec 18 21:03:56 2005
|
||||
@@ -273,9 +273,11 @@ void msg_pop_popup()
|
||||
--- src/player.c.orig 2006-02-06 18:46:50.000000000 +0000
|
||||
+++ src/player.c 2006-04-06 21:49:45.000000000 +0100
|
||||
@@ -300,6 +300,8 @@ int msg_pop_popup()
|
||||
|
||||
int update_player()
|
||||
{
|
||||
+ GtkRange *scale;
|
||||
+
|
||||
if(!mpd_ob_check_connected(connection)) return FALSE;
|
||||
/* update the volume slider */
|
||||
- GtkRange *scale = (GtkRange *)glade_xml_get_widget(xml_main_window, "volume_slider");
|
||||
+ scale = (GtkRange *)glade_xml_get_widget(xml_main_window, "volume_slider");
|
||||
if((int)gtk_range_get_value(scale) != mpd_ob_status_get_volume(connection))
|
||||
{
|
||||
gtk_range_set_value(scale, (double)mpd_ob_status_get_volume(connection));
|
||||
if(!xml_main_window) return FALSE;
|
||||
if(!mpd_check_connected(connection)) return FALSE;
|
||||
/* things that only need to be updated during playing */
|
||||
@@ -308,7 +310,7 @@ int update_player()
|
||||
int elapsedTime = mpd_status_get_elapsed_song_time(connection);
|
||||
/* update the progress bar */
|
||||
if(!seek){
|
||||
- GtkRange *scale = (GtkRange *)glade_xml_get_widget(xml_main_window, "progress_slider");
|
||||
+ scale = (GtkRange *)glade_xml_get_widget(xml_main_window, "progress_slider");
|
||||
gdouble prog = ((double)elapsedTime/(double)totalTime)*100;
|
||||
gtk_range_set_value(scale, prog);
|
||||
}
|
||||
|
|
|
@ -1,30 +1,19 @@
|
|||
$NetBSD: patch-af,v 1.1 2005/12/18 20:24:46 rillig Exp $
|
||||
$NetBSD: patch-af,v 1.2 2006/04/07 17:40:22 rpaulo Exp $
|
||||
|
||||
Keywords: c90
|
||||
|
||||
--- src/playlist3.c.orig Sun Aug 14 15:01:07 2005
|
||||
+++ src/playlist3.c Sun Dec 18 21:09:30 2005
|
||||
@@ -193,7 +193,7 @@ unsigned long pl3_find_view_browser()
|
||||
if(loop)
|
||||
{
|
||||
GtkTreeIter piter;
|
||||
- int id = 0, ttime = 0;;
|
||||
+ int id = 0, ttime = 0;
|
||||
char *icon;
|
||||
gtk_tree_model_get(GTK_TREE_MODEL(pl2_store), &iter, SONG_ID, &id, SONG_STOCK_ID, &icon, -1);
|
||||
gtk_list_store_append(pl3_store, &piter);
|
||||
@@ -1239,9 +1239,12 @@ void pl3_playlist_row_activated(GtkTreeV
|
||||
*/
|
||||
void pl3_reinitialize_tree()
|
||||
--- src/playlist3.c.orig 2006-02-15 21:09:17.000000000 +0000
|
||||
+++ src/playlist3.c 2006-04-06 21:51:40.000000000 +0100
|
||||
@@ -105,10 +105,12 @@ int pl3_cat_get_selected_browser()
|
||||
void pl3_initialize_tree()
|
||||
{
|
||||
int i;
|
||||
+ GtkTreePath *path;
|
||||
+ GtkTreeSelection *sel;
|
||||
+
|
||||
if(pl3_xml == NULL) return;
|
||||
|
||||
- GtkTreePath *path = gtk_tree_path_new_from_string("0");
|
||||
- GtkTreeSelection *sel = gtk_tree_view_get_selection(GTK_TREE_VIEW(glade_xml_get_widget(pl3_xml, "cat_tree")));
|
||||
+ path = gtk_tree_path_new_from_string("0");
|
||||
+ sel = gtk_tree_view_get_selection(GTK_TREE_VIEW(glade_xml_get_widget(pl3_xml, "cat_tree")));
|
||||
gtk_tree_store_clear(pl3_tree);
|
||||
/* add the current playlist */
|
||||
pl3_current_playlist_add();
|
||||
if((old_type&PLUGIN_ID_MARK || old_type&PLUGIN_ID_INTERNALL) != 0)
|
||||
{
|
||||
if(old_type >= 0)
|
||||
|
|
Loading…
Reference in a new issue