update to 0.45

changes:
- Makefile no longer appends 'static' to statically linked binaries
- Add optional SSH_ASKPASS support to the client
- Respect HOST_LOOKUP option
- Fix accidentally removed "return;" statement which was removed in 0.44
  (causing clients which sent an empty terminal-modes string to fail to
  connect - including pssh, ssh.com, danger hiptop). (patches
  independently from Paul Fox, David Horwitt and Sven-Ola Tuecke)
- Read "y/n" response for fingerprints from /dev/tty directly so that dbclient
  will work with scp.
This commit is contained in:
drochner 2005-04-29 16:14:41 +00:00
parent fa46fe612f
commit d4ec42c6fe
4 changed files with 26 additions and 26 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.9 2005/04/11 21:47:11 tv Exp $
# $NetBSD: Makefile,v 1.10 2005/04/29 16:14:41 drochner Exp $
DISTNAME= dropbear-0.44
DISTNAME= dropbear-0.45
CATEGORIES= security
MASTER_SITES= http://matt.ucc.asn.au/dropbear/releases/
EXTRACT_SUFX= .tar.bz2

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.6 2005/02/24 13:10:05 agc Exp $
$NetBSD: distinfo,v 1.7 2005/04/29 16:14:41 drochner Exp $
SHA1 (dropbear-0.44.tar.bz2) = a95bde40bce8d7809097a1cda87ef139e97649ce
RMD160 (dropbear-0.44.tar.bz2) = a885fe418a27192061ef5022f9387e83d0abda13
Size (dropbear-0.44.tar.bz2) = 1263785 bytes
SHA1 (patch-aa) = a6ee765ce4a06571ea560ad9d9705667c52ee5ec
SHA1 (patch-ab) = b3c25e61718837f758723c06a97b691d25d82bd2
SHA1 (dropbear-0.45.tar.bz2) = 6368d839888750726391394177f89f5709d6d816
RMD160 (dropbear-0.45.tar.bz2) = 583f6b38660758d37f4177f41af149aec4475b6d
Size (dropbear-0.45.tar.bz2) = 1268881 bytes
SHA1 (patch-aa) = 2464dc94fc91e297bf132bcdf8d2fd36ed24093b
SHA1 (patch-ab) = 80aacb92daf040e8bcff0171ac54b19b3031e86c

View file

@ -1,23 +1,23 @@
$NetBSD: patch-aa,v 1.5 2005/01/18 17:30:59 drochner Exp $
$NetBSD: patch-aa,v 1.6 2005/04/29 16:14:41 drochner Exp $
--- Makefile.in.orig 2005-01-03 10:24:03.000000000 +0100
--- Makefile.in.orig 2005-03-07 05:27:01.000000000 +0100
+++ Makefile.in
@@ -140,14 +140,14 @@ insmulti%: dropbearmulti
@@ -137,14 +137,14 @@ insmulti%: dropbearmulti
inst_dropbear: dropbear
$(INSTALL) -d -m 755 $(DESTDIR)$(sbindir)
$(INSTALL) -m 755 $(SPREFIX)dropbear$(EXEEXT) $(DESTDIR)$(sbindir)
- -chown root $(DESTDIR)$(sbindir)/$(SPREFIX)dropbear$(EXEEXT)
- -chgrp 0 $(DESTDIR)$(sbindir)/$(SPREFIX)dropbear$(EXEEXT)
+ -chown ${ROOT_USER} $(DESTDIR)$(sbindir)/$(SPREFIX)dropbear$(EXEEXT)
+ -chgrp ${ROOT_GROUP} $(DESTDIR)$(sbindir)/$(SPREFIX)dropbear$(EXEEXT)
$(INSTALL) -m 755 dropbear$(EXEEXT) $(DESTDIR)$(sbindir)
- -chown root $(DESTDIR)$(sbindir)/dropbear$(EXEEXT)
- -chgrp 0 $(DESTDIR)$(sbindir)/dropbear$(EXEEXT)
+ -chown ${ROOT_USER} $(DESTDIR)$(sbindir)/dropbear$(EXEEXT)
+ -chgrp ${ROOT_GROUP} $(DESTDIR)$(sbindir)/dropbear$(EXEEXT)
inst_%: $*
$(INSTALL) -d -m 755 $(DESTDIR)$(bindir)
$(INSTALL) -m 755 $(SPREFIX)$*$(EXEEXT) $(DESTDIR)$(bindir)
- -chown root $(DESTDIR)$(bindir)/$(SPREFIX)$*$(EXEEXT)
- -chgrp 0 $(DESTDIR)$(bindir)/$(SPREFIX)$*$(EXEEXT)
+ -chown ${ROOT_USER} $(DESTDIR)$(bindir)/$(SPREFIX)$*$(EXEEXT)
+ -chgrp ${ROOT_GROUP} $(DESTDIR)$(bindir)/$(SPREFIX)$*$(EXEEXT)
$(INSTALL) -m 755 $*$(EXEEXT) $(DESTDIR)$(bindir)
- -chown root $(DESTDIR)$(bindir)/$*$(EXEEXT)
- -chgrp 0 $(DESTDIR)$(bindir)/$*$(EXEEXT)
+ -chown ${ROOT_USER} $(DESTDIR)$(bindir)/$*$(EXEEXT)
+ -chgrp ${ROOT_GROUP} $(DESTDIR)$(bindir)/$*$(EXEEXT)
# for some reason the rule further down doesn't like $($@objs) as a prereq.

View file

@ -1,11 +1,11 @@
$NetBSD: patch-ab,v 1.1 2005/01/18 17:30:59 drochner Exp $
$NetBSD: patch-ab,v 1.2 2005/04/29 16:14:41 drochner Exp $
--- options.h.orig 2005-01-18 15:42:25.000000000 +0100
--- options.h.orig 2005-03-07 05:27:02.000000000 +0100
+++ options.h
@@ -139,7 +139,7 @@ etc) slower (perhaps by 50%). Recommende
* will prevent Dropbear from blocking on the device. This could
@@ -143,7 +143,7 @@ etc) slower (perhaps by 50%). Recommende
* however significantly reduce the security of your ssh connections
* if the PRNG state becomes simpler. */
* if the PRNG state becomes guessable - make sure you know what you are
* doing if you change this. */
-#define DROPBEAR_RANDOM_DEV "/dev/random"
+#define DROPBEAR_RANDOM_DEV "/dev/urandom"