update ldpc package to pkgrevision 1

fix a packaging botch whereby the file of random numbers was not installed,
and a reference to the build directory was embedded in the executables.

now the regression tests run to completion:

	Running ex-dep:

	Running ex-ham7a:

	Running ex-ham7b:

	Running ex-ldpc-encode:

	Running ex-ldpc36-1000a:

	Running ex-ldpc36-5000a:

	Running ex-ldpcvar-5000a:

	Running ex-wrong-model:
	155c155
	< Bit error rate (on message bits only): 1.320e-02
	---
	> Bit error rate (on message bits only): 1.299e-02
This commit is contained in:
agc 2011-02-10 16:15:36 +00:00
parent a907e636f2
commit d4fdb2e8da
4 changed files with 24 additions and 4 deletions

View file

@ -1,8 +1,9 @@
# $NetBSD: Makefile,v 1.1.1.1 2010/11/29 06:43:15 agc Exp $
# $NetBSD: Makefile,v 1.2 2011/02/10 16:15:36 agc Exp $
DISTNAME= LDPC-2006-02-08
PKGNAME= ldpc-20060208
CATEGORIES= devel
PKGREVISION= 1
MASTER_SITES= http://www.cs.utoronto.ca/~radford/ftp/LDPC-2006-02-08/
MAINTAINER= agc@NetBSD.org
@ -25,11 +26,13 @@ LDPCDOCS+= mod2dense.html mod2sparse.html modify.html modules.html pchk.html
LDPCDOCS+= progs.html rand.html refs.html release.html sparse-LU.html
LDPCDOCS+= support.html
LDPCRANDFILE= randfile
do-install:
for p in ${LDPCPROGS}; do \
${INSTALL_PROGRAM} ${WRKSRC}/$$p ${DESTDIR}${PREFIX}/bin; \
done
for d in ${LDPCDOCS}; do \
for d in ${LDPCDOCS} ${LDPCRANDFILE}; do \
${INSTALL_DATA} ${WRKSRC}/$$d ${DESTDIR}${PREFIX}/share/ldpc; \
done

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2010/11/29 06:43:15 agc Exp $
@comment $NetBSD: PLIST,v 1.2 2011/02/10 16:15:36 agc Exp $
bin/alist-to-pchk
bin/decode
bin/encode
@ -28,6 +28,7 @@ share/ldpc/modules.html
share/ldpc/pchk.html
share/ldpc/progs.html
share/ldpc/rand.html
share/ldpc/randfile
share/ldpc/refs.html
share/ldpc/release.html
share/ldpc/sparse-LU.html

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2010/11/29 06:43:15 agc Exp $
$NetBSD: distinfo,v 1.2 2011/02/10 16:15:36 agc Exp $
SHA1 (LDPC-2006-02-08.tar.gz) = b4bc77ed5a56976dca7d47f1065b0d59863385d9
RMD160 (LDPC-2006-02-08.tar.gz) = 37ffa0afc895ab7448d77bf5cdfb05735443c317
Size (LDPC-2006-02-08.tar.gz) = 405064 bytes
SHA1 (patch-aa) = e7594fa0595c3bef0d6548d706aaa26e3380748b

View file

@ -0,0 +1,15 @@
$NetBSD: patch-aa,v 1.1 2011/02/10 16:15:36 agc Exp $
Refer to the file of random numbers in the correct location
--- Makefile 2011/02/10 04:47:36 1.1
+++ Makefile 2011/02/10 04:46:57
@@ -104,7 +104,7 @@
$(COMPILE) mod2sparse.c
$(COMPILE) mod2convert.c
$(COMPILE) distrib.c
- $(COMPILE) -DRAND_FILE=\"`pwd`/randfile\" rand.c
+ $(COMPILE) -DRAND_FILE=\"${PREFIX}/share/ldpc/randfile\" rand.c
# CLEAN UP ALL PROGRAMS AND REMOVE ALL FILES PRODUCED BY TESTS AND EXAMPLES.