Linker flags must be prefixed with -Wl. Don't add default arguments

during method implementation.
This commit is contained in:
joerg 2013-01-15 15:28:37 +00:00
parent 70300a813d
commit d4ff19682b
4 changed files with 32 additions and 4 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.24 2011/12/06 19:49:54 joerg Exp $
$NetBSD: distinfo,v 1.25 2013/01/15 15:28:37 joerg Exp $
SHA1 (scribus-1.3.3.14.tar.bz2) = 3ad5341fb815e2782aa4d817025d74af4a7c78e1
RMD160 (scribus-1.3.3.14.tar.bz2) = b0f35060eb61f033cb86ee644d5c88222b534596
@ -8,7 +8,9 @@ SHA1 (patch-ab) = 275027632360bb5458b1f4b2fda8d3741c74d5e9
SHA1 (patch-ad) = 03a4edef89cf4f8d78b20c5a4b7809036ba8d694
SHA1 (patch-ae) = 063d4737cbffd3f712d505818fd028f132267c90
SHA1 (patch-ag) = 906fa6305015ec3b2589350d338cf2dcb30d5c58
SHA1 (patch-ah) = 51d12aabcbdc7abbee12b0a445b57311b6bd28d4
SHA1 (patch-ah) = 68c77baab8bba10bb058f6fecea03abd9a00c0de
SHA1 (patch-ai) = 7dd3641fef0cafe79313cf04d9765bb77c6b6e61
SHA1 (patch-scribus_cupsoptions.cpp) = 92eb7dd8b0caf1efb2019b8e10b25daf1499f870
SHA1 (patch-scribus_plugins_scriptplugin_runscriptdialog.cpp) = 75e9dfbc1b0c6fce3f9c5dc1f1eba62e4a1525a0
SHA1 (patch-scribus_plugins_scriptplugin_runscriptdialog.h) = f4399a4b9352b61ca5a0c8e3f3be908f3d925b55
SHA1 (patch-scribus_printerutil.cpp) = 5a6d7b3d7dc327473b14dc5dcbe74f4fdb8a724b

View file

@ -1,4 +1,4 @@
$NetBSD: patch-ah,v 1.4 2009/09/16 09:24:55 drochner Exp $
$NetBSD: patch-ah,v 1.5 2013/01/15 15:28:37 joerg Exp $
--- scribus/CMakeLists.txt.orig 2008-02-26 20:48:49.000000000 +0100
+++ scribus/CMakeLists.txt
@ -6,7 +6,7 @@ $NetBSD: patch-ah,v 1.4 2009/09/16 09:24:55 drochner Exp $
${SCRIBUS_PIXBUF_LIB}
)
+SET_TARGET_PROPERTIES(${EXE_NAME} PROPERTIES LINK_FLAGS "-export-dynamic")
+SET_TARGET_PROPERTIES(${EXE_NAME} PROPERTIES LINK_FLAGS "-Wl,-export-dynamic")
+
IF(RENDER_LIB STREQUAL "LIBART")
TARGET_LINK_LIBRARIES(${EXE_NAME}

View file

@ -0,0 +1,13 @@
$NetBSD: patch-scribus_plugins_scriptplugin_runscriptdialog.cpp,v 1.1 2013/01/15 15:28:37 joerg Exp $
--- scribus/plugins/scriptplugin/runscriptdialog.cpp.orig 2013-01-14 12:19:58.000000000 +0000
+++ scribus/plugins/scriptplugin/runscriptdialog.cpp
@@ -11,7 +11,7 @@ for which a new license (GPL+exception)
QString RunScriptDialog::m_lastScriptDir;
-RunScriptDialog::RunScriptDialog(QWidget* parent = 0, bool extEnable = false) :
+RunScriptDialog::RunScriptDialog(QWidget* parent, bool extEnable) :
QFileDialog(parent, "runScriptDialog", true)
{
this->extEnable = extEnable;

View file

@ -0,0 +1,13 @@
$NetBSD: patch-scribus_plugins_scriptplugin_runscriptdialog.h,v 1.1 2013/01/15 15:28:37 joerg Exp $
--- scribus/plugins/scriptplugin/runscriptdialog.h.orig 2013-01-14 12:21:57.000000000 +0000
+++ scribus/plugins/scriptplugin/runscriptdialog.h
@@ -20,7 +20,7 @@ class RunScriptDialog : public QFileDial
Q_OBJECT
public:
- RunScriptDialog(QWidget* parent, bool extEnable);
+ RunScriptDialog(QWidget* parent = 0, bool extEnable = false);
~RunScriptDialog();
/// Check if the user wanted the script run as an extension script