Bump PKGREVISION

Fix PR pkg/46655.

With NetBSD current and 6.0's OpenSSL, OPENSSL_NO_SSL_INTERN should not
be defined, due to it lacks some functions.
Exclude version 0x10001000 from OPENSSL_NO_SSL_INTERN definition.
This commit is contained in:
ryoon 2012-07-05 12:50:44 +00:00
parent b500cf74cf
commit d4ff6cceaf
3 changed files with 20 additions and 3 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.7 2012/05/18 20:56:28 ryoon Exp $
# $NetBSD: Makefile,v 1.8 2012/07/05 12:50:44 ryoon Exp $
DISTNAME= httpd-2.4.2
PKGNAME= ${DISTNAME:S/httpd/apache/}
PKGREVISION= 1
PKGREVISION= 2
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE:=httpd/} \
http://archive.apache.org/dist/httpd/ \

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.3 2012/05/18 20:56:28 ryoon Exp $
$NetBSD: distinfo,v 1.4 2012/07/05 12:50:44 ryoon Exp $
SHA1 (httpd-2.4.2.tar.bz2) = 8d391db515edfb6623c0c7c6ce5c1b2e1f7c64c2
RMD160 (httpd-2.4.2.tar.bz2) = 1b97ab44075bea0f398f507dacb5f719a87b720b
@ -13,4 +13,5 @@ SHA1 (patch-ai) = 867ac81fd14b1bd6af048ec57390d915956e9568
SHA1 (patch-al) = 02d9ade5aac4270182063d5ad413970c832ee911
SHA1 (patch-am) = f14b260ffad2c7e8d26e5b614d4aeaf8506e195b
SHA1 (patch-aw) = 43cd64df886853ef7b75b91ed20183f329fcc9df
SHA1 (patch-modules_ssl_ssl__private.h) = 67bb0ec17c4e29cd855467e3cc135bf6a44eb458
SHA1 (patch-server_core__filters.c) = 331672c9a65691229518f31dcdae64382b392287

View file

@ -0,0 +1,16 @@
$NetBSD: patch-modules_ssl_ssl__private.h,v 1.1 2012/07/05 12:50:44 ryoon Exp $
Exclude OpenSSL shipped with NetBSD current and 6.0.
It is pre-beta snapshot of 1.0.1.
--- modules/ssl/ssl_private.h.orig 2012-04-03 12:37:57.000000000 +0000
+++ modules/ssl/ssl_private.h
@@ -83,7 +83,7 @@
/* OpenSSL headers */
#include <openssl/opensslv.h>
-#if (OPENSSL_VERSION_NUMBER >= 0x10001000)
+#if (OPENSSL_VERSION_NUMBER >= 0x10001001)
/* must be defined before including ssl.h */
#define OPENSSL_NO_SSL_INTERN
#endif