Update avrdude 6.0.1 to 6.1

----------------------------------------------------------------------
  * Major changes compared to the previous version:
    - Atmel EDBG protocol support added (JTAGICE3, XplainedPro, Atmel-ICE)

  * New programmers supported:
    - Atmel DFU, using FLIP protocol version 1 (AT90USB and ATmega*U* devices),
      or version 2 (Xmega devices)
    - Atmel-ICE (ARM/AVR), JTAG, PDI, debugWIRE, ISP modi

  * Bugfixes
    - bug #40055: AVRDUDE segfaults when writing eeprom
    - bug #40085: Typo fix in fuses report (for 6.1-svn-20130917)
    - bug #40782: Verify errors for object size > 16 k on x32e5 due
      to typo in avrdude.conf
    - bug #40817: Elf file support (possibly) not working on 6.0.1 windows build
    - bug #40897: AT Mega2560 not correctly programmed with stk500(v1)
      ISP (solution patch)
    - bug #41357: OS X: Avrdude messes with the usb stack?
    - bug #41402: dfu.c missing include <stdint.h>
    - patch #7896: DFU FLIPv2 programming support
    - patch #XXXX: xxx

  * Internals:
    - (Some) programmers can take a list of USB PIDs now.
This commit is contained in:
mef 2014-10-07 15:10:29 +00:00
parent 29448f02e0
commit d50827c0ff
4 changed files with 17 additions and 17 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.38 2013/12/06 07:23:55 mef Exp $
# $NetBSD: Makefile,v 1.39 2014/10/07 15:10:29 mef Exp $
DISTNAME= avrdude-6.0.1
DISTNAME= avrdude-6.1
CATEGORIES= cross
MASTER_SITES= http://download.savannah.gnu.org/releases/avrdude/

View file

@ -1,8 +1,7 @@
@comment $NetBSD: PLIST,v 1.9 2011/03/28 21:42:40 zafer Exp $
@comment $NetBSD: PLIST,v 1.10 2014/10/07 15:10:29 mef Exp $
bin/avrdude
info/avrdude.info
man/man1/avrdude.1
share/examples/avrdude/avrdude.conf
share/doc/${DISTNAME}/avrdude-html/avrdude.html
share/doc/${DISTNAME}/avrdude-html/avrdude_1.html
share/doc/${DISTNAME}/avrdude-html/avrdude_10.html
@ -16,6 +15,7 @@ share/doc/${DISTNAME}/avrdude-html/avrdude_17.html
share/doc/${DISTNAME}/avrdude-html/avrdude_18.html
share/doc/${DISTNAME}/avrdude-html/avrdude_19.html
share/doc/${DISTNAME}/avrdude-html/avrdude_2.html
share/doc/${DISTNAME}/avrdude-html/avrdude_20.html
share/doc/${DISTNAME}/avrdude-html/avrdude_3.html
share/doc/${DISTNAME}/avrdude-html/avrdude_4.html
share/doc/${DISTNAME}/avrdude-html/avrdude_5.html
@ -27,3 +27,4 @@ share/doc/${DISTNAME}/avrdude-html/avrdude_abt.html
share/doc/${DISTNAME}/avrdude-html/avrdude_toc.html
share/doc/${DISTNAME}/avrdude.pdf
share/doc/${DISTNAME}/avrdude.ps
share/examples/avrdude/avrdude.conf

View file

@ -1,13 +1,12 @@
$NetBSD: distinfo,v 1.11 2013/12/06 07:27:15 mef Exp $
$NetBSD: distinfo,v 1.12 2014/10/07 15:10:29 mef Exp $
SHA1 (avrdude-6.0.1.tar.gz) = b0f440f1b1ba3890da6e5b752003ca99e550e3bf
RMD160 (avrdude-6.0.1.tar.gz) = 412483e87c88d9111729db6e3f94acc81b04e145
Size (avrdude-6.0.1.tar.gz) = 692284 bytes
SHA1 (avrdude-6.1.tar.gz) = 15525cbff5918568ef3955d871dbb94feaf83c79
RMD160 (avrdude-6.1.tar.gz) = f2c31951c0941e86ff6deab6bd0348b54d05658c
Size (avrdude-6.1.tar.gz) = 714595 bytes
SHA1 (patch-aa) = 619f682af2e8eff36684993b331ba37cd1b446b6
SHA1 (patch-ab) = a9105ae562c078eec5c87df6e7f27a80184bb6d4
SHA1 (patch-ac) = df871808200e5732f77d50ef2d7fb51234173445
SHA1 (patch-ad) = f9e7465b355f5b3feda8868287d6aaa5cd1dcd28
SHA1 (patch-ae) = 4ad74b5abe90ddf29dd419043a2e6026f704d1c9
SHA1 (patch-af) = 4ae54ce739ff41964fe56bc1b3e85611288a6e0c
SHA1 (patch-ag) = 2a6a13c2878d28e476ec6ee747e7ca5d2e023468
SHA1 (patch-fileio_c) = d0c01ae237bc5df0fd76d2362160d6946ef04846
SHA1 (patch-ag) = fa8828a50faa835fa957de036af925dafd5584cb

View file

@ -1,12 +1,12 @@
$NetBSD: patch-ag,v 1.6 2013/12/06 07:27:15 mef Exp $
$NetBSD: patch-ag,v 1.7 2014/10/07 15:10:29 mef Exp $
Work around AVRISP mkII initial sync stalls on NetBSD.
--- usb_libusb.c.orig 2010-01-19 10:39:11.000000000 +0000
+++ usb_libusb.c
@@ -237,6 +237,17 @@ static void usbdev_close(union filedescr
{
usb_dev_handle *udev = (usb_dev_handle *)fd->usb.handle;
--- usb_libusb.c.orig 2014-03-13 08:03:19.000000000 +0900
+++ usb_libusb.c 2014-10-08 00:01:40.000000000 +0900
@@ -324,6 +324,17 @@ static void usbdev_close(union filedescr
if (udev == NULL)
return;
+#if defined(__NetBSD__)
+#define USB_FEAT_ENDPOINT_HALT 0
@ -21,4 +21,4 @@ Work around AVRISP mkII initial sync stalls on NetBSD.
+
(void)usb_release_interface(udev, usb_interface);
#if !( defined(__FreeBSD__) ) // || ( defined(__APPLE__) && defined(__MACH__) ) )
#if defined(__linux__)