Updated fluxbox to 1.3.7.

Set LICENSE.

Version 1.3.7 is a bug fix release.

Critical Bugfixes:
    * Segfault on startup (mostly *BSD)
    * Segfault on shutdown
    * Segfault on clicking the Remember menu
    * Menu crops on TypeAhead

Minor Bugfixes:
    * _NET_REQUEST_FRAME_EXTENTS
    * Working autorepeat keys
    * Working vertical rotated Tabs and Toolbar
    * Proper size of titlebar buttons on restart / detaching tabs
    * Missing windowmenu works again
    * Several glitches in the menu
    * Correct handling of 'maximized' statement in the apps file

Features:
    * The improved TypeAhead sytem is not limited to matches on beginning
      of menu items anymore, the behavior is configurable:
      - Nowhere - disables TypeAhead support
      - ItemStart - matches typed text only at the start of a menu item
      - Somewhere - matches typed text somewhere in a menu item
      (Currently this is a configfile-only option)
    * Minor tweaks to the i18n system
    * Updated turkish translations

End User unrelated:
    * Code refactoring and cleanup, assisted by Coverity and
      clang static code analysis
This commit is contained in:
wiz 2017-02-22 12:20:51 +00:00
parent 81dfb9114b
commit d54142eba3
8 changed files with 47 additions and 79 deletions

View file

@ -1,8 +1,6 @@
# $NetBSD: Makefile,v 1.64 2013/07/05 13:29:43 ryoon Exp $
#
# $NetBSD: Makefile,v 1.65 2017/02/22 12:20:51 wiz Exp $
DISTNAME= fluxbox-1.3.2
PKGREVISION= 6
DISTNAME= fluxbox-1.3.7
CATEGORIES= wm x11
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=fluxbox/}
EXTRACT_SUFX= .tar.bz2
@ -10,11 +8,13 @@ EXTRACT_SUFX= .tar.bz2
MAINTAINER= sborrill@NetBSD.org
HOMEPAGE= http://fluxbox.sourceforge.net/
COMMENT= Window Manager for X based on Blackbox
LICENSE= mit
USE_LANGUAGES= c c++
GNU_CONFIGURE= YES
USE_TOOLS+= gmake
USE_TOOLS+= gmake pkg-config
USE_LIBTOOL= YES
EXTRACT_USING= bsdtar
.include "../../mk/bsd.prefs.mk"

View file

@ -1,16 +1,15 @@
$NetBSD: distinfo,v 1.33 2015/11/02 23:42:52 agc Exp $
$NetBSD: distinfo,v 1.34 2017/02/22 12:20:51 wiz Exp $
SHA1 (fluxbox-1.3.2.tar.bz2) = 069d810d449c2a223f447aa7a2374f42094bd87b
RMD160 (fluxbox-1.3.2.tar.bz2) = b0b5f1ca76f7776d90c7619148dca6aa999bd2a9
SHA512 (fluxbox-1.3.2.tar.bz2) = 2624c337e85b98e39398319170cbf57f8ab031539844e62f2f61aefd5c2e307b8390261b9658073bcf557f7f006c9df95c72a4420f12fa7122742b4623a17d49
Size (fluxbox-1.3.2.tar.bz2) = 787400 bytes
SHA1 (patch-aa) = 70dacee8af0acee5a75c322260d0b8448e531210
SHA1 (patch-ac) = 1e480faa2c3c56de39e3ea3c5fc5e104cd396916
SHA1 (patch-af) = 1cdde9aa6901e23ba42377d71cefb19f073445fa
SHA1 (fluxbox-1.3.7.tar.bz2) = f8939f43b4c353ebef5fec2b95e8cbfd3cd5ac4d
RMD160 (fluxbox-1.3.7.tar.bz2) = efb8d458edf2b429fb2999eb184ab3aed6a54f7a
SHA512 (fluxbox-1.3.7.tar.bz2) = c40cc765f5d542210e18dca21b98b97a048c6685b605a68e2c64f4e886329f4e6d3a3a7e76b3ca0ce488242f38d0ee2a4d6dfebc9ce97d37c68f84c3948aac8c
Size (fluxbox-1.3.7.tar.bz2) = 911098 bytes
SHA1 (patch-aa) = e237a1b172c95fe5f251ab8795ed63c1888be83b
SHA1 (patch-af) = 871c9ce0bdfecda2c4180bd33b21186111ddecac
SHA1 (patch-bd) = 75532deb83a0f7e8c91f43acb0299d46d69496ba
SHA1 (patch-be) = 0c8c0cfa12bbfeca28d76b12b488777b589bb43a
SHA1 (patch-bf) = db8892e83021a92055621bd394f5697cb696eb10
SHA1 (patch-bf) = 7da25f4e9a0e738da7c24264a91e6ab036d5acf2
SHA1 (patch-bg) = 8f4decdb2ff611dcc1af64145801fac35f83e25a
SHA1 (patch-bj) = 9b0ac35028644b142073a498bc3d59324c51d349
SHA1 (patch-bk) = ae0c9857dd0cd203c8ae3f4bf5a0c7126cf48c92
SHA1 (patch-util_fbsetbg) = 052029bb1938a783359eb527a7059c407e8988aa
SHA1 (patch-src_fluxbox.cc) = a652d685cd80896b45bfa7b2dfd5e98b2561e326

View file

@ -1,25 +1,25 @@
$NetBSD: patch-aa,v 1.12 2012/04/17 20:08:06 bsiegert Exp $
$NetBSD: patch-aa,v 1.13 2017/02/22 12:20:51 wiz Exp $
* "grep -q" doesn't work everywhere.
* Do not use the home directory of the user building the package.
--- util/fluxbox-generate_menu.in.orig Sat Oct 29 13:45:51 2011
--- util/fluxbox-generate_menu.in.orig 2015-02-08 10:44:45.000000000 +0000
+++ util/fluxbox-generate_menu.in
@@ -330,7 +330,7 @@ searchForIcon(){
# echo "^.${entry_exec}.[[:space:]]*<.*/${icon_base}\....>"
if [ -f "$entry_icon" ]; then
# if icon exists and entry does not already exists, add it
- if ! grep -q -m 1 "^.${entry_exec}.[[:space:]]*<.*/${icon_base}\....>" $ICONMAPPING 2> /dev/null; then
+ if ! grep "^.${entry_exec}.[[:space:]]*<.*/${icon_base}\....>" $ICONMAPPING 2> /dev/null; then
echo -e "\"${entry_exec}\" \t <${entry_icon}>" >> $ICONMAPPING
- if ! grep -q -m 1 "^.${execname}.[[:space:]]*<.*/${icon_base}\....>" $ICONMAPPING 2> /dev/null; then
+ if ! grep "^.${execname}.[[:space:]]*<.*/${icon_base}\....>" $ICONMAPPING > /dev/null 2> /dev/null; then
printf "\"${execname}\" \t <${entry_icon}>\n" >> $ICONMAPPING
else
: echo "# mapping already exists for ${entry_exec}" >> $ICONMAPPING
: echo "# mapping already exists for ${execname}" >> $ICONMAPPING
@@ -561,7 +561,7 @@ WHOAMI=`whoami`
[ "$WHOAMI" = root ] && PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
# Check for Imlib2-support
-if @pkgprefix@fluxbox@pkgsuffix@ -info 2> /dev/null | grep -q "^IMLIB"; then
+if @pkgprefix@fluxbox@pkgsuffix@ -info 2> /dev/null | grep "^IMLIB" > /dev/null; then
-if @pkgprefix@fluxbox@pkgsuffix@@EXEEXT@ -info 2> /dev/null | grep -q "^IMLIB"; then
+if @pkgprefix@fluxbox@pkgsuffix@@EXEEXT@ -info 2> /dev/null | grep "^IMLIB" > /dev/null; then
PNG_ICONS="yes"
else
# better assume to assume "no"

View file

@ -1,22 +0,0 @@
$NetBSD: patch-ac,v 1.13 2013/04/30 22:31:02 joerg Exp $
--- src/fluxbox.cc.orig 2013-04-30 20:22:28.000000000 +0000
+++ src/fluxbox.cc
@@ -1077,7 +1077,7 @@ void Fluxbox::saveWindowSearchGroup(Wind
}
void Fluxbox::saveGroupSearch(Window window, WinClient *data) {
- m_group_search.insert(pair<const Window, WinClient *>(window, data));
+ m_group_search.insert(std::multimap<Window, WinClient *>::value_type(window, data));
}
@@ -1341,7 +1341,7 @@ bool Fluxbox::validateClient(const WinCl
WinClientMap::const_iterator it =
find_if(m_window_search.begin(),
m_window_search.end(),
- Compose(bind2nd(equal_to<WinClient *>(), client),
+ Compose(bind2nd(equal_to<const WinClient *>(), client),
Select2nd<WinClientMap::value_type>()));
return it != m_window_search.end();
}

View file

@ -1,10 +1,10 @@
$NetBSD: patch-af,v 1.4 2007/01/15 17:41:28 tonio Exp $
$NetBSD: patch-af,v 1.5 2017/02/22 12:20:51 wiz Exp $
--- src/FbTk/I18n.cc.orig 2007-01-15 17:54:14.000000000 +0100
--- src/FbTk/I18n.cc.orig 2015-02-08 10:44:45.000000000 +0000
+++ src/FbTk/I18n.cc
@@ -76,7 +76,9 @@ void NLSInit(const char *catalog) {
I18n::I18n():m_multibyte(false), m_utf8_translate(false), m_catalog_fd((nl_catd)(-1)) {
#ifdef HAVE_SETLOCALE
@@ -209,7 +209,9 @@ void I18n::init(const char* catalog) {
I18n::I18n() : m_multibyte(false), m_utf8_translate(false) {
#if defined(HAVE_SETLOCALE) && defined(NLS)
//make sure we don't get 0 to m_locale string
- char *temp = setlocale(LC_MESSAGES, "");
+ char *temp;

View file

@ -1,10 +1,10 @@
$NetBSD: patch-bf,v 1.3 2012/04/17 20:08:06 bsiegert Exp $
$NetBSD: patch-bf,v 1.4 2017/02/22 12:20:51 wiz Exp $
Adding "const" to a primitive type is useless. Sunpro doesn't like it.
--- src/CurrentWindowCmd.cc.orig Sat Oct 29 13:45:51 2011
--- src/CurrentWindowCmd.cc.orig 2015-02-08 10:44:45.000000000 +0000
+++ src/CurrentWindowCmd.cc
@@ -462,7 +462,7 @@ REGISTER_COMMAND_PARSER(moveleft, MoveCm
@@ -485,7 +485,7 @@ REGISTER_COMMAND_PARSER(moveleft, MoveCm
REGISTER_COMMAND_PARSER(moveup, MoveCmd::parse, void);
REGISTER_COMMAND_PARSER(movedown, MoveCmd::parse, void);
@ -13,21 +13,12 @@ Adding "const" to a primitive type is useless. Sunpro doesn't like it.
m_step_size_x(step_size_x), m_step_size_y(step_size_y) { }
void MoveCmd::real_execute() {
@@ -499,7 +499,7 @@ REGISTER_COMMAND_PARSER(resizeto, Resize
@@ -558,7 +558,7 @@ REGISTER_COMMAND_PARSER(resizeto, Resize
REGISTER_COMMAND_PARSER(resizehorizontal, ResizeCmd::parse, void);
REGISTER_COMMAND_PARSER(resizevertical, ResizeCmd::parse, void);
-ResizeCmd::ResizeCmd(const int step_size_x, const int step_size_y) :
+ResizeCmd::ResizeCmd(int step_size_x, int step_size_y) :
m_step_size_x(step_size_x), m_step_size_y(step_size_y) { }
-ResizeCmd::ResizeCmd(const int step_size_x, const int step_size_y, bool is_relative_x, bool is_relative_y) :
+ResizeCmd::ResizeCmd(int step_size_x, int step_size_y, bool is_relative_x, bool is_relative_y) :
m_step_size_x(step_size_x), m_step_size_y(step_size_y), m_is_relative_x(is_relative_x), m_is_relative_y(is_relative_y) { }
void ResizeCmd::real_execute() {
@@ -579,7 +579,7 @@ void MoveToCmd::real_execute() {
}
-ResizeToCmd::ResizeToCmd(const int step_size_x, const int step_size_y) :
+ResizeToCmd::ResizeToCmd(int step_size_x, int step_size_y) :
m_step_size_x(step_size_x), m_step_size_y(step_size_y) { }
void ResizeToCmd::real_execute() {

View file

@ -0,0 +1,13 @@
$NetBSD: patch-src_fluxbox.cc,v 1.1 2017/02/22 12:20:51 wiz Exp $
--- src/fluxbox.cc.orig 2015-02-08 10:44:45.000000000 +0000
+++ src/fluxbox.cc
@@ -1045,7 +1045,7 @@ void Fluxbox::saveWindowSearchGroup(Wind
}
void Fluxbox::saveGroupSearch(Window window, WinClient *data) {
- m_group_search.insert(pair<const Window, WinClient *>(window, data));
+ m_group_search.insert(std::multimap<Window, WinClient *>::value_type(window, data));
}

View file

@ -1,13 +0,0 @@
$NetBSD: patch-util_fbsetbg,v 1.1 2012/04/17 20:08:06 bsiegert Exp $
--- util/fbsetbg.orig Thu Dec 15 03:36:05 2011
+++ util/fbsetbg
@@ -526,7 +526,7 @@ fi
if [ ! -r "$wallpaper" ]; then
- if [ "$ignore_missing_wallpaper" == "true" ]; then
+ if [ "$ignore_missing_wallpaper" = "true" ]; then
exit 0
fi
message "Can't find wallpaper $wallpaper"