pixman: fix shell portability issue
Also move SUBST fragment into the patch-Makefile.in patch instead
This commit is contained in:
parent
8f5b373f2f
commit
d556fbf5b2
3 changed files with 30 additions and 8 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.73 2020/01/18 23:35:55 rillig Exp $
|
||||
# $NetBSD: Makefile,v 1.74 2020/03/12 19:19:52 tnn Exp $
|
||||
|
||||
DISTNAME= pixman-0.38.4
|
||||
PKGREVISION= 1
|
||||
|
@ -11,6 +11,8 @@ HOMEPAGE= https://xorg.freedesktop.org/
|
|||
COMMENT= Library of low-level pixel manipulation routines
|
||||
LICENSE= mit
|
||||
|
||||
CHECK_PORTABILITY_SKIP+= Makefile.am # already patched in Makefile.in
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
.if ${MACHINE_ARCH} == i386
|
||||
CONFIGURE_ARGS+= --disable-sse2
|
||||
|
@ -22,10 +24,4 @@ USE_TOOLS+= pkg-config perl
|
|||
PKGCONFIG_OVERRIDE+= pixman-1.pc.in
|
||||
PKGCONFIG_OVERRIDE+= pixman-1-uninstalled.pc.in
|
||||
|
||||
SUBST_CLASSES= subdirs
|
||||
SUBST_STAGE.subdirs= pre-configure
|
||||
SUBST_FILES.subdirs= Makefile.in
|
||||
SUBST_SED.subdirs= -e "s|pixman demos test|pixman|"
|
||||
SUBST_MESSAGE.subdirs= Skip building demos and test SUBDIRS
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,9 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.62 2019/04/10 20:24:09 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.63 2020/03/12 19:19:52 tnn Exp $
|
||||
|
||||
SHA1 (pixman-0.38.4.tar.bz2) = 87e1abc91ac4e5dfcc275f744f1d0ec3277ee7cd
|
||||
RMD160 (pixman-0.38.4.tar.bz2) = 106b73f871b5e0f8a739a47788fb9fd7a82cb8c5
|
||||
SHA512 (pixman-0.38.4.tar.bz2) = 0683b7f67caa0881b23188b7e6f8487c7e0a1257a912686616b7d862efd5a9efdb51641c81ec54905a6f6b1029d796ca4e25c0909db28fc29fa3617bf09f9cf9
|
||||
Size (pixman-0.38.4.tar.bz2) = 756898 bytes
|
||||
SHA1 (patch-Makefile.in) = 90ddfa2f96e4b2770f3f6c283267d7fb8a3524fb
|
||||
SHA1 (patch-ba) = 9bd8a7fd0cfbd280df06d69838d3d10ab1b51e23
|
||||
SHA1 (patch-bb) = d47b1857771b8addb6897d45782ba2735a7aacbd
|
||||
SHA1 (patch-bc) = 3e23e6c482ea193885f3f762af355ef2f692132b
|
||||
|
|
25
x11/pixman/patches/patch-Makefile.in
Normal file
25
x11/pixman/patches/patch-Makefile.in
Normal file
|
@ -0,0 +1,25 @@
|
|||
$NetBSD: patch-Makefile.in,v 1.1 2020/03/12 19:19:52 tnn Exp $
|
||||
|
||||
Skip building demos and test SUBDIRS
|
||||
Shell portability
|
||||
|
||||
--- Makefile.in.orig 2019-04-10 17:19:26.000000000 +0000
|
||||
+++ Makefile.in
|
||||
@@ -381,7 +381,7 @@ target_alias = @target_alias@
|
||||
top_build_prefix = @top_build_prefix@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
-SUBDIRS = pixman demos test
|
||||
+SUBDIRS = pixman
|
||||
pkgconfigdir = $(libdir)/pkgconfig
|
||||
pkgconfig_DATA = pixman-1.pc
|
||||
GPGKEY = 3892336E
|
||||
@@ -964,7 +964,7 @@ release-remove-old:
|
||||
$(RM) $(tar_gz) $(tar_bz2) $(HASHFILES) $(gpg_file)
|
||||
|
||||
ensure-prev:
|
||||
- @if [[ "$(PREV)" == "" ]]; then \
|
||||
+ @if [ "$(PREV)" = "" ]; then \
|
||||
echo "" && \
|
||||
echo "You must set the PREV variable on the make command line to" && \
|
||||
echo "the last version." && \
|
Loading…
Reference in a new issue