Don't use -O2 on a particular problem file on mipsel. Makes this work on
pmax.
This commit is contained in:
parent
f994d552f0
commit
d5b8bb9657
3 changed files with 28 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.17 2000/08/23 23:14:28 tron Exp $
|
||||
# $NetBSD: Makefile,v 1.18 2000/10/06 15:23:46 dmcmahill Exp $
|
||||
# FreeBSD Id: Makefile,v 1.12 1998/03/11 03:08:12 vanilla Exp
|
||||
#
|
||||
|
||||
|
@ -23,6 +23,8 @@ GNU_CONFIGURE= YES
|
|||
|
||||
CONFIGURE_ARGS+=--enable-japanese --enable-chinese
|
||||
CONFIGURE_ARGS+=--with-freetype-includes=${LOCALBASE}/include
|
||||
CONFIGURE_ENV+= CXXFLAGS=${CXXFLAGS}
|
||||
MAKE_ENV+= SED=${SED} ECHO=${ECHO}
|
||||
|
||||
post-install:
|
||||
${SED} 's|@@LOCALBASE@@|${LOCALBASE}|' \
|
||||
|
|
3
graphics/xpdf/files/patch-sum
Normal file
3
graphics/xpdf/files/patch-sum
Normal file
|
@ -0,0 +1,3 @@
|
|||
$NetBSD: patch-sum,v 1.5 2000/10/06 15:23:47 dmcmahill Exp $
|
||||
|
||||
MD5 (patch-aa) = 3a86e0b6e272e8698ba8a5f0c6bacb5a
|
22
graphics/xpdf/patches/patch-aa
Normal file
22
graphics/xpdf/patches/patch-aa
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-aa,v 1.3 2000/10/06 15:23:47 dmcmahill Exp $
|
||||
|
||||
Avoid a toolchain bug on mipsel noted in NetBSD-1.4.2/pmax
|
||||
|
||||
--- xpdf/Makefile.in.orig Tue Aug 15 01:01:52 2000
|
||||
+++ xpdf/Makefile.in Fri Oct 6 10:27:43 2000
|
||||
@@ -19,4 +19,7 @@
|
||||
CXXFLAGS = @CXXFLAGS@ @DEFS@ @OPTIONS@ -I$(GOOSRCDIR) -I$(LTKSRCDIR) -I$(srcdir) @X_CFLAGS@ @Xpm_CFLAGS@ @t1_CFLAGS@ @freetype_CFLAGS@
|
||||
|
||||
+CXXFLAGS_NOOPT!= ${ECHO} ${CXXFLAGS} | ${SED} 's/-O[0-9]*//g'
|
||||
+
|
||||
+
|
||||
LDFLAGS = @LDFLAGS@
|
||||
|
||||
@@ -258,4 +261,7 @@
|
||||
config.h Params.h TextOutputDev.h OutputDev.h XOutputDev.h T1Font.h \
|
||||
SFont.h TTFont.h XOutputFontInfo.h
|
||||
+.if (${MACHINE_ARCH} == "mipsel")
|
||||
+ ${CXX} ${CXXFLAGS_NOOPT} -c XOutputDev.cc
|
||||
+.endif
|
||||
XRef.o: ./XRef.cc ../goo/gmem.h Object.h ../goo/gtypes.h \
|
||||
../goo/GString.h Array.h Dict.h Stream.h Lexer.h Parser.h Decrypt.h \
|
Loading…
Reference in a new issue