Changes 0.8.1:
- Game mode editor for local game (allows you to choose some game options) - Team editor for local game (allows you to personalize characters names) - Better menus: tabs, basic keyboard control, more options,... - All characters redrawn: better graphisms, new positions, new clothes,... - 2 new skins: Pidgin and Suse - New maps: Lonely island and oktopus - New waters: add lava, dirty water,... - Better minimap - New weapon: slap - Some sounds added (thanks a lot to wesnoth project) - A lot of bug fixes - A lot of improvements (code and graphism) - Translations updates
This commit is contained in:
parent
5d2d680394
commit
d5c9d70b38
4 changed files with 909 additions and 451 deletions
|
@ -1,7 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.8 2008/06/02 16:57:37 drochner Exp $
|
||||
#
|
||||
# $NetBSD: Makefile,v 1.9 2008/10/06 15:49:34 adam Exp $
|
||||
|
||||
DISTNAME= wormux-0.8
|
||||
DISTNAME= wormux-0.8.1
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= http://download.gna.org/wormux/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
@ -12,11 +11,11 @@ COMMENT= Battle game
|
|||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LANGUAGES= c c++
|
||||
USE_PKGLOCALEDIR= yes
|
||||
USE_TOOLS+= pkg-config msgfmt
|
||||
USE_DIRS+= xdg-1.1
|
||||
USE_DIRS+= xdg-1.1
|
||||
USE_LANGUAGES= c c++
|
||||
USE_PKGLOCALEDIR= yes
|
||||
USE_TOOLS+= pkg-config msgfmt
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
.include "../../devel/SDL/buildlink3.mk"
|
||||
.include "../../graphics/SDL_image/buildlink3.mk"
|
||||
|
|
1269
games/wormux/PLIST
1269
games/wormux/PLIST
File diff suppressed because it is too large
Load diff
|
@ -1,6 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.2 2008/06/02 16:57:37 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.3 2008/10/06 15:49:34 adam Exp $
|
||||
|
||||
SHA1 (wormux-0.8.tar.bz2) = e23d06daa1b7a7f5c3400f0b2354541f91bb9c68
|
||||
RMD160 (wormux-0.8.tar.bz2) = 9df989b1a3b2730844c836cef97888648b963571
|
||||
Size (wormux-0.8.tar.bz2) = 56824903 bytes
|
||||
SHA1 (patch-aa) = db3da706e2f2dc5f6e6ef278ccf6cc51961ba929
|
||||
SHA1 (wormux-0.8.1.tar.bz2) = b5a9b22b382272a7d8b262c67718bbfccd8c9129
|
||||
RMD160 (wormux-0.8.1.tar.bz2) = 9c651105173cd283cec0961153b1a2389d19f571
|
||||
Size (wormux-0.8.1.tar.bz2) = 53499763 bytes
|
||||
|
|
|
@ -1,67 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.2 2008/06/02 16:57:37 drochner Exp $
|
||||
|
||||
--- src/map/tileitem.cpp.orig 2008-05-16 00:47:34.000000000 +0200
|
||||
+++ src/map/tileitem.cpp
|
||||
@@ -136,40 +136,42 @@ void TileItem_AlphaSoftware::Dig(const P
|
||||
buf += y * line_size;
|
||||
|
||||
//Empties each line of the tile horizontaly that are in the circle
|
||||
- while ( (uint) y <= center.y + radius + EXPLOSION_BORDER_SIZE&& y < CELL_SIZE.y )
|
||||
+ for (; (uint)y <= center.y + radius + EXPLOSION_BORDER_SIZE && y < CELL_SIZE.y;
|
||||
+ buf += line_size, y++)
|
||||
{
|
||||
//Abscisse distance from the center of the circle to the circle
|
||||
int dac = center.y - y;
|
||||
|
||||
- //Angle on the circle
|
||||
- float angle = asin( (float)dac / (float)radius);
|
||||
+ //Darken the border of the removed ground
|
||||
+ int bstart_x, bend_x, blenght;
|
||||
+ blenght = lrint(sqrt((radius + EXPLOSION_BORDER_SIZE) * (radius + EXPLOSION_BORDER_SIZE)
|
||||
+ - dac * dac));
|
||||
+
|
||||
+ if ((uint)abs(dac) > radius) {
|
||||
+ bstart_x = center.x - blenght;
|
||||
+ bend_x = center.x + blenght;
|
||||
+ Darken(bstart_x, bend_x, buf, bpp);
|
||||
+ continue;
|
||||
+ }
|
||||
|
||||
//Zone of the line which needs to be emptied
|
||||
- int start_x, end_x, lenght;
|
||||
- lenght = (int) ((float) radius * cos (angle));
|
||||
- lenght = lenght > 0 ? lenght : - lenght;
|
||||
- start_x = center.x - lenght;
|
||||
- lenght *= 2;
|
||||
- end_x = start_x + lenght;
|
||||
- Empty(start_x, end_x, buf, bpp);
|
||||
+ int lenght;
|
||||
+ lenght = lrint(sqrt(radius * radius - dac * dac));
|
||||
|
||||
- //Darken the border of the removed ground
|
||||
// Left half of the circle
|
||||
- int bstart_x, bend_x, blenght;
|
||||
- angle = asin( (float)dac / (float)(radius + EXPLOSION_BORDER_SIZE));
|
||||
- blenght = (int) ((float) (radius + EXPLOSION_BORDER_SIZE) * cos (angle));
|
||||
- blenght = blenght > 0 ? blenght : - blenght;
|
||||
bstart_x = center.x - blenght;
|
||||
- bend_x = bstart_x + (blenght - lenght/2);
|
||||
+ bend_x = center.x - lenght;
|
||||
Darken(bstart_x, bend_x, buf, bpp);
|
||||
|
||||
// Right half of the circle
|
||||
- bstart_x = center.x + lenght/2 + 1;
|
||||
- bend_x = bstart_x + (blenght - lenght/2);
|
||||
+ bstart_x = center.x + lenght;
|
||||
+ bend_x = center.x + blenght;
|
||||
Darken(bstart_x, bend_x, buf, bpp);
|
||||
|
||||
- buf += line_size;
|
||||
- y++;
|
||||
+ int start_x, end_x;
|
||||
+ start_x = center.x - lenght;
|
||||
+ end_x = center.x + lenght;
|
||||
+ Empty(start_x, end_x, buf, bpp);
|
||||
}
|
||||
}
|
||||
|
Loading…
Reference in a new issue