PkgSrc changes:

* recommended dependencies (from http://www.graphviz.org/Download_source.php)
  are now non-optional: that includes Pango, Cairo and GTS
* enabled Quartz support on macOS
* added Poppler and QT as options
* options are not nested in X11 any more; that allows building on Darwin
* PLIST has been sorted correctly
This commit is contained in:
adam 2017-05-22 11:19:20 +00:00
parent 06dabf7d85
commit d5ca8f6a14
6 changed files with 121 additions and 112 deletions

View file

@ -1,6 +1,7 @@
# $NetBSD: Makefile,v 1.165 2017/03/08 14:51:56 wiz Exp $
# $NetBSD: Makefile,v 1.166 2017/05/22 11:19:20 adam Exp $
DISTNAME= graphviz-2.40.1
PKGREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://www.graphviz.org/pub/graphviz/stable/SOURCES/
@ -23,9 +24,6 @@ CONFIGURE_ARGS+= --disable-python
CONFIGURE_ARGS+= --disable-ruby
CONFIGURE_ARGS+= --disable-sharp
CONFIGURE_ARGS+= --disable-r
CONFIGURE_ARGS+= --with-poppler=no
CONFIGURE_ARGS+= --with-gts=no
CONFIGURE_ARGS+= --with-qt=no
# build fails when PHP and/or Ruby are also installed
CONFIGURE_ENV+= ac_cv_prog_PHP=
CONFIGURE_ENV+= ac_cv_prog_RUBY=
@ -58,6 +56,13 @@ REPLACE_PERL+= config/config_perl.pl \
.include "../../mk/bsd.prefs.mk"
PLIST_VARS+= quartz
.if ${OPSYS} == "Darwin"
CONFIGURE_ARGS+= --with-quartz
PLIST.quartz= yes
.endif
.include "../../mk/compiler.mk"
.if !empty(CC_VERSION:Mgcc-2*)
BUILDLINK_TRANSFORM+= rm:-Wno-unused-parameter
@ -81,9 +86,10 @@ post-install:
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../devel/libltdl/buildlink3.mk"
#.include "../../devel/libltdl/convenience.mk"
.include "../../devel/pango/buildlink3.mk"
.include "../../fonts/fontconfig/buildlink3.mk"
#.include "../../mk/jpeg.buildlink3.mk"
#.include "../../graphics/png/buildlink3.mk"
.include "../../graphics/cairo/buildlink3.mk"
.include "../../graphics/gts/buildlink3.mk"
.include "../../textproc/expat/buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.48 2017/03/08 14:51:56 wiz Exp $
@comment $NetBSD: PLIST,v 1.49 2017/05/22 11:19:20 adam Exp $
bin/acyclic
bin/bcomps
bin/ccomps
@ -7,8 +7,8 @@ bin/cluster
${PLIST.gd}bin/diffimg
bin/dijkstra
bin/dot
bin/dot_builtins
bin/dot2gxl
bin/dot_builtins
${PLIST.x11}bin/dotty
bin/edgepaint
bin/fdp
@ -18,6 +18,7 @@ bin/graphml2gv
bin/gv2gml
bin/gv2gxl
bin/gvcolor
${PLIST.qt}bin/gvedit
bin/gvgen
bin/gvmap
bin/gvmap.sh
@ -38,7 +39,7 @@ bin/sfdp
bin/tred
bin/twopi
bin/unflatten
${PLIST.pangocairo}bin/vimdot
${PLIST.x11}bin/vimdot
include/graphviz/arith.h
include/graphviz/cdt.h
include/graphviz/cgraph.h
@ -71,12 +72,14 @@ lib/graphviz/libgvplugin_core.la
lib/graphviz/libgvplugin_dot_layout.la
${PLIST.gd}lib/graphviz/libgvplugin_gd.la
${PLIST.gtk}lib/graphviz/libgvplugin_gdk.la
${PLIST.gtk}lib/graphviz/libgvplugin_gtk.la
${PLIST.ghostscript}lib/graphviz/libgvplugin_gs.la
${PLIST.gtk}lib/graphviz/libgvplugin_gtk.la
lib/graphviz/libgvplugin_neato_layout.la
${PLIST.pangocairo}lib/graphviz/libgvplugin_pango.la
lib/graphviz/libgvplugin_pango.la
${PLIST.poppler}lib/graphviz/libgvplugin_poppler.la
${PLIST.quartz}lib/graphviz/libgvplugin_quartz.la
${PLIST.svg}lib/graphviz/libgvplugin_rsvg.la
${PLIST.pangocairo}lib/graphviz/libgvplugin_xlib.la
${PLIST.x11}lib/graphviz/libgvplugin_xlib.la
${PLIST.lua}lib/graphviz/lua/libgv_lua.la
${PLIST.ocaml}lib/graphviz/ocaml/META.gv
${PLIST.ocaml}lib/graphviz/ocaml/gv.a
@ -136,6 +139,7 @@ man/man1/graphml2gv.1
man/man1/gv2gml.1
man/man1/gv2gxl.1
man/man1/gvcolor.1
${PLIST.qt}man/man1/gvedit.1
man/man1/gvgen.1
man/man1/gvmap.1
man/man1/gvmap.sh.1
@ -409,6 +413,7 @@ share/graphviz/doc/pdf/edgepaint.1.pdf
share/graphviz/doc/pdf/expr.3.pdf
share/graphviz/doc/pdf/fdp.1.pdf
share/graphviz/doc/pdf/gc.1.pdf
${PLIST.qt}share/graphviz/doc/pdf/gvedit.1.pdf
${PLIST.tcl}${PLIST.gd}share/graphviz/doc/pdf/gdtclft.3tcl.pdf
share/graphviz/doc/pdf/gml2gv.1.pdf
share/graphviz/doc/pdf/graphml2gv.1.pdf
@ -445,8 +450,8 @@ share/graphviz/doc/pdf/pathplan.3.pdf
share/graphviz/doc/pdf/prune.pdf
share/graphviz/doc/pdf/sccmap.1.pdf
share/graphviz/doc/pdf/sfdp.1.pdf
share/graphviz/doc/pdf/smyrna.pdf
share/graphviz/doc/pdf/smyrna.1.pdf
share/graphviz/doc/pdf/smyrna.pdf
${PLIST.tcl}share/graphviz/doc/pdf/tcldot.3tcl.pdf
share/graphviz/doc/pdf/tred.1.pdf
share/graphviz/doc/pdf/twopi.1.pdf
@ -513,6 +518,7 @@ share/graphviz/graphs/undirected/Heawood.gv
share/graphviz/graphs/undirected/Petersen.gv
share/graphviz/graphs/undirected/ngk10_4.gv
share/graphviz/graphs/undirected/process.gv
${PLIST.qt}share/graphviz/gvedit/attrs.txt
share/graphviz/gvpr/addedges
share/graphviz/gvpr/addranks
share/graphviz/gvpr/addrings

View file

@ -1,4 +1,4 @@
# $NetBSD: buildlink3.mk,v 1.23 2013/06/04 22:16:19 tron Exp $
# $NetBSD: buildlink3.mk,v 1.24 2017/05/22 11:19:20 adam Exp $
BUILDLINK_TREE+= graphviz
@ -7,7 +7,7 @@ GRAPHVIZ_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.graphviz+= graphviz>=2.26.3
BUILDLINK_ABI_DEPENDS.graphviz+= graphviz>=2.26.3nb26
BUILDLINK_PKGSRCDIR.graphviz?= ../../graphics/graphviz
BUILDLINK_PKGSRCDIR.graphviz?= ../../graphics/graphviz
# doxygen PLIST varies with pangocairo of PKG_OPTIONS
pkgbase := graphviz

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.57 2017/03/08 14:51:56 wiz Exp $
$NetBSD: distinfo,v 1.58 2017/05/22 11:19:20 adam Exp $
SHA1 (graphviz-2.40.1.tar.gz) = 8a44d19bcdb50df1bd8e649de472ebf868468888
RMD160 (graphviz-2.40.1.tar.gz) = 8fc103fc519e07e9db522ec2f748838571c71acf
@ -10,4 +10,5 @@ SHA1 (patch-configure) = 2e541e065a594093f54e47d5a24972367405bec1
SHA1 (patch-configure.ac) = c02e7e2ab65cb5df8bcf15c1bbed0e673480bd3f
SHA1 (patch-lib_gvc_Makefile.in) = f469c2dc53cf9af5b1e86f5da04bf9575685bd41
SHA1 (patch-plugin_gs_gvloadimage__gs.c) = b5b46a1e7dc52f163526c5b8b7e1b893d5500e3c
SHA1 (patch-plugin_quartz_Makefile.in) = 1712a43849137c23e94f3eeb2ae9b86938bd4980
SHA1 (patch-plugin_xlib_gvdevice__xlib.c) = 932c337dcf9cb53d52f24c6c20818038ed169cd0

View file

@ -1,13 +1,12 @@
# $NetBSD: options.mk,v 1.23 2017/03/08 14:51:56 wiz Exp $
# $NetBSD: options.mk,v 1.24 2017/05/22 11:19:20 adam Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.graphviz
PKG_SUPPORTED_OPTIONS= gd ghostscript gtk lua ocaml pangocairo svg tcl x11 perl # guile does not build with guile20
PKG_SUGGESTED_OPTIONS= gd gtk lua pangocairo perl tcl x11
PKG_SUPPORTED_OPTIONS= gd ghostscript gtk gts lua ocaml poppler qt svg tcl x11 perl # guile does not build with guile20
PKG_SUGGESTED_OPTIONS= gd gtk lua perl tcl x11
# Explanation of consequence of options, to help those trying to slim down:
# guile ocaml lua tcl perl: extension language support
# x11: Omits all linking with x11, which means x11 graphics supports as
# well as x11 frontend support.
# pangocairo: basic ps/pdf support.
# gtk: basic graphic format support (in addition to gd, which isn't
# maintained anymore)
# svg: Omitting loses svg support. librsvg has large dependencies
@ -17,104 +16,68 @@ PKG_SUGGESTED_OPTIONS= gd gtk lua pangocairo perl tcl x11
.include "../../mk/bsd.options.mk"
PLIST_VARS+= gd ghostscript gtk guile lua ocaml pangocairo perl svg tcl x11
.if !empty(PKG_OPTIONS:Mx11)
.include "../../mk/xaw.buildlink3.mk"
CONFIGURE_ENV+= X11BASE=${X11BASE}
PLIST.x11= yes
. if !empty(PKG_OPTIONS:Mpangocairo)
. include "../../devel/pango/buildlink3.mk"
. include "../../graphics/cairo/buildlink3.mk"
PLIST.pangocairo= yes
. if !empty(PKG_OPTIONS:Mghostscript)
. include "../../print/ghostscript/buildlink3.mk"
PLIST.ghostscript= yes
. else
CONFIGURE_ARGS+= --without-ghostscript
. endif
. if !empty(PKG_OPTIONS:Mgtk)
. include "../../x11/gtk2/buildlink3.mk"
PLIST.gtk= yes
. else
CONFIGURE_ARGS+= --without-gdk-pixbuf
CONFIGURE_ARGS+= --without-gtk
CONFIGURE_ARGS+= --without-gnomeui
. endif
. if !empty(PKG_OPTIONS:Msvg)
. include "../../graphics/librsvg/buildlink3.mk"
PLIST.svg= yes
. else
CONFIGURE_ARGS+= --without-rsvg
. endif
. else
# + x11, -pangocairo
CONFIGURE_ARGS+= --without-pangocairo
. if !empty(PKG_OPTIONS:Mghostscript)
PKG_FAIL_REASON+= "option ghostscript needs option pangocairo"
. endif
CONFIGURE_ARGS+= --without-ghostscript
. if !empty(PKG_OPTIONS:Mgtk)
PKG_FAIL_REASON+= "option gtk needs option pangocairo"
. endif
CONFIGURE_ARGS+= --without-gdk-pixbuf
CONFIGURE_ARGS+= --without-gtk
CONFIGURE_ARGS+= --without-gnomeui
. if !empty(PKG_OPTIONS:Msvg)
PKG_FAIL_REASON+= "option svg needs option pangocairo"
. endif
CONFIGURE_ARGS+= --without-rsvg
. endif
.else
# - x11
CONFIGURE_ARGS+= --without-x
. if !empty(PKG_OPTIONS:Mpangocairo)
PKG_FAIL_REASON+= "option pangocairo needs option x11"
. endif
CONFIGURE_ARGS+= --without-pangocairo
. if !empty(PKG_OPTIONS:Mghostscript)
PKG_FAIL_REASON+= "option ghostscript needs option pangocairo and x11"
. endif
CONFIGURE_ARGS+= --without-ghostscript
. if !empty(PKG_OPTIONS:Mgtk)
PKG_FAIL_REASON+= "option gtk needs option pangocairo and x11"
. endif
CONFIGURE_ARGS+= --without-gdk-pixbuf
CONFIGURE_ARGS+= --without-gtk
CONFIGURE_ARGS+= --without-gnomeui
. if !empty(PKG_OPTIONS:Msvg)
PKG_FAIL_REASON+= "option svg needs option pangocairo and x11"
. endif
CONFIGURE_ARGS+= --without-rsvg
.endif
PLIST_VARS+= gd ghostscript gtk guile lua ocaml perl poppler qt svg tcl x11
.if !empty(PKG_OPTIONS:Mgd)
.include "../../graphics/gd/buildlink3.mk"
. include "../../graphics/gd/buildlink3.mk"
PLIST.gd= yes
.else
CONFIGURE_ARGS+= --without-libgd
CONFIGURE_ARGS+= --without-mylibgd
.endif
.if !empty(PKG_OPTIONS:Mghostscript)
. include "../../print/ghostscript/buildlink3.mk"
PLIST.ghostscript= yes
.else
CONFIGURE_ARGS+= --without-ghostscript
.endif
.if !empty(PKG_OPTIONS:Mgtk)
. include "../../x11/gtk2/buildlink3.mk"
PLIST.gtk= yes
.else
CONFIGURE_ARGS+= --without-gdk-pixbuf
CONFIGURE_ARGS+= --without-gtk
CONFIGURE_ARGS+= --without-gnomeui
.endif
.if !empty(PKG_OPTIONS:Mpoppler)
. include "../../print/poppler-glib/buildlink3.mk"
PLIST.poppler= yes
.else
CONFIGURE_ARGS+= --without-poppler
.endif
.if !empty(PKG_OPTIONS:Mqt)
. include "../../x11/qt4-libs/buildlink3.mk"
. include "../../x11/qt4-tools/buildlink3.mk"
PLIST.qt= yes
.else
CONFIGURE_ARGS+= --without-qt
.endif
.if !empty(PKG_OPTIONS:Msvg)
. include "../../graphics/librsvg/buildlink3.mk"
PLIST.svg= yes
.else
CONFIGURE_ARGS+= --without-rsvg
.endif
.if !empty(PKG_OPTIONS:Mx11)
. include "../../mk/xaw.buildlink3.mk"
CONFIGURE_ENV+= X11BASE=${X11BASE}
PLIST.x11= yes
.else
CONFIGURE_ARGS+= --without-x
.endif
USING_SWIG= no
.if !empty(PKG_OPTIONS:Mlua)
USING_SWIG= yes
.include "../../lang/lua/tool.mk"
.include "../../lang/lua/buildlink3.mk"
. include "../../lang/lua/tool.mk"
. include "../../lang/lua/buildlink3.mk"
PLIST.lua= yes
.else
CONFIGURE_ARGS+= --disable-lua
@ -122,7 +85,7 @@ CONFIGURE_ARGS+= --disable-lua
.if !empty(PKG_OPTIONS:Mocaml)
USING_SWIG= yes
.include "../../lang/ocaml/buildlink3.mk"
. include "../../lang/ocaml/buildlink3.mk"
PLIST.ocaml= yes
.else
CONFIGURE_ARGS+= --disable-ocaml
@ -130,8 +93,8 @@ CONFIGURE_ARGS+= --disable-ocaml
.if !empty(PKG_OPTIONS:Mtcl)
USING_SWIG= yes
.include "../../lang/tcl/Makefile.version"
.include "../../x11/tk/buildlink3.mk"
. include "../../lang/tcl/Makefile.version"
. include "../../x11/tk/buildlink3.mk"
CONFIGURE_ENV+= TCLCONFIG=${TCLCONFIG_SH:Q}
CONFIGURE_ENV+= TKCONFIG=${TKCONFIG_SH:Q}
CONFIGURE_ARGS+= --with-wish=${WISH}
@ -144,7 +107,7 @@ CONFIGURE_ARGS+= --disable-tcl
.if !empty(PKG_OPTIONS:Mguile)
USING_SWIG= yes
.include "../../lang/guile20/buildlink3.mk"
. include "../../lang/guile20/buildlink3.mk"
CONFIGURE_ARGS+= --enable-guile
PLIST.guile= yes
.else
@ -153,7 +116,7 @@ CONFIGURE_ARGS+= --disable-guile
.if !empty(PKG_OPTIONS:Mperl)
USING_SWIG= yes
.include "../../lang/perl5/buildlink3.mk"
. include "../../lang/perl5/buildlink3.mk"
CONFIGURE_ARGS+= --enable-perl
PLIST.perl= yes
USE_TOOLS+=perl
@ -162,7 +125,7 @@ CONFIGURE_ARGS+= --disable-perl
.endif
.if !empty(USING_SWIG:Myes)
.include "../../devel/swig/buildlink3.mk"
. include "../../devel/swig/buildlink3.mk"
.else
CONFIGURE_ARGS+= --disable-swig
.endif

View file

@ -0,0 +1,33 @@
$NetBSD: patch-plugin_quartz_Makefile.in,v 1.1 2017/05/22 11:19:20 adam Exp $
Use libtool tags for obj-c files.
--- plugin/quartz/Makefile.in.orig 2017-05-22 08:57:46.000000000 +0000
+++ plugin/quartz/Makefile.in
@@ -138,7 +138,7 @@ AM_V_lt = $(am__v_lt_@AM_V@)
am__v_lt_ = $(am__v_lt_@AM_DEFAULT_V@)
am__v_lt_0 = --silent
am__v_lt_1 =
-libgvplugin_quartz_la_LINK = $(LIBTOOL) $(AM_V_lt) $(AM_LIBTOOLFLAGS) \
+libgvplugin_quartz_la_LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) \
$(LIBTOOLFLAGS) --mode=link $(OBJCLD) $(AM_OBJCFLAGS) \
$(OBJCFLAGS) $(libgvplugin_quartz_la_LDFLAGS) $(LDFLAGS) -o $@
@WITH_QUARTZ_TRUE@@WITH_WIN32_FALSE@am_libgvplugin_quartz_la_rpath = \
@@ -188,7 +188,7 @@ am__v_CCLD_0 = @echo " CCLD " $@;
am__v_CCLD_1 =
OBJCCOMPILE = $(OBJC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
$(AM_CPPFLAGS) $(CPPFLAGS) $(AM_OBJCFLAGS) $(OBJCFLAGS)
-LTOBJCCOMPILE = $(LIBTOOL) $(AM_V_lt) $(AM_LIBTOOLFLAGS) \
+LTOBJCCOMPILE = $(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) \
$(LIBTOOLFLAGS) --mode=compile $(OBJC) $(DEFS) \
$(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) \
$(AM_OBJCFLAGS) $(OBJCFLAGS)
@@ -197,7 +197,7 @@ am__v_OBJC_ = $(am__v_OBJC_@AM_DEFAULT_V
am__v_OBJC_0 = @echo " OBJC " $@;
am__v_OBJC_1 =
OBJCLD = $(OBJC)
-OBJCLINK = $(LIBTOOL) $(AM_V_lt) $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
+OBJCLINK = $(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
--mode=link $(OBJCLD) $(AM_OBJCFLAGS) $(OBJCFLAGS) \
$(AM_LDFLAGS) $(LDFLAGS) -o $@
AM_V_OBJCLD = $(am__v_OBJCLD_@AM_V@)