Switch to use libnotify07.
Bump PKGREVISION.
This commit is contained in:
parent
a8d2810c3a
commit
d5da0d0ab1
3 changed files with 27 additions and 4 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.44 2013/06/06 12:55:04 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.45 2013/08/14 08:01:48 obache Exp $
|
||||
#
|
||||
|
||||
DISTNAME= gnome-power-manager-2.24.4
|
||||
PKGREVISION= 34
|
||||
PKGREVISION= 35
|
||||
CATEGORIES= sysutils gnome
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/gnome-power-manager/2.24/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
@ -47,7 +47,7 @@ BUILDLINK_TRANSFORM+= rm:-Werror
|
|||
.include "../../security/policykit-gnome/buildlink3.mk"
|
||||
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
|
||||
.include "../../sysutils/hal/buildlink3.mk"
|
||||
.include "../../sysutils/libnotify/buildlink3.mk"
|
||||
.include "../../sysutils/libnotify07/buildlink3.mk"
|
||||
.include "../../sysutils/dbus-glib/buildlink3.mk"
|
||||
.include "../../textproc/gnome-doc-utils/buildlink3.mk"
|
||||
.include "../../x11/gnome-panel/buildlink3.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.5 2012/01/20 17:02:55 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.6 2013/08/14 08:01:48 obache Exp $
|
||||
|
||||
SHA1 (gnome-power-manager-2.24.4.tar.bz2) = ea9c895a78761c59fea13701e074946a20c50fe6
|
||||
RMD160 (gnome-power-manager-2.24.4.tar.bz2) = c0b16ead610ffeae9d801f8bde44507464808e53
|
||||
|
@ -8,3 +8,4 @@ SHA1 (patch-ab) = 1d095932a52528148703ce63bfab81f3a2f316fd
|
|||
SHA1 (patch-ac) = 57ade4298abd05dc57af06347dc96dea4683eb51
|
||||
SHA1 (patch-ad) = b0a68283600b33f730c3b5b07128858c96c04394
|
||||
SHA1 (patch-src-gpm-array-float.h) = e9592fdab1c0ee0beedd49c524ae2fdd4a1eea47
|
||||
SHA1 (patch-src_gpm-notify.c) = d8669db0c44405fe65f0b92f74d43186e3e8d63b
|
||||
|
|
22
sysutils/gnome-power-manager/patches/patch-src_gpm-notify.c
Normal file
22
sysutils/gnome-power-manager/patches/patch-src_gpm-notify.c
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-src_gpm-notify.c,v 1.1 2013/08/14 08:01:48 obache Exp $
|
||||
|
||||
* for libnotify-0.7 API change
|
||||
|
||||
--- src/gpm-notify.c.orig 2008-09-04 10:05:15.000000000 +0000
|
||||
+++ src/gpm-notify.c
|
||||
@@ -103,14 +103,7 @@ gpm_notify_create (GpmNotify *notify,
|
||||
// notify->priv->libnotify = NULL;
|
||||
}
|
||||
|
||||
- if (notify->priv->status_icon != NULL &&
|
||||
- gtk_status_icon_get_visible (notify->priv->status_icon)) {
|
||||
- notify->priv->libnotify = notify_notification_new_with_status_icon (title, content,
|
||||
- msgicon,
|
||||
- notify->priv->status_icon);
|
||||
- } else {
|
||||
- notify->priv->libnotify = notify_notification_new (title, content, msgicon, NULL);
|
||||
- }
|
||||
+ notify->priv->libnotify = notify_notification_new (title, content, msgicon);
|
||||
|
||||
if (timeout == GPM_NOTIFY_TIMEOUT_NEVER) {
|
||||
notify_notification_set_timeout (notify->priv->libnotify, 0);
|
Loading…
Reference in a new issue