Remove an unused variable that breaks the clang build.

This commit is contained in:
joerg 2013-10-26 23:24:40 +00:00
parent aa99a1cefc
commit d64faf1979
2 changed files with 15 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.1 2013/10/21 15:12:38 ryoon Exp $
$NetBSD: distinfo,v 1.2 2013/10/26 23:24:40 joerg Exp $
SHA1 (sdcc-src-3.3.0.tar.bz2) = beed1b8c73f13344e018f48b1563ff2a948b70cf
RMD160 (sdcc-src-3.3.0.tar.bz2) = 464b5aae6242e0da0181e9050b52949ae176de00
@ -15,3 +15,4 @@ SHA1 (patch-support_cpp_Makefile.in) = 7bc2a33eb42afd18930ddaf6d75b981135fca36f
SHA1 (patch-support_makebin_Makefile_in) = 6045bc4a0870b57f74c597b4a6215bf3accd1a46
SHA1 (patch-support_scripts_Makefile.in) = f292001be4a7dc0a629529087838138e1bb52161
SHA1 (patch-support_sdbinutils_Makefile.in) = 5d8fce39c55d44340a6431426aa01690e39b7c67
SHA1 (patch-support_sdbinutils_bfd_asxxxx.c) = 3163003fec4ea548dc89ce35ef0e9b7ed53c67f9

View file

@ -0,0 +1,13 @@
$NetBSD: patch-support_sdbinutils_bfd_asxxxx.c,v 1.1 2013/10/26 23:24:40 joerg Exp $
--- support/sdbinutils/bfd/asxxxx.c.orig 2013-10-23 20:53:26.000000000 +0000
+++ support/sdbinutils/bfd/asxxxx.c
@@ -166,7 +166,7 @@
/* Macros for converting between hex and binary. */
-static const char digs[] = "0123456789ABCDEF";
+/* static const char digs[] = "0123456789ABCDEF"; */
#define NIBBLE(x) hex_value(x)
#define HEX(buffer) ((NIBBLE ((buffer)[0])<<4) + NIBBLE ((buffer)[1]))