Replace uses of -fno-builtin with -ffreestanding. -ffreestanding also
implies -fno-builtin, but also conveys additional information ("not in a hosted environment"). This is 1/2 of the fix for PR toolchain/19265.
This commit is contained in:
parent
f17b2a4192
commit
d6c3cd26ba
7 changed files with 391 additions and 1 deletions
|
@ -1,6 +1,12 @@
|
|||
$NetBSD: distinfo,v 1.3 2003/01/24 23:49:54 jmmv Exp $
|
||||
$NetBSD: distinfo,v 1.4 2003/03/14 23:35:24 thorpej Exp $
|
||||
|
||||
SHA1 (grub-0.93.tar.gz) = 51cc79b0088f8e0e3260e33dc5b2ea5055bfc8f8
|
||||
Size (grub-0.93.tar.gz) = 891032 bytes
|
||||
SHA1 (patch-aa) = f2b6a1c0ec11c1c01f39bf6241291fc0c3879e34
|
||||
SHA1 (patch-ab) = 274f05f518de51b708102ec853641e237fd40990
|
||||
SHA1 (patch-ac) = 891a04da17ae13ad10227d137448eb5d028759ca
|
||||
SHA1 (patch-ad) = 8a39ae6da142493672d11521fd99594a6161a1d0
|
||||
SHA1 (patch-ae) = fc41e5b3db06d3e2fa33913946e1eb31a93f435f
|
||||
SHA1 (patch-af) = 0955009cd1b09b766b3aab5517b36002c6c08401
|
||||
SHA1 (patch-ag) = ecbbcf164039cbc047b247036fa183bb8ae08a6f
|
||||
SHA1 (patch-ah) = e71b2aa77e597e1501bcee9cb27123793a22dda7
|
||||
|
|
166
sysutils/grub/patches/patch-ac
Normal file
166
sysutils/grub/patches/patch-ac
Normal file
|
@ -0,0 +1,166 @@
|
|||
$NetBSD: patch-ac,v 1.1 2003/03/14 23:35:25 thorpej Exp $
|
||||
|
||||
--- netboot/Makefile.am.orig 2003-03-14 15:21:01.000000000 -0800
|
||||
+++ netboot/Makefile.am 2003-03-14 15:21:18.000000000 -0800
|
||||
@@ -19,7 +19,7 @@
|
||||
ni5010.c ns8390.c ns8390.h otulip.c otulip.h rtl8139.c \
|
||||
sis900.c sis900.h sk_g16.c sk_g16.h smc9000.c smc9000.h \
|
||||
tiara.c tlan.c tulip.c via-rhine.c w89c840.c
|
||||
-libdrivers_a_CFLAGS = $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+libdrivers_a_CFLAGS = $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
-DFSYS_TFTP=1 $(NET_CFLAGS) $(NET_EXTRAFLAGS)
|
||||
# Filled by configure.
|
||||
libdrivers_a_LIBADD = @NETBOOT_DRIVERS@
|
||||
@@ -60,127 +60,127 @@
|
||||
# Is it really necessary to specify dependecies explicitly?
|
||||
$(3c509_drivers): 3c509.c 3c509.h
|
||||
$(3c509_drivers): %.o: 3c509.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(3c595_drivers): 3c595.c 3c595.h
|
||||
$(3c595_drivers): %.o: 3c595.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(3c90x_drivers): 3c90x.c
|
||||
$(3c90x_drivers): %.o: 3c90x.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(cs89x0_drivers): cs89x0.c cs89x0.h
|
||||
$(cs89x0_drivers): %.o: cs89x0.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(davicom_drivers): davicom.c
|
||||
$(davicom_drivers): %.o: davicom.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(depca_drivers): depca.c
|
||||
$(depca_drivers): %.o: depca.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(eepro_drivers): eepro.c
|
||||
$(eepro_drivers): %.o: eepro.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(eepro100_drivers): eepro100.c
|
||||
$(eepro100_drivers): %.o: eepro100.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(epic100_drivers): epic100.c epic100.h
|
||||
$(epic100_drivers): %.o: epic100.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
#$(fa311_drivers): fa311.c
|
||||
#$(fa311_drivers): %.o: fa311.c
|
||||
-# $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+# $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
# $(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(i82586_drivers): i82586.c
|
||||
$(i82586_drivers): %.o: i82586.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(lance_drivers): lance.c
|
||||
$(lance_drivers): %.o: lance.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(natsemi_drivers): natsemi.c
|
||||
$(natsemi_drivers): %.o: natsemi.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(ni5010_drivers): ni5010.c
|
||||
$(ni5010_drivers): %.o: ni5010.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(ns8390_drivers): ns8390.c ns8390.h
|
||||
$(ns8390_drivers): %.o: ns8390.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(otulip_drivers): otulip.c otulip.h
|
||||
$(otulip_drivers): %.o: otulip.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(rtl8139_drivers): rtl8139.c
|
||||
$(rtl8139_drivers): %.o: rtl8139.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(sis900_drivers): sis900.c
|
||||
$(sis900_drivers): %.o: sis900.c sis900.h
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(sk_g16_drivers): sk_g16.c sk_g16.h
|
||||
$(sk_g16_drivers): %.o: sk_g16.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(smc9000_drivers): smc9000.c smc9000.h
|
||||
$(smc9000_drivers): %.o: smc9000.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(tiara_drivers): tiara.c
|
||||
$(tiara_drivers): %.o: tiara.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
#$(tlan_drivers): tlan.c
|
||||
#$(tlan_drivers): %.o: tlan.c
|
||||
-# $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+# $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
# $(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(tulip_drivers): tulip.c
|
||||
$(tulip_drivers): %.o: tulip.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(via_rhine_drivers): via-rhine.c
|
||||
$(via_rhine_drivers): %.o: via-rhine.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(w89c840_drivers): w89c840.c
|
||||
$(w89c840_drivers): %.o: w89c840.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
# Per-object flags.
|
166
sysutils/grub/patches/patch-ad
Normal file
166
sysutils/grub/patches/patch-ad
Normal file
|
@ -0,0 +1,166 @@
|
|||
$NetBSD: patch-ad,v 1.1 2003/03/14 23:35:25 thorpej Exp $
|
||||
|
||||
--- netboot/Makefile.in.orig 2003-03-14 15:21:22.000000000 -0800
|
||||
+++ netboot/Makefile.in 2003-03-14 15:21:31.000000000 -0800
|
||||
@@ -107,7 +107,7 @@
|
||||
sis900.c sis900.h sk_g16.c sk_g16.h smc9000.c smc9000.h \
|
||||
tiara.c tlan.c tulip.c via-rhine.c w89c840.c
|
||||
|
||||
-libdrivers_a_CFLAGS = $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+libdrivers_a_CFLAGS = $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
-DFSYS_TFTP=1 $(NET_CFLAGS) $(NET_EXTRAFLAGS)
|
||||
|
||||
# Filled by configure.
|
||||
@@ -852,127 +852,127 @@
|
||||
# Is it really necessary to specify dependecies explicitly?
|
||||
$(3c509_drivers): 3c509.c 3c509.h
|
||||
$(3c509_drivers): %.o: 3c509.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(3c595_drivers): 3c595.c 3c595.h
|
||||
$(3c595_drivers): %.o: 3c595.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(3c90x_drivers): 3c90x.c
|
||||
$(3c90x_drivers): %.o: 3c90x.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(cs89x0_drivers): cs89x0.c cs89x0.h
|
||||
$(cs89x0_drivers): %.o: cs89x0.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(davicom_drivers): davicom.c
|
||||
$(davicom_drivers): %.o: davicom.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(depca_drivers): depca.c
|
||||
$(depca_drivers): %.o: depca.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(eepro_drivers): eepro.c
|
||||
$(eepro_drivers): %.o: eepro.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(eepro100_drivers): eepro100.c
|
||||
$(eepro100_drivers): %.o: eepro100.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(epic100_drivers): epic100.c epic100.h
|
||||
$(epic100_drivers): %.o: epic100.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
#$(fa311_drivers): fa311.c
|
||||
#$(fa311_drivers): %.o: fa311.c
|
||||
-# $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+# $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
# $(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(i82586_drivers): i82586.c
|
||||
$(i82586_drivers): %.o: i82586.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(lance_drivers): lance.c
|
||||
$(lance_drivers): %.o: lance.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(natsemi_drivers): natsemi.c
|
||||
$(natsemi_drivers): %.o: natsemi.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(ni5010_drivers): ni5010.c
|
||||
$(ni5010_drivers): %.o: ni5010.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(ns8390_drivers): ns8390.c ns8390.h
|
||||
$(ns8390_drivers): %.o: ns8390.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(otulip_drivers): otulip.c otulip.h
|
||||
$(otulip_drivers): %.o: otulip.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(rtl8139_drivers): rtl8139.c
|
||||
$(rtl8139_drivers): %.o: rtl8139.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(sis900_drivers): sis900.c
|
||||
$(sis900_drivers): %.o: sis900.c sis900.h
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(sk_g16_drivers): sk_g16.c sk_g16.h
|
||||
$(sk_g16_drivers): %.o: sk_g16.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(smc9000_drivers): smc9000.c smc9000.h
|
||||
$(smc9000_drivers): %.o: smc9000.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(tiara_drivers): tiara.c
|
||||
$(tiara_drivers): %.o: tiara.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
#$(tlan_drivers): tlan.c
|
||||
#$(tlan_drivers): %.o: tlan.c
|
||||
-# $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+# $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
# $(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(tulip_drivers): tulip.c
|
||||
$(tulip_drivers): %.o: tulip.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(via_rhine_drivers): via-rhine.c
|
||||
$(via_rhine_drivers): %.o: via-rhine.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
|
||||
$(w89c840_drivers): w89c840.c
|
||||
$(w89c840_drivers): %.o: w89c840.c
|
||||
- $(COMPILE) $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+ $(COMPILE) $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NET_EXTRAFLAGS) $($(basename $@)_o_CFLAGS) -o $@ -c $<
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||
# Otherwise a system limit (for SysV at least) may be exceeded.
|
13
sysutils/grub/patches/patch-ae
Normal file
13
sysutils/grub/patches/patch-ae
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ae,v 1.1 2003/03/14 23:35:26 thorpej Exp $
|
||||
|
||||
--- stage1/Makefile.am.orig 2003-03-14 15:23:00.000000000 -0800
|
||||
+++ stage1/Makefile.am 2003-03-14 15:23:10.000000000 -0800
|
||||
@@ -4,7 +4,7 @@
|
||||
CLEANFILES = $(nodist_pkgdata_DATA)
|
||||
|
||||
# We can't use builtins or standard includes.
|
||||
-AM_ASFLAGS = $(STAGE1_CFLAGS) -fno-builtin -nostdinc
|
||||
+AM_ASFLAGS = $(STAGE1_CFLAGS) -ffreestanding -nostdinc
|
||||
LDFLAGS = -nostdlib -Wl,-N,-Ttext,7C00
|
||||
|
||||
noinst_PROGRAMS = stage1.exec
|
13
sysutils/grub/patches/patch-af
Normal file
13
sysutils/grub/patches/patch-af
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-af,v 1.1 2003/03/14 23:35:26 thorpej Exp $
|
||||
|
||||
--- stage1/Makefile.in.orig 2003-03-14 15:23:32.000000000 -0800
|
||||
+++ stage1/Makefile.in 2003-03-14 15:23:47.000000000 -0800
|
||||
@@ -91,7 +91,7 @@
|
||||
CLEANFILES = $(nodist_pkgdata_DATA)
|
||||
|
||||
# We can't use builtins or standard includes.
|
||||
-AM_ASFLAGS = $(STAGE1_CFLAGS) -fno-builtin -nostdinc
|
||||
+AM_ASFLAGS = $(STAGE1_CFLAGS) -ffreestanding -nostdinc
|
||||
LDFLAGS = -nostdlib -Wl,-N,-Ttext,7C00
|
||||
|
||||
noinst_PROGRAMS = stage1.exec
|
13
sysutils/grub/patches/patch-ag
Normal file
13
sysutils/grub/patches/patch-ag
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ag,v 1.1 2003/03/14 23:35:26 thorpej Exp $
|
||||
|
||||
--- stage2/Makefile.am.orig 2003-03-14 15:24:38.000000000 -0800
|
||||
+++ stage2/Makefile.am 2003-03-14 15:24:48.000000000 -0800
|
||||
@@ -75,7 +75,7 @@
|
||||
HERCULES_FLAGS =
|
||||
endif
|
||||
|
||||
-STAGE2_COMPILE = $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+STAGE2_COMPILE = $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NETBOOT_FLAGS) $(SERIAL_FLAGS) $(HERCULES_FLAGS)
|
||||
|
||||
STAGE1_5_LINK = -nostdlib -Wl,-N -Wl,-Ttext -Wl,2000
|
13
sysutils/grub/patches/patch-ah
Normal file
13
sysutils/grub/patches/patch-ah
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ah,v 1.1 2003/03/14 23:35:26 thorpej Exp $
|
||||
|
||||
--- stage2/Makefile.in.orig 2003-03-14 15:24:54.000000000 -0800
|
||||
+++ stage2/Makefile.in 2003-03-14 15:25:06.000000000 -0800
|
||||
@@ -158,7 +158,7 @@
|
||||
@HERCULES_SUPPORT_TRUE@HERCULES_FLAGS = -DSUPPORT_HERCULES=1
|
||||
@HERCULES_SUPPORT_FALSE@HERCULES_FLAGS =
|
||||
|
||||
-STAGE2_COMPILE = $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
|
||||
+STAGE2_COMPILE = $(STAGE2_CFLAGS) -ffreestanding -nostdinc \
|
||||
$(NETBOOT_FLAGS) $(SERIAL_FLAGS) $(HERCULES_FLAGS)
|
||||
|
||||
|
Loading…
Reference in a new issue