Fix a bug on some platforms which causes the installation to fail.
Thanks to Peter Avalos for debugging and joerg@ for pointing it out.
This commit is contained in:
parent
0bcb9a14df
commit
d71ecf387a
4 changed files with 26 additions and 12 deletions
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.2 2008/07/13 17:55:38 tonnerre Exp $
|
||||
$NetBSD: distinfo,v 1.3 2008/09/17 22:49:24 adrianp Exp $
|
||||
|
||||
SHA1 (pear/MDB2-2.4.1.tgz) = 91e12cc3ae6203db6cf5b6bb42c7befa11777800
|
||||
RMD160 (pear/MDB2-2.4.1.tgz) = 2298a0c5963779f7d42f268d79ed607835413e4b
|
||||
Size (pear/MDB2-2.4.1.tgz) = 119790 bytes
|
||||
SHA1 (patch-aa) = e1ccd0bef185d66b7bfbe66336d3ae5a5b34d2b3
|
||||
SHA1 (patch-aa) = 2b8f0f9140ed42e9e7118ba9273be83a401e823f
|
||||
SHA1 (patch-ab) = 99b150c34cce6566dbbe9e1e2c4c6a241c1145de
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-aa,v 1.1 2008/07/13 17:55:38 tonnerre Exp $
|
||||
$NetBSD: patch-aa,v 1.2 2008/09/17 22:49:24 adrianp Exp $
|
||||
|
||||
--- MDB2.php.orig 2007-05-03 20:58:15.000000000 +0200
|
||||
+++ MDB2.php 2008-07-13 18:44:59.000000000 +0200
|
||||
@@ -1156,6 +1156,7 @@
|
||||
--- MDB2.php.orig 2007-05-03 19:58:15.000000000 +0100
|
||||
+++ MDB2.php
|
||||
@@ -1156,6 +1156,7 @@ class MDB2_Driver_Common extends PEAR
|
||||
'datatype_map' => array(),
|
||||
'datatype_map_callback' => array(),
|
||||
'nativetype_map_callback' => array(),
|
||||
|
@ -10,3 +10,10 @@ $NetBSD: patch-aa,v 1.1 2008/07/13 17:55:38 tonnerre Exp $
|
|||
);
|
||||
|
||||
/**
|
||||
@@ -4268,4 +4269,4 @@ function MDB2_defaultDebugOutput(&$db, $
|
||||
}
|
||||
|
||||
// }}}
|
||||
-?>
|
||||
\ No newline at end of file
|
||||
+?>
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.2 2008/07/13 17:55:38 tonnerre Exp $
|
||||
$NetBSD: distinfo,v 1.3 2008/09/17 22:40:06 adrianp Exp $
|
||||
|
||||
SHA1 (pear/MDB2_Driver_mysql-1.4.1.tgz) = edbbc2e5e6074080650c5f6a21b7fe7fb8dededd
|
||||
RMD160 (pear/MDB2_Driver_mysql-1.4.1.tgz) = 872f6d4e9a8ba3be37dcafeaf2e5ae38e772e4e3
|
||||
Size (pear/MDB2_Driver_mysql-1.4.1.tgz) = 36481 bytes
|
||||
SHA1 (patch-aa) = a364e57d25e8501123df072016f062d444ca2def
|
||||
SHA1 (patch-ab) = 7d67850a37ccfaaadd4b2c260f5b64f664c8a51d
|
||||
SHA1 (patch-ab) = 6de75808e8864aa7ff8ba69a7eeb4591ff5b4668
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ab,v 1.1 2008/07/13 17:55:38 tonnerre Exp $
|
||||
$NetBSD: patch-ab,v 1.2 2008/09/17 22:40:06 adrianp Exp $
|
||||
|
||||
--- MDB2/Driver/mysql.php 2007/05/02 22:00:08 1.182
|
||||
+++ MDB2/Driver/mysql.php 2007/05/03 22:20:20 1.183
|
||||
@@ -1398,7 +1398,7 @@
|
||||
--- MDB2/Driver/mysql.php.orig 2007-05-03 20:05:23.000000000 +0100
|
||||
+++ MDB2/Driver/mysql.php
|
||||
@@ -1398,7 +1398,7 @@ class MDB2_Statement_mysql extends MDB2_
|
||||
}
|
||||
$value = $this->values[$parameter];
|
||||
$type = array_key_exists($parameter, $this->types) ? $this->types[$parameter] : null;
|
||||
|
@ -11,3 +11,10 @@ $NetBSD: patch-ab,v 1.1 2008/07/13 17:55:38 tonnerre Exp $
|
|||
if (!is_resource($value) && preg_match('/^(\w+:\/\/)(.*)$/', $value, $match)) {
|
||||
if ($match[1] == 'file://') {
|
||||
$value = $match[2];
|
||||
@@ -1476,4 +1476,4 @@ class MDB2_Statement_mysql extends MDB2_
|
||||
return $result;
|
||||
}
|
||||
}
|
||||
-?>
|
||||
\ No newline at end of file
|
||||
+?>
|
||||
|
|
Loading…
Reference in a new issue