following is not 100% right, but will adjust after getting to use it:

lprof is a tool to build ICC profiles.  The common uses an IT8 target
and an input device.
This commit is contained in:
gdt 2005-11-06 00:51:48 +00:00
parent 6506e4f149
commit d723dd6b5a
5 changed files with 80 additions and 0 deletions

2
graphics/lprof/DESCR Normal file
View file

@ -0,0 +1,2 @@
lprof is a tool to build ICC profiles. The common uses an IT8 target
and an input device.

19
graphics/lprof/Makefile Normal file
View file

@ -0,0 +1,19 @@
# $NetBSD: Makefile,v 1.1.1.1 2005/11/06 00:51:48 gdt Exp $
#
DISTNAME= lprof-1.10.1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=lprof/}
MAINTAINER= gdt@NetBSD.org
HOMEPAGE= http://lprof.sourceforge.net/
COMMENT= ICC Profile generation tool (for IT8.7 targets)
USE_TOOLS+= gmake
MAKE_ENV+= QTDIR=${PREFIX} BASEDIR=${PREFIX}
.include "../../x11/qt3-libs/buildlink3.mk"
.include "../../graphics/lcms/buildlink3.mk"
.include "../../graphics/tiff/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

40
graphics/lprof/PLIST Normal file
View file

@ -0,0 +1,40 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2005/11/06 00:51:48 gdt Exp $
bin/icc2it8
bin/qtmeasurementtool
bin/qtmonitorprofiler
bin/qtprofilechecker
bin/qtscannerprofiler
include/lcmsprf.h
lib/liblprof.a
lib/libqtlcmswidgets.a
share/doc/lprof/manual.txt
share/lprof/data/desktop/qtmeasurementtool.desktop
share/lprof/data/desktop/qtmonitorprofiler.desktop
share/lprof/data/desktop/qtprofilechecker.desktop
share/lprof/data/desktop/qtscannerprofiler.desktop
share/lprof/data/icons/qtchecker.png
share/lprof/data/icons/qtmeasure.png
share/lprof/data/icons/qtmonitor.png
share/lprof/data/icons/qtscanner.png
share/lprof/data/pics/MonitorTemplate.it8
share/lprof/data/pics/grayscale.tif
share/lprof/data/pics/monitor patches.tif
share/lprof/data/pics/party_4s.png
share/lprof/data/pics/scandmo.it8
share/lprof/data/pics/scandmo.png
share/lprof/data/pics/srgb.it8
share/lprof/data/profiles/CIEE.icm
share/lprof/data/profiles/sRGB Color Space Profile.icm
share/lprof/data/profiles/scandmo.icm
share/lprof/data/template/AVOID.ITX
share/lprof/data/template/IT8_19.ITX
share/lprof/data/template/IT8_22.ITX
share/lprof/data/template/KODAK.ITX
@dirrm share/lprof/data/template
@dirrm share/lprof/data/profiles
@dirrm share/lprof/data/pics
@dirrm share/lprof/data/icons
@dirrm share/lprof/data/desktop
@dirrm share/lprof/data
@dirrm share/lprof
@dirrm share/doc/lprof

6
graphics/lprof/distinfo Normal file
View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2005/11/06 00:51:48 gdt Exp $
SHA1 (lprof-1.10.1.tar.gz) = ad7cc5fff5d6dfff9d0993d201232d7bb71a46aa
RMD160 (lprof-1.10.1.tar.gz) = d4a20cffe42a2ca12a1321a2e6013756e447300f
Size (lprof-1.10.1.tar.gz) = 1244587 bytes
SHA1 (patch-aa) = 8ce9546f07a51ed058764bffb1a6ece5d71c5273

View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.1.1.1 2005/11/06 00:51:48 gdt Exp $
--- src/liblprof/Makefile.orig 2005-08-19 21:11:53.000000000 -0400
+++ src/liblprof/Makefile
@@ -50,7 +50,7 @@ clean:
install: liblprof.a
mkdir -p $(DESTDIR)$(BINDIR) $(DESTDIR)$(LIBDIR) $(DESTDIR)$(INCDIR)
- cp -a liblprof.a $(DESTDIR)$(LIBDIR)
+ install -c liblprof.a $(DESTDIR)$(LIBDIR)
cp lcmsprf.h $(DESTDIR)$(INCDIR)
chmod 644 $(DESTDIR)$(INCDIR)/lcmsprf.h