rvault: fix build with curl 7.87
This commit is contained in:
parent
62f02dbeb2
commit
d72bda198c
2 changed files with 17 additions and 1 deletions
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.6 2021/10/26 11:18:00 nia Exp $
|
||||
$NetBSD: distinfo,v 1.7 2022/12/23 12:40:04 wiz Exp $
|
||||
|
||||
BLAKE2s (rvault-0.3.tar.gz) = 4ff52e5edf6156c4c9cc0046f02ef8845e9678a2c4719c64a1f7e83a040bd1b6
|
||||
SHA512 (rvault-0.3.tar.gz) = 0687d14cf646adccb3c09a3d5a16e771ef9b046bd4e596a487413e83e06709b27a62c2f08a9a23d47f6253cadc1fb7cbe53262455faa6628d5b23d8539f12271
|
||||
Size (rvault-0.3.tar.gz) = 76921 bytes
|
||||
SHA1 (patch-core_cli.c) = 8214fe7f75273a0d434751b600d89d70f735a24c
|
||||
SHA1 (patch-core_http__req.c) = 35c9eec1588a2602d11d123063895cb1ed96723c
|
||||
|
|
15
security/rvault/patches/patch-core_http__req.c
Normal file
15
security/rvault/patches/patch-core_http__req.c
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-core_http__req.c,v 1.1 2022/12/23 12:40:04 wiz Exp $
|
||||
|
||||
core/http_req.c:55:2: error: 'CURLOPT_PROTOCOLS' is deprecated: since 7.85.0. Use CURLOPT_PROTOCOLS_STR
|
||||
|
||||
--- core/http_req.c.orig 2020-04-22 16:11:18.000000000 +0000
|
||||
+++ core/http_req.c
|
||||
@@ -52,7 +52,7 @@ http_request(const char *url, http_req_t
|
||||
if ((curl = curl_easy_init()) == NULL) {
|
||||
return -1;
|
||||
}
|
||||
- curl_easy_setopt(curl, CURLOPT_PROTOCOLS, CURLPROTO_HTTPS);
|
||||
+ curl_easy_setopt(curl, CURLOPT_PROTOCOLS_STR, CURLPROTO_HTTPS);
|
||||
if ((res = curl_easy_setopt(curl, CURLOPT_URL, url)) != CURLE_OK) {
|
||||
app_log(LOG_ERR, "http without TLS is not allowed");
|
||||
goto out;
|
Loading…
Reference in a new issue