Add patch comments. Regen patch-ac as it wasn't diff -u format. Improve

portability of patch-aa.
This commit is contained in:
dholland 2012-07-30 04:08:53 +00:00
parent b4a3fafdd0
commit d736e02fe1
4 changed files with 28 additions and 19 deletions

View file

@ -1,10 +1,10 @@
$NetBSD: distinfo,v 1.6 2006/07/29 04:39:31 minskim Exp $
$NetBSD: distinfo,v 1.7 2012/07/30 04:08:53 dholland Exp $
SHA1 (xscribble.tgz) = 9983577533c6b6f482e2bfe863f54604337562c7
RMD160 (xscribble.tgz) = 49f5a5339819a76e303a135d54fb8ffd4f88febb
Size (xscribble.tgz) = 164379 bytes
SHA1 (patch-aa) = eaab5d05c9ced68dda8848df5360afc990e58b6d
SHA1 (patch-aa) = 3655a05ea99e25a9f126d1b33c562c5387db82b7
SHA1 (patch-ab) = 6da2e1ba900c05d428de74b44e369c0e0c242190
SHA1 (patch-ac) = 0a6352bf35e79db51b25e195a5bed88661672987
SHA1 (patch-ac) = 61557798a2ea575862e9c0a14761465491ec6ac5
SHA1 (patch-ad) = 9fe0ce4f137975cd380280e13ccfa1543016b5b7
SHA1 (patch-ae) = 383631838e7467196ed5fa579084d4637cf82d7b
SHA1 (patch-ae) = 794a20d07760403be3fd90fef5de604732834771

View file

@ -1,4 +1,7 @@
$NetBSD: patch-aa,v 1.3 2004/05/23 18:31:27 danw Exp $
$NetBSD: patch-aa,v 1.4 2012/07/30 04:08:53 dholland Exp $
- use standard headers
- don't need to provide bcopy or strdup
--- lirec/li_recognizer.c.orig Mon Jun 12 18:20:13 2000
+++ lirec/li_recognizer.c
@ -28,7 +31,7 @@ $NetBSD: patch-aa,v 1.3 2004/05/23 18:31:27 danw Exp $
/*#include <assert.h>*/
-#include <values.h>
+#include <sys/param.h>
+#include <limits.h>
+#define MAXINT INT_MAX
#include <sys/time.h>

View file

@ -1,13 +1,16 @@
$NetBSD: patch-ac,v 1.1 2001/01/01 14:30:25 itojun Exp $
$NetBSD: patch-ac,v 1.2 2012/07/30 04:08:53 dholland Exp $
*** lirec/util.h- Mon Jan 1 22:47:35 2001
--- lirec/util.h Mon Jan 1 22:48:37 2001
***************
*** 55,57 ****
! #ifndef unix
--- 55,57 ----
! #if 0
Everything pkgsrc builds on counts as "unix", but doesn't necessarily
pollute the namespace with that by default.
--- lirec/util.h.orig 2000-06-12 22:20:14.000000000 +0000
+++ lirec/util.h
@@ -53,7 +53,7 @@ char *tempstring(); /* returns a pointer
# define GRAPHICS /* only GDEV on unix machines */
#endif
-#ifndef unix
+#if 0
/* various BSD to lattice C name changes */

View file

@ -1,4 +1,7 @@
$NetBSD: patch-ae,v 1.1 2006/07/29 04:39:31 minskim Exp $
$NetBSD: patch-ae,v 1.2 2012/07/30 04:08:53 dholland Exp $
- Use standard headers.
- Don't declare own malloc.
--- lirec/util.c.orig 2000-06-12 22:20:14.000000000 +0000
+++ lirec/util.c