Fix build with ocaml4.

This commit is contained in:
dholland 2012-12-16 22:39:47 +00:00
parent e0c777976e
commit d76060dfaa
9 changed files with 302 additions and 1 deletions

View file

@ -1,7 +1,15 @@
$NetBSD: distinfo,v 1.15 2009/09/06 13:04:19 tonio Exp $
$NetBSD: distinfo,v 1.16 2012/12/16 22:39:47 dholland Exp $
SHA1 (geneweb-5.01.tgz) = 4443b12d88cc8a6fa04ae903ace3f7bdb384d40e
RMD160 (geneweb-5.01.tgz) = 75507bb35df74b92becc8514c9ad82c8f4ef886e
Size (geneweb-5.01.tgz) = 1388008 bytes
SHA1 (patch-ac) = cf35956939ab1ce57cac2a4261f892b0a34cb053
SHA1 (patch-ad) = 83bdd42cc3229257b9eca3433c2f09b315b5e53d
SHA1 (patch-ged2gwb_ged2gwb.ml) = 28261aadb7b129297582105d491b79fc8c8c86e8
SHA1 (patch-src_dag.ml) = a0dfc2d6f6de185ac3786dfe4ba604f141397879
SHA1 (patch-src_date.ml) = c69a0c0976e03cef7314d00fdbedcbf8cef7c75d
SHA1 (patch-src_gwd.ml) = c165a4eb563b44e562f572714ab0ae5ba6af75c6
SHA1 (patch-src_mutil.ml) = e82edaec112fd4879340c46fde748d8d39e1c214
SHA1 (patch-src_relation.ml) = a5dddf98aa7f804ccb2f1ba9b18200cb03c940ea
SHA1 (patch-src_srcfile.ml) = c7f325ee6341e5732f9dbaf72bba80deadacb12e
SHA1 (patch-wserver_wserver.ml) = eaac0ab86ef99a27d4c66d705f2f44b76f3e81ae

View file

@ -0,0 +1,37 @@
$NetBSD: patch-ged2gwb_ged2gwb.ml,v 1.1 2012/12/16 22:39:47 dholland Exp $
Replace long-deprecated Stdpp.Exc_located with Ploc.Exc.
--- ged2gwb/ged2gwb.ml~ 2007-09-12 09:58:44.000000000 +0000
+++ ged2gwb/ged2gwb.ml
@@ -857,10 +857,10 @@ value date_of_field pos d =
let s = Stream.of_string (String.uppercase d) in
date_str.val := d;
try Some (Grammar.Entry.parse date_value s) with
- [ Stdpp.Exc_located loc (Stream.Error _) ->
+ [ Ploc.Exc loc (Stream.Error _) ->
let s = Stream.of_string (String.uppercase d) in
try Some (Grammar.Entry.parse date_value_recover s) with
- [ Stdpp.Exc_located loc (Stream.Error _) -> Some (Dtext d) ] ]
+ [ Ploc.Exc loc (Stream.Error _) -> Some (Dtext d) ] ]
}
;
@@ -1327,7 +1327,7 @@ value decode_date_interval pos s =
| Begin d -> (Some d, None)
| End d -> (None, Some d) ]
with
- [ Stdpp.Exc_located _ _ | Not_found ->
+ [ Ploc.Exc _ _ | Not_found ->
do { print_bad_date pos s; (None, None) } ]
;
@@ -2968,7 +2968,7 @@ The database \"%s\" already exists. Use
try main () with e ->
let e =
match e with
- [ Stdpp.Exc_located _ e -> e
+ [ Ploc.Exc _ e -> e
| _ -> e ]
in
do {

View file

@ -0,0 +1,56 @@
$NetBSD: patch-src_dag.ml,v 1.1 2012/12/16 22:39:47 dholland Exp $
Insert missing semicolons demanded by ocaml4.
--- src/dag.ml~ 2007-09-12 09:58:44.000000000 +0000
+++ src/dag.ml
@@ -48,7 +48,7 @@ value tag_dag d =
})
d
;
-end END;
+end; END;
(* input dag *)
@@ -305,7 +305,7 @@ value print_table conf hts =
end_centered conf;
}
;
-end END;
+end; END;
(*
* Print without HTML table tags: using <pre>
@@ -834,7 +834,7 @@ value print_html_table conf hts =
else print_table conf hts
}
;
-end END;
+end; END;
value make_tree_hts conf base elem_txt vbar_txt invert set spl d =
let no_group = p_getenv conf.env "nogroup" = Some "on" in
@@ -1020,7 +1020,7 @@ value print_dag_page conf base page_titl
Hutil.trailer conf
}
;
-end END;
+end; END;
(* *)
@@ -1269,11 +1269,11 @@ value old_print_slices_menu_or_dag_page
if p_getenv conf.env "slices" = Some "on" then print_slices_menu conf hts
else print_dag_page conf base page_title hts next_txt
;
-end ELSE declare
+end; ELSE declare
value old_print_slices_menu_or_dag_page conf base page_title hts next_txt =
incorrect_request conf
;
-end END;
+end; END;
value print_slices_menu_or_dag_page conf base page_title hts next_txt =
(**)

View file

@ -0,0 +1,30 @@
$NetBSD: patch-src_date.ml,v 1.1 2012/12/16 22:39:47 dholland Exp $
Insert missing semicolons demanded by ocaml4.
--- src/date.ml~ 2007-09-12 09:58:44.000000000 +0000
+++ src/date.ml
@@ -790,7 +790,7 @@ value old_print_calendar conf base =
trailer conf;
}
;
-end END;
+end; END;
(* *)
@@ -846,7 +846,7 @@ value print_calendar conf base =
(fun _ -> Templ.eval_transl conf) (fun _ -> raise Not_found)
get_vother set_vother (print_foreach conf) [] (eval_julian_day conf)
;
-end ELSE declare
+end; ELSE declare
value print_calendar conf base =
Hutil.interp conf base "calendar"
{Templ.eval_var = eval_var conf;
@@ -856,4 +856,4 @@ value print_calendar conf base =
Templ.print_foreach = print_foreach conf}
[] (eval_julian_day conf)
;
-end END;
+end; END;

View file

@ -0,0 +1,50 @@
$NetBSD: patch-src_gwd.ml,v 1.1 2012/12/16 22:39:47 dholland Exp $
Replace long-deprecated Stdpp.Exc_located with Ploc.Exc.
Insert missing semicolons demanded by ocaml4.
--- src/gwd.ml.orig 2007-09-12 09:58:44.000000000 +0000
+++ src/gwd.ml
@@ -27,7 +27,7 @@ value log_flags =
[Open_wronly; Open_append; Open_creat; Open_text; Open_nonblock]
;
IFDEF UNIX THEN
-value max_clients = ref None
+value max_clients = ref None;
END;
value robot_xcl = ref None;
value auth_file = ref "";
@@ -1644,7 +1644,7 @@ value null_reopen flags fd =
;
IFDEF SYS_COMMAND THEN
-value wserver_auto_call = ref False
+value wserver_auto_call = ref False;
END;
value geneweb_server () =
@@ -1707,6 +1707,7 @@ value cgi_timeout tmout _ =
Wserver.wflush ();
exit 0;
}
+;
END;
IFDEF UNIX THEN
@@ -1716,6 +1717,7 @@ value manage_cgi_timeout tmout =
let _ = Unix.alarm tmout in
()
else ()
+;
END;
value geneweb_cgi addr script_name contents =
@@ -1798,7 +1800,7 @@ value robot_exclude_arg s =
robot_xcl.val :=
Some (G.Entry.parse robot_xcl_arg (G.parsable (Stream.of_string s)))
with
- [ Stdpp.Exc_located _ (Stream.Error _ | Token.Error _) ->
+ [ Ploc.Exc _ (Stream.Error _ | Token.Error _) ->
do {
eprintf "Bad use of option -robot_xcl\n";
eprintf "Use option -help for usage.\n";

View file

@ -0,0 +1,24 @@
$NetBSD: patch-src_mutil.ml,v 1.1 2012/12/16 22:39:47 dholland Exp $
Insert missing semicolons demanded by ocaml4.
--- src/mutil.ml~ 2007-08-04 07:22:30.000000000 +0000
+++ src/mutil.ml
@@ -95,7 +95,7 @@ value decline case s =
| '>' -> String.sub s ibeg (i + 1 - ibeg) ^ loop (i + 1) (i + 1)
| _ -> loop ibeg (i + 1) ]
;
-end ELSE declare
+end; ELSE declare
(* [decline] has been deprecated since version 5.00
compatibility code: *)
value colon_to_at_word s ibeg iend =
@@ -158,7 +158,7 @@ value decline case s =
(if not (String.contains s ':') then s else colon_to_at s)
;
(* end compatibility code *)
-end END;
+end; END;
value nominative s =
match rindex s ':' with

View file

@ -0,0 +1,20 @@
$NetBSD: patch-src_relation.ml,v 1.1 2012/12/16 22:39:47 dholland Exp $
Insert missing semicolons demanded by ocaml4.
--- src/relation.ml~ 2007-09-12 09:58:44.000000000 +0000
+++ src/relation.ml
@@ -194,11 +194,11 @@ value old_print_relationship_dag conf ba
let hts = Dag.make_tree_hts conf base elem_txt vbar_txt invert set [] d in
Dag.print_slices_menu_or_dag_page conf base page_title hts next_txt
;
-end ELSE declare
+end; ELSE declare
value old_print_relationship_dag conf base elem_txt vbar_txt path next_txt =
incorrect_request conf
;
-end END;
+end; END;
value add_common_parent base ip1 ip2 set =
let a1 = poi base ip1 in

View file

@ -0,0 +1,15 @@
$NetBSD: patch-src_srcfile.ml,v 1.1 2012/12/16 22:39:47 dholland Exp $
Replace long-deprecated Stdpp.Exc_located with Ploc.Exc.
--- src/srcfile.ml~ 2007-09-12 09:58:44.000000000 +0000
+++ src/srcfile.ml
@@ -192,7 +192,7 @@ END;
value extract_date d =
try Some (G.Entry.parse date (G.parsable (Stream.of_string d))) with
- [ Stdpp.Exc_located _ (Stream.Error _ | Token.Error _) -> None ]
+ [ Ploc.Exc _ (Stream.Error _ | Token.Error _) -> None ]
;
value string_of_start_date conf =

View file

@ -0,0 +1,61 @@
$NetBSD: patch-wserver_wserver.ml,v 1.1 2012/12/16 22:39:47 dholland Exp $
Insert missing semicolons demanded by ocaml4.
--- wserver/wserver.ml.orig 2007-09-12 09:42:26.000000000 +0000
+++ wserver/wserver.ml
@@ -264,6 +264,7 @@ value timeout tmout spid _ =
let _ = Unix.waitpid [] pid in ();
exit 2
}
+;
END;
value get_request_and_content strm =
@@ -364,6 +365,7 @@ value copy_what_necessary t oc =
in
let _ = get_request_and_content strm in
()
+;
END;
value rec list_remove x =
@@ -372,13 +374,13 @@ value rec list_remove x =
| [y :: l] -> if x = y then l else [y :: list_remove x l] ]
;
-IFDEF NOFORK THEN declare end ELSE
-value pids = ref []
+IFDEF NOFORK THEN declare end; ELSE
+value pids = ref [];
END;
-IFDEF NOFORK THEN declare end ELSE
-value cleanup_verbose = ref True
+IFDEF NOFORK THEN declare end; ELSE
+value cleanup_verbose = ref True;
END;
-IFDEF NOFORK THEN declare end ELSE
+IFDEF NOFORK THEN declare end; ELSE
value cleanup_sons () =
List.iter
(fun p ->
@@ -403,9 +405,10 @@ value cleanup_sons () =
if pid = 0 then ()
else pids.val := list_remove pid pids.val)
pids.val
+;
END;
-IFDEF NOFORK THEN declare end ELSE
+IFDEF NOFORK THEN declare end; ELSE
value wait_available max_clients s =
match max_clients with
[ Some m ->
@@ -435,6 +438,7 @@ eprintf "*** %02d/%02d/%4d %02d:%02d:%02
};
}
| None -> () ]
+;
END;
value wait_and_compact s =