The version 2017.0 is mainly a bug fix release. The biggest fixes regard:

* Several fixes for working with HDR images (display in GUI, photometric optimizer, handling of under/over exposured pixels in merging code).
* Fixes handling of masks in cpfind when images needs remapping for cp finding.
* Sometimes unsaved changes were disregarded without asking the user (e.g. when loading a project via the recently used projects list). Unsaved changes should now always require user confirmation.

Besides the bug fixes some smaller improvements have been implemented.
* Optimizer tabs uses now checkboxes instead of bold underlined font for marking of variables to be optimized.
* Use wxWidgets help windows instead of default browser (Linux&Mac only, this provides table of content, index and full text search in help files).
* Added special assistant variant for single image projects.
* Display of final panorama dimensions on stitcher tab.
* Extended the user defined output sequences:
  - The shipped user defined output sequences are exposed in the GUI as own sub-menu.
  - Added some more user defined output sequences (layered TIFF, cube faces).
  - Added new placeholder %sourceimage% to user defined output sequence.
This commit is contained in:
adam 2017-07-03 20:48:03 +00:00
parent 722d3e3637
commit d7b2208231
6 changed files with 59 additions and 161 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.66 2017/04/30 01:21:43 ryoon Exp $
# $NetBSD: Makefile,v 1.67 2017/07/03 20:48:03 adam Exp $
DISTNAME= hugin-2016.2.0
PKGREVISION= 6
DISTNAME= hugin-2017.0
PKGNAME= ${DISTNAME}.0
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=hugin/}
EXTRACT_SUFX= .tar.bz2
@ -11,15 +11,20 @@ HOMEPAGE= http://hugin.sourceforge.net/
COMMENT= Panorama photo stitcher
LICENSE= gnu-gpl-v2
WRKSRC= ${WRKDIR}/${PKGNAME_NOREV}
DEPENDS+= enblend-enfuse>=4.0:../../graphics/enblend-enfuse
DEPENDS+= p5-Image-ExifTool>=8.15:../../graphics/p5-Image-ExifTool
USE_CMAKE= yes
USE_LANGUAGES= c c++
USE_LIBTOOL= yes
USE_TOOLS+= msgfmt pkg-config
CONFIGURE_ENV+= MANDIR=${PKGMANDIR}
CMAKE_ARGS+= -DBUILD_HSI=OFF
PY_PATCHPLIST= yes
REPLACE_PYTHON+= src/hugin_script_interface/*.py
REPLACE_PYTHON+= src/hugin_script_interface/plugins/*.py
REPLACE_PYTHON+= src/hugin_script_interface/plugins-dev/*.py
SUBST_CLASSES+= apple
SUBST_MESSAGE.apple= Avoiding Mac OS X application bundles
@ -45,7 +50,8 @@ SUBST_SED.apple= -e 's,(APPLE),(ELPPA),g'
.include "../../graphics/libpano13/buildlink3.mk"
.include "../../graphics/openexr/buildlink3.mk"
.include "../../graphics/vigra/buildlink3.mk"
#.include "../../lang/python/extension.mk"
.include "../../lang/python/application.mk"
.include "../../lang/python/extension.mk"
.include "../../math/fftw/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../x11/wxGTK30/buildlink3.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.9 2016/11/06 16:08:00 adam Exp $
@comment $NetBSD: PLIST,v 1.10 2017/07/03 20:48:03 adam Exp $
bin/PTBatcherGUI
bin/align_image_stack
bin/autooptimiser
@ -31,11 +31,14 @@ bin/tca_correct
bin/verdandi
bin/vig_optimize
lib/libceleste.so.0.0
lib/libhugin_python_interface.so.0.0
lib/libhuginbase.so.0.0
lib/libhuginbasewx.so.0.0
lib/libhuginlines.so.0.0
lib/libicpfindlib.so.0.0
lib/liblocalfeatures.so.0.0
${PYSITELIB}/_hsi.so
${PYSITELIB}/hpi.py
${PYSITELIB}/hsi.py
man/man1/PTBatcherGUI.1
man/man1/align_image_stack.1
man/man1/autooptimiser.1
@ -80,8 +83,18 @@ share/hugin/data/default.setting
share/hugin/data/fused_layers.executor
share/hugin/data/hdr_pano.executor
share/hugin/data/hugin_exiftool_copy.arg
share/hugin/data/hugin_exiftool_final_example.arg
share/hugin/data/normal_enblend.executor
share/hugin/data/normal_enblend_cubic.executor
share/hugin/data/normal_layered_tiff.executor
share/hugin/data/normal_smartblend.executor
share/hugin/data/plugins-templates/dual_use.py
share/hugin/data/plugins-templates/plugin_skeleton.py
share/hugin/data/plugins/README_woa.txt
share/hugin/data/plugins/crop_cp.py
share/hugin/data/plugins/shooting_pattern.py
share/hugin/data/plugins/top_five.py
share/hugin/data/plugins/woa.py
share/hugin/data/zeronoise.executor
share/hugin/xrc/about.xrc
share/hugin/xrc/batch_frame.xrc
@ -369,6 +382,7 @@ share/hugin/xrc/data/help_en_EN/Lightprobe.html
share/hugin/xrc/data/help_en_EN/Linefind.html
share/hugin/xrc/data/help_en_EN/Medinet_habu_horizontal_fisheye.jpg
share/hugin/xrc/data/help_en_EN/Medinet_habu_horizontal_stereographic.jpg
share/hugin/xrc/data/help_en_EN/Multi_image_techniques.html
share/hugin/xrc/data/help_en_EN/NPP.html
share/hugin/xrc/data/help_en_EN/Nadir.html
share/hugin/xrc/data/help_en_EN/No-parallax_point.html
@ -433,6 +447,7 @@ share/hugin/xrc/data/help_en_EN/TIFF.html
share/hugin/xrc/data/help_en_EN/Tca_correct.html
share/hugin/xrc/data/help_en_EN/The_General_Panini_Projection.html
share/hugin/xrc/data/help_en_EN/Tone_mapping.html
share/hugin/xrc/data/help_en_EN/User_defined_output_sequence.html
share/hugin/xrc/data/help_en_EN/Using_Celeste_with_hugin.html
share/hugin/xrc/data/help_en_EN/Verdandi.html
share/hugin/xrc/data/help_en_EN/Vertical-fisheye.jpg
@ -458,131 +473,11 @@ share/hugin/xrc/data/help_en_EN/f7bd60b75b29d79b660a2859395c1a24.png
share/hugin/xrc/data/help_en_EN/fa5313ae442c1ac7f832c141880e3e74.png
share/hugin/xrc/data/help_en_EN/help_index_en.hhk
share/hugin/xrc/data/help_en_EN/help_toc_en.hhc
share/hugin/xrc/data/help_en_EN/hugin.hhc
share/hugin/xrc/data/help_en_EN/hugin.hhk
share/hugin/xrc/data/help_en_EN/hugin.hhp
share/hugin/xrc/data/help_en_EN/hugin_help_en_EN.hhp
share/hugin/xrc/data/help_en_EN/license.html
share/hugin/xrc/data/help_en_EN/magnify-clip.png
share/hugin/xrc/data/help_en_EN/manual.css
share/hugin/xrc/data/help_en_EN/panotoolsng.png
share/hugin/xrc/data/help_it_IT/16bit_workflow_with_hugin.html
share/hugin/xrc/data/help_it_IT/Aliasing.html
share/hugin/xrc/data/help_it_IT/Align_a_stack_of_photos.html
share/hugin/xrc/data/help_it_IT/Align_image_stack.html
share/hugin/xrc/data/help_it_IT/Alpha_channel.html
share/hugin/xrc/data/help_it_IT/Aspect_Ratio.html
share/hugin/xrc/data/help_it_IT/Autooptimiser.html
share/hugin/xrc/data/help_it_IT/Autopano-sift-C.html
share/hugin/xrc/data/help_it_IT/Autopano-sift.html
share/hugin/xrc/data/help_it_IT/Autopano.html
share/hugin/xrc/data/help_it_IT/Banding.html
share/hugin/xrc/data/help_it_IT/Barrel_distortion.html
share/hugin/xrc/data/help_it_IT/Bracketing.html
share/hugin/xrc/data/help_it_IT/CCD.html
share/hugin/xrc/data/help_it_IT/Camera_response_curve.html
share/hugin/xrc/data/help_it_IT/Chromatic_aberration.html
share/hugin/xrc/data/help_it_IT/Color_correct_tiff.html
share/hugin/xrc/data/help_it_IT/Colour_profile.html
share/hugin/xrc/data/help_it_IT/Control_points.html
share/hugin/xrc/data/help_it_IT/Crop_factor.html
share/hugin/xrc/data/help_it_IT/Cropped_TIFF.html
share/hugin/xrc/data/help_it_IT/Cubic.html
share/hugin/xrc/data/help_it_IT/Cubic_Projection.html
share/hugin/xrc/data/help_it_IT/Cylindrical.html
share/hugin/xrc/data/help_it_IT/Cylindrical_Projection.html
share/hugin/xrc/data/help_it_IT/Cylindrical_panorama.html
share/hugin/xrc/data/help_it_IT/Depth_of_Field.html
share/hugin/xrc/data/help_it_IT/Dust_Removal_with_Flatfield.html
share/hugin/xrc/data/help_it_IT/Dynamic_range.html
share/hugin/xrc/data/help_it_IT/EXIF.html
share/hugin/xrc/data/help_it_IT/Enblend.html
share/hugin/xrc/data/help_it_IT/Enfuse.html
share/hugin/xrc/data/help_it_IT/Entrance_pupil.html
share/hugin/xrc/data/help_it_IT/Equirectangular.html
share/hugin/xrc/data/help_it_IT/Equirectangular_Projection.html
share/hugin/xrc/data/help_it_IT/Field_of_View.html
share/hugin/xrc/data/help_it_IT/Fisheye_Projection.html
share/hugin/xrc/data/help_it_IT/Focal_Length.html
share/hugin/xrc/data/help_it_IT/Freepv.html
share/hugin/xrc/data/help_it_IT/Fulla.html
share/hugin/xrc/data/help_it_IT/GIF.html
share/hugin/xrc/data/help_it_IT/Gamma.html
share/hugin/xrc/data/help_it_IT/HDR.html
share/hugin/xrc/data/help_it_IT/HDR_workflow_with_hugin.html
share/hugin/xrc/data/help_it_IT/Horizontal_control_points.html
share/hugin/xrc/data/help_it_IT/Hugin.html
share/hugin/xrc/data/help_it_IT/Hugin_Assistant_tab.html
share/hugin/xrc/data/help_it_IT/Hugin_Batch_Processor.html
share/hugin/xrc/data/help_it_IT/Hugin_Batch_Stitcher.html
share/hugin/xrc/data/help_it_IT/Hugin_Camera_and_Lens_tab.html
share/hugin/xrc/data/help_it_IT/Hugin_Control_Points_tab.html
share/hugin/xrc/data/help_it_IT/Hugin_Control_Points_table.html
share/hugin/xrc/data/help_it_IT/Hugin_Crop_tab.html
share/hugin/xrc/data/help_it_IT/Hugin_Exposure_tab.html
share/hugin/xrc/data/help_it_IT/Hugin_FAQ.html
share/hugin/xrc/data/help_it_IT/Hugin_Fast_Preview_window.html
share/hugin/xrc/data/help_it_IT/Hugin_Images_tab.html
share/hugin/xrc/data/help_it_IT/Hugin_Keyboard_shortcuts.html
share/hugin/xrc/data/help_it_IT/Hugin_Main_window.html
share/hugin/xrc/data/help_it_IT/Hugin_Optimizer_tab.html
share/hugin/xrc/data/help_it_IT/Hugin_Preferences.html
share/hugin/xrc/data/help_it_IT/Hugin_Preview_window.html
share/hugin/xrc/data/help_it_IT/Hugin_Stitcher_tab.html
share/hugin/xrc/data/help_it_IT/Hugin_translation_guide.html
share/hugin/xrc/data/help_it_IT/Interpolation.html
share/hugin/xrc/data/help_it_IT/JPEG.html
share/hugin/xrc/data/help_it_IT/Landscape.html
share/hugin/xrc/data/help_it_IT/Lens_correction_model.html
share/hugin/xrc/data/help_it_IT/Lens_distortion.html
share/hugin/xrc/data/help_it_IT/MatchPoint.html
share/hugin/xrc/data/help_it_IT/NPP.html
share/hugin/xrc/data/help_it_IT/Nadir.html
share/hugin/xrc/data/help_it_IT/No-parallax_point.html
share/hugin/xrc/data/help_it_IT/Nodal_Point.html
share/hugin/xrc/data/help_it_IT/Nona.html
share/hugin/xrc/data/help_it_IT/Nona_gui.html
share/hugin/xrc/data/help_it_IT/OpenEXR.html
share/hugin/xrc/data/help_it_IT/Optimization.html
share/hugin/xrc/data/help_it_IT/PNG.html
share/hugin/xrc/data/help_it_IT/PPI.html
share/hugin/xrc/data/help_it_IT/PSD.html
share/hugin/xrc/data/help_it_IT/PTOptimizer.html
share/hugin/xrc/data/help_it_IT/PTStitcher.html
share/hugin/xrc/data/help_it_IT/PTblender.html
share/hugin/xrc/data/help_it_IT/PTmender.html
share/hugin/xrc/data/help_it_IT/PTtiff2psd.html
share/hugin/xrc/data/help_it_IT/Pano12.html
share/hugin/xrc/data/help_it_IT/Panoglview.html
share/hugin/xrc/data/help_it_IT/Panoinfo.html
share/hugin/xrc/data/help_it_IT/Panomatic.html
share/hugin/xrc/data/help_it_IT/Panorama.html
share/hugin/xrc/data/help_it_IT/Panorama_formats.html
share/hugin/xrc/data/help_it_IT/Panorama_tools.html
share/hugin/xrc/data/help_it_IT/Panotools.html
share/hugin/xrc/data/help_it_IT/Parallax.html
share/hugin/xrc/data/help_it_IT/Perspective_correction.html
share/hugin/xrc/data/help_it_IT/Perspective_distortion.html
share/hugin/xrc/data/help_it_IT/Pincushion_distortion.html
share/hugin/xrc/data/help_it_IT/Pitch.html
share/hugin/xrc/data/help_it_IT/Portrait.html
share/hugin/xrc/data/help_it_IT/Projections.html
share/hugin/xrc/data/help_it_IT/QTVR.html
share/hugin/xrc/data/help_it_IT/RAW.html
share/hugin/xrc/data/help_it_IT/RGBE.html
share/hugin/xrc/data/help_it_IT/Rectilinear_Projection.html
share/hugin/xrc/data/help_it_IT/Roll.html
share/hugin/xrc/data/help_it_IT/Spherical.html
share/hugin/xrc/data/help_it_IT/Stereographic_Projection.html
share/hugin/xrc/data/help_it_IT/Straight_line_control_points.html
share/hugin/xrc/data/help_it_IT/TIFF.html
share/hugin/xrc/data/help_it_IT/Tone_mapping.html
share/hugin/xrc/data/help_it_IT/Vertical_control_points.html
share/hugin/xrc/data/help_it_IT/Vignetting.html
share/hugin/xrc/data/help_it_IT/Wavy_distortion.html
share/hugin/xrc/data/help_it_IT/Yaw.html
share/hugin/xrc/data/help_it_IT/Zenith.html
share/hugin/xrc/data/help_it_IT/license.html
share/hugin/xrc/data/hugin.ico
share/hugin/xrc/data/hugin.png
share/hugin/xrc/data/hugin_small.png

View file

@ -1,18 +1,19 @@
$NetBSD: distinfo,v 1.17 2016/11/06 16:08:00 adam Exp $
$NetBSD: distinfo,v 1.18 2017/07/03 20:48:03 adam Exp $
SHA1 (hugin-2016.2.0.tar.bz2) = 9d28609d973fa72b95b1e2506cf1de7d24578e67
RMD160 (hugin-2016.2.0.tar.bz2) = 9eaf5f5c3f68a5bbc1a86272488c2821a63db83e
SHA512 (hugin-2016.2.0.tar.bz2) = 9c652e685d0135afef6418bdf5fce39cec8ef1ec0dbe3a325151957c91495db0a2a3171ee04a28955a638493913c1bc800a90c37347ad17612584646c8a65510
Size (hugin-2016.2.0.tar.bz2) = 10386216 bytes
SHA1 (patch-CMakeLists.txt) = e30ad71ef5abe0efcf113278ae85f5d33a0a4ccd
SHA1 (hugin-2017.0.tar.bz2) = 4ba7f5bf5afdadbea9cf10d15aa14e644ef94ed3
RMD160 (hugin-2017.0.tar.bz2) = 2a0cf1af75d384abca0a62d80480fc815f63e0bf
SHA512 (hugin-2017.0.tar.bz2) = bfd39135119fddb559ecec220da36a4c15d96bda7f93e738d8815aafca94685ba879239202e2cc81c87787188ee3b1b6dc5cbe8014aa12e2f95d654591dc1969
Size (hugin-2017.0.tar.bz2) = 9803272 bytes
SHA1 (patch-CMakeLists.txt) = 9c7f017d8446e61b2cfffe7969f900c63cb229a1
SHA1 (patch-CMakeModules_FindPNG.cmake) = 811fd3cf6f819b31129e1560cd8acd1f7ee6defc
SHA1 (patch-doc_deghosting_mask.pod) = fe5462b10966420b0cf3fab004854d9dab3bfb4f
SHA1 (patch-src_hugin1_base__wx_StitchingExecutor.cpp) = c30a62b1da413fce9524d7d558ec5bb1f21eb65e
SHA1 (patch-src_hugin1_base__wx_StitchingExecutor.cpp) = 15b22b2a098bcf644eb07943baa958c09d72a7f6
SHA1 (patch-src_hugin1_base__wx_platform.cpp) = f0f544438a4818e9bbad9fd0f7fb0af06f1bdf4e
SHA1 (patch-src_hugin1_base__wx_wxPanoCommand.cpp) = d5bf8f747ae86338e728c472d3dc04bf4c84f182
SHA1 (patch-src_hugin1_calibrate__lens_LensCalFrame.cpp) = 9b815a681317cb19880e7bb6ef170bc14d01b28b
SHA1 (patch-src_hugin1_hugin_CPEditorPanel.cpp) = d373c00d4783b3edc1bad5a67339163a0c23d8c5
SHA1 (patch-src_hugin1_hugin_GLPreviewFrame.cpp) = fda8db4abf3ab10332d4309c90f0ef4f845c76a6
SHA1 (patch-src_hugin1_ptbatcher_BatchFrame.cpp) = 51ce24f1eb99cc5c0151758299eb1ecc34128171
SHA1 (patch-src_hugin__script__interface_hsi.i) = b11a52579fd12fdf7c51fef63049d285cb2b52e1
SHA1 (patch-src_tools_align_image_stack.cpp) = fc2759f0722365d4c5339c5c8bc1eda1a6bf7a71
SHA1 (patch-src_tools_tca__correct.cpp) = 73a86d3086336f168de5fb1cc02378a3ecc43104

View file

@ -1,11 +1,10 @@
$NetBSD: patch-CMakeLists.txt,v 1.3 2016/11/06 16:08:00 adam Exp $
$NetBSD: patch-CMakeLists.txt,v 1.4 2017/07/03 20:48:03 adam Exp $
Correct 'man' path.
Do not make an application bundle on OS X.
--- CMakeLists.txt.orig 2016-07-09 07:25:44.000000000 +0000
--- CMakeLists.txt.orig 2017-05-15 15:05:31.000000000 +0000
+++ CMakeLists.txt
@@ -2,18 +2,12 @@
@@ -2,10 +2,6 @@
# require at least cmake 3.1
cmake_minimum_required(VERSION 3.1.0 FATAL_ERROR )
@ -16,24 +15,7 @@ Do not make an application bundle on OS X.
if(COMMAND cmake_policy)
cmake_policy(SET CMP0003 NEW)
endif(COMMAND cmake_policy)
if(APPLE)
- set(CMAKE_OSX_SYSROOT macosx10.11)
- set(CMAKE_OSX_DEPLOYMENT_TARGET "10.9")
if (MAC_SELF_CONTAINED_BUNDLE)
set(CMAKE_LIBRARY_PATH ${CMAKE_SOURCE_DIR}/mac/ExternalPrograms/repository/lib)
set(CMAKE_INCLUDE_PATH ${CMAKE_SOURCE_DIR}/mac/ExternalPrograms/repository/include ${CMAKE_SOURCE_DIR}/mac/ExternalPrograms/repository/bin)
@@ -538,7 +532,7 @@ IF (NOT MANDIR AND NOT $ENV{MANDIR} STRE
ELSEIF(CMAKE_SYSTEM_NAME STREQUAL "FreeBSD" OR CMAKE_SYSTEM_NAME STREQUAL "NetBSD")
SET (MANDIR "man")
ELSE(NOT MANDIR AND NOT $ENV{MANDIR} STREQUAL "")
- SET (MANDIR "share/man")
+ SET (MANDIR "man")
ENDIF(NOT MANDIR AND NOT $ENV{MANDIR} STREQUAL "")
SET(LOCALEDIR share/locale)
@@ -563,16 +557,6 @@ IF (APPLE)
@@ -570,16 +566,6 @@ IF (APPLE)
ENDIF (NOT MAC_SELF_CONTAINED_BUNDLE)
ENDIF (APPLE)

View file

@ -1,10 +1,10 @@
$NetBSD: patch-src_hugin1_base__wx_StitchingExecutor.cpp,v 1.1 2015/10/18 15:56:56 adam Exp $
$NetBSD: patch-src_hugin1_base__wx_StitchingExecutor.cpp,v 1.2 2017/07/03 20:48:03 adam Exp $
Re-order includes to fix building.
--- src/hugin1/base_wx/StitchingExecutor.cpp.orig 2015-08-24 21:56:49.000000000 +0000
--- src/hugin1/base_wx/StitchingExecutor.cpp.orig 2017-04-29 16:05:50.000000000 +0000
+++ src/hugin1/base_wx/StitchingExecutor.cpp
@@ -37,9 +37,9 @@
@@ -34,9 +34,9 @@
#include "hugin_base/panotools/PanoToolsUtils.h"
#include "hugin_base/panodata/PanoramaOptions.h"
#include "hugin_base/algorithms/basic/LayerStacks.h"
@ -14,4 +14,4 @@ Re-order includes to fix building.
-#include "base_wx/LensTools.h"
#include "hugin/config_defaults.h"
#if wxCHECK_VERSION(3,0,0)
namespace HuginQueue

View file

@ -0,0 +1,14 @@
$NetBSD: patch-src_hugin__script__interface_hsi.i,v 1.1 2017/07/03 20:48:04 adam Exp $
Vigra's class VT1 conflicts with '#define VT1' from sys/termios.h.
--- src/hugin_script_interface/hsi.i.orig 2017-06-01 22:41:27.000000000 +0000
+++ src/hugin_script_interface/hsi.i
@@ -27,6 +27,7 @@
%{
#define SWIG_FILE_WITH_INIT
+#undef VT1
#include <hugin_shared.h>
#include <appbase/DocumentData.h>