audio/festival-freebsoft-utils: import festival-freebsoft-utils-0.10

festival-freebsoft-utils is a collection of Festival utilities that
enhance Festival with some useful features.  They provide all what is
needed for interaction with Speech Dispatcher.

Key festival-freebsoft-utils features are:

- Generalized concept of input events.  festival-freebsoft-utils
  allows not only plain text synthesis, but also combining it with
  sounds.  Additionally, mechanism of logical events mapped to other
  events is provided.

- Substitution of events for given words.

- High-level voice selection mechanism and setting of basic prosodic
  parameters.

- Spelling mode.

- Capital letter signalization.
This commit is contained in:
ryoon 2023-10-16 14:04:53 +00:00
parent cf9ab18448
commit d7b3a6c46d
5 changed files with 81 additions and 0 deletions

View file

@ -0,0 +1,19 @@
festival-freebsoft-utils is a collection of Festival utilities that
enhance Festival with some useful features. They provide all what is
needed for interaction with Speech Dispatcher.
Key festival-freebsoft-utils features are:
- Generalized concept of input events. festival-freebsoft-utils
allows not only plain text synthesis, but also combining it with
sounds. Additionally, mechanism of logical events mapped to other
events is provided.
- Substitution of events for given words.
- High-level voice selection mechanism and setting of basic prosodic
parameters.
- Spelling mode.
- Capital letter signalization.

View file

@ -0,0 +1,23 @@
# $NetBSD: Makefile,v 1.1 2023/10/16 14:04:53 ryoon Exp $
DISTNAME= festival-freebsoft-utils-0.10
CATEGORIES= audio
MASTER_SITES= https://freebsoft.org/pub/projects/festival-freebsoft-utils/
MAINTAINER= ryoon@NetBSD.org
HOMEPAGE= https://freebsoft.org/festival-freebsoft-utils
COMMENT= Festival extensions and utilities for Speech Dispatcher
LICENSE= gnu-gpl-v2
DEPENDS+= festival-[0-9]*:../../audio/festival
USE_LANGUAGES= # none
NO_CONFIGURE= yes
NO_BUILD= yes
INSTALLATION_DIRS+= share/festival/lib
do-install:
${INSTALL_DATA} ${WRKSRC}/*.scm ${DESTDIR}${PREFIX}/share/festival/lib
.include "../../mk/bsd.pkg.mk"

View file

@ -0,0 +1,18 @@
@comment $NetBSD: PLIST,v 1.1 2023/10/16 14:04:53 ryoon Exp $
share/festival/lib/cap-signalization.scm
share/festival/lib/events.scm
share/festival/lib/fileio.scm
share/festival/lib/multiwave.scm
share/festival/lib/nopauses.scm
share/festival/lib/oo.scm
share/festival/lib/prosody-param.scm
share/festival/lib/punctuation.scm
share/festival/lib/recode.scm
share/festival/lib/speech-dispatcher.scm
share/festival/lib/spell-mode.scm
share/festival/lib/ssml-mode.scm
share/festival/lib/tokenize.scm
share/festival/lib/util.scm
share/festival/lib/voice-select.scm
share/festival/lib/wave.scm
share/festival/lib/word-mapping.scm

View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1 2023/10/16 14:04:53 ryoon Exp $
BLAKE2s (festival-freebsoft-utils-0.10.tar.gz) = fa055f18816a891b03237b1bdbcee918fbbe96aebd8f132115a7e4230a9c5344
SHA512 (festival-freebsoft-utils-0.10.tar.gz) = 26305b9d0fc7f1333786d38cc0efbbe2cb2734e9f981e846ce7b9369cf012adf04e357af9c39fea650620cf7ff619ad15c48dbbd5d6a2781907301817718136c
Size (festival-freebsoft-utils-0.10.tar.gz) = 73022 bytes
SHA1 (patch-recode.scm) = a4378ae524c449099707024b1dfb53eded73c1c2

View file

@ -0,0 +1,15 @@
$NetBSD: patch-recode.scm,v 1.1 2023/10/16 14:04:53 ryoon Exp $
* Support iconv(1) of NetBSD.
--- recode.scm.orig 2008-10-16 10:10:04.000000000 +0000
+++ recode.scm
@@ -29,7 +29,7 @@
string
(with-temp-file-data (tmpfile string)
(with-temp-file out-tmpfile
- (system (format nil "iconv -c -f %s -t %s//TRANSLIT -o %s %s" from to out-tmpfile tmpfile))
+ (system (format nil "iconv -c -f %s -t %s %s > %s" from to tmpfile out-tmpfile))
(read-file out-tmpfile)))))
(defvar recode-special-utf8-translations