better approach. thanks wiz@

This commit is contained in:
cjep 2021-02-12 22:53:14 +00:00
parent af64b052e1
commit d7c0fe008f
3 changed files with 6 additions and 10 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.117 2021/02/12 22:28:03 cjep Exp $
# $NetBSD: Makefile,v 1.118 2021/02/12 22:53:14 cjep Exp $
DISTNAME= screen-4.8.0
PKGREVISION= 3
@ -45,10 +45,6 @@ PLIST_VARS+= terminfo
.include "../../mk/compiler.mk"
.if ${OPSYS} == "OpenBSD"
CFLAGS+= -D_OpenBSD_
.endif
.if ${OPSYS} == "SunOS"
. if !empty(PKGSRC_COMPILER:Mclang) || !empty(CC_VERSION:Mgcc-[6-9]*)
CPPFLAGS+= -D_XOPEN_SOURCE=600 -D__EXTENSIONS__

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.57 2021/02/12 22:29:36 cjep Exp $
$NetBSD: distinfo,v 1.58 2021/02/12 22:53:14 cjep Exp $
SHA1 (screen-4.8.0.tar.gz) = 2328927e10e68d357bdfec7bd740726011e834e9
RMD160 (screen-4.8.0.tar.gz) = 43888fa00f708a8a9aa226e0df39abd7181b15ae
@ -19,4 +19,4 @@ SHA1 (patch-display.h) = 922ebe152d8c09fc016b983d8fe9c1c64ef74578
SHA1 (patch-screen.c) = de5d8468100ab88cbdb842e21b04b00221e798b8
SHA1 (patch-socket.c) = ef7d3cb14f0199383c0e750af48f19537eb0b36d
SHA1 (patch-tty.sh) = 711e10879250de4b0e04bc2ec00472edeaf6aada
SHA1 (patch-window.h) = c146857e76dbf6156ed93710bd4c5acc2469d0c5
SHA1 (patch-window.h) = 84dc5a2c24ff77147b416c05f897536c0cfddf31

View file

@ -1,14 +1,14 @@
$NetBSD: patch-window.h,v 1.2 2021/02/12 22:29:37 cjep Exp $
$NetBSD: patch-window.h,v 1.3 2021/02/12 22:53:14 cjep Exp $
OpenBSD grumbles without the socket definitions
--- window.h.orig Wed Feb 5 20:09:38 2020
+++ window.h Thu Feb 11 21:01:43 2021
+++ window.h Thu Feb 11 21:27:43 2021
@@ -33,6 +33,10 @@
#ifndef SCREEN_WINDOW_H
#define SCREEN_WINDOW_H
+#ifdef _OpenBSD_
+#ifdef __OpenBSD__
+#include <sys/socket.h>
+#endif
+