Update www/libsass to 3.4.5.
Features - Implement trailing commas in parameters and arguments - Implement unary slash expressions Fixes - Fix Attribute Selector equal compare operator - Fix segfault for varargs with non-string keys - Fix Element Selector compare operators - Fix compiler issue with spec regression on NetBSD 6.1 - Fix some segfaults caused by the parser being too forgiving - Fix segfault with invalid map keys - Fix null pointer dereference in css_error - Fix bug when parsing selector schemas - Fix null pointer dereference in parse_selector_schema - Fix segfault when extending pseudo selectors failed - Fix parser for urls looking like ruleset selectors - Error for trailing rulesets comma - Improve selector and binominal look ahead - Improve hex escape handling in interpolation - Fix wrong parsing of calc functions as number units - Skip comment evaluation for compressed output - Improve parent selector handling in selector schema - Improve parameter vararg and keyword handling - Hotfix to avoid invalid nested :not selectors - Fix a few minor memory leaks
This commit is contained in:
parent
814dee2578
commit
d7c8d59a5e
3 changed files with 27 additions and 7 deletions
|
@ -1,6 +1,6 @@
|
||||||
# $NetBSD: Makefile,v 1.6 2017/04/09 15:31:34 adam Exp $
|
# $NetBSD: Makefile,v 1.7 2017/06/13 12:44:06 fhajny Exp $
|
||||||
|
|
||||||
DISTNAME= libsass-3.4.4
|
DISTNAME= libsass-3.4.5
|
||||||
CATEGORIES= www devel
|
CATEGORIES= www devel
|
||||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=sass/}
|
MASTER_SITES= ${MASTER_SITE_GITHUB:=sass/}
|
||||||
|
|
||||||
|
@ -15,6 +15,8 @@ USE_TOOLS+= aclocal autoheader autoconf automake gmake
|
||||||
GNU_CONFIGURE= yes
|
GNU_CONFIGURE= yes
|
||||||
MAKE_FILE= GNUmakefile
|
MAKE_FILE= GNUmakefile
|
||||||
|
|
||||||
|
PKGCONFIG_OVERRIDE= src/support/libsass.pc.in
|
||||||
|
|
||||||
pre-configure:
|
pre-configure:
|
||||||
set -e; cd ${WRKSRC}; libtoolize -c -f; \
|
set -e; cd ${WRKSRC}; libtoolize -c -f; \
|
||||||
aclocal; autoheader; automake -a --foreign -i; autoconf
|
aclocal; autoheader; automake -a --foreign -i; autoconf
|
||||||
|
|
|
@ -1,6 +1,7 @@
|
||||||
$NetBSD: distinfo,v 1.6 2017/04/09 15:31:34 adam Exp $
|
$NetBSD: distinfo,v 1.7 2017/06/13 12:44:06 fhajny Exp $
|
||||||
|
|
||||||
SHA1 (libsass-3.4.4.tar.gz) = 4b4990fcef1b3cb875b4b0f038cf66eb8ad3ab22
|
SHA1 (libsass-3.4.5.tar.gz) = dcb2d3fcf3b1f577c8cf4cff0d77d21819189ea1
|
||||||
RMD160 (libsass-3.4.4.tar.gz) = b8d7cadf3e0ee4b34e444068411d31c540549dec
|
RMD160 (libsass-3.4.5.tar.gz) = 6f42ed9b40861e3a79bfe899e82e2c7363ae5d51
|
||||||
SHA512 (libsass-3.4.4.tar.gz) = 346675230f30190864723a5dcaf9b8fd9256b0198001f02fbbadf1e932be0f95863a7517197063f31373c55c4a4d38b2fe2f01a53a6982110324d0f668680a91
|
SHA512 (libsass-3.4.5.tar.gz) = 5e3f56d44d100067d68e338fa97209a78d80c3536d64fdf48d83ec5351f944dbbe50e1050ffc8189b3ae86fd86d7b121229a3866f6e0287abc55af3770ed2bb6
|
||||||
Size (libsass-3.4.4.tar.gz) = 316884 bytes
|
Size (libsass-3.4.5.tar.gz) = 318689 bytes
|
||||||
|
SHA1 (patch-src_units.hpp) = f3d4d926e2cf9517bea9fc4ee47e597908c150cc
|
||||||
|
|
17
www/libsass/patches/patch-src_units.hpp
Normal file
17
www/libsass/patches/patch-src_units.hpp
Normal file
|
@ -0,0 +1,17 @@
|
||||||
|
$NetBSD: patch-src_units.hpp,v 1.1 2017/06/13 12:44:07 fhajny Exp $
|
||||||
|
|
||||||
|
Avoid macro conflict on SunOS.
|
||||||
|
|
||||||
|
--- src/units.hpp.orig 2017-03-05 04:57:36.000000000 +0000
|
||||||
|
+++ src/units.hpp
|
||||||
|
@@ -5,6 +5,10 @@
|
||||||
|
#include <string>
|
||||||
|
#include <sstream>
|
||||||
|
|
||||||
|
+#if defined(SEC)
|
||||||
|
+#undef SEC
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
namespace Sass {
|
||||||
|
|
||||||
|
const double PI = std::acos(-1);
|
Loading…
Reference in a new issue