Updated devel/deforaos-libsystem to version 0.2.0

This release includes:
- a command-line tool, configctl(1), to interact with configuration files
- a new generic Mutator class
- further improvements to the String and Variable classes
This commit is contained in:
khorben 2014-09-16 19:25:51 +00:00
parent a7205d963f
commit d7ddfdaac7
6 changed files with 47 additions and 19 deletions

View file

@ -1 +1,4 @@
DeforaOS system library
libSystem is the most essential library within DeforaOS, with the aim to become
a complete C runtime (thus obsoleting the libc and replacing its API).
Regardless of its progress in this regard, libSystem is intended to be portable
and work on any system, using any POSIX-compliant runtime provided instead.

View file

@ -1,11 +1,10 @@
# $NetBSD: Makefile,v 1.6 2014/03/21 13:57:42 jperkin Exp $
# $NetBSD: Makefile,v 1.7 2014/09/16 19:25:51 khorben Exp $
#
DISTNAME= libSystem-0.1.7
PKGNAME= deforaos-libsystem-0.1.7
PKGREVISION= 2
DISTNAME= libSystem-0.2.0
PKGNAME= deforaos-libsystem-0.2.0
CATEGORIES= devel
MASTER_SITES= http://www.defora.org/os/download/download/4321/
MASTER_SITES= http://www.defora.org/os/download/download/4330/
MAINTAINER= khorben@defora.org
HOMEPAGE= http://www.defora.org/

View file

@ -1,4 +1,5 @@
@comment $NetBSD: PLIST,v 1.3 2014/02/21 20:19:21 joerg Exp $
@comment $NetBSD: PLIST,v 1.4 2014/09/16 19:25:51 khorben Exp $
bin/configctl
include/System.h
include/System/array.h
include/System/buffer.h
@ -7,6 +8,8 @@ include/System/error.h
include/System/event.h
include/System/file.h
include/System/hash.h
include/System/license.h
include/System/mutator.h
include/System/object.h
include/System/parser.h
include/System/plugin.h
@ -18,14 +21,15 @@ lib/libSystem.so
lib/libSystem.so.0
lib/libSystem.so.0.0
lib/pkgconfig/libSystem.pc
share/doc/libSystem/README.md
share/gtk-doc/html/libSystem/api-index-full.html
share/gtk-doc/html/libSystem/ch01.html
share/gtk-doc/html/libSystem/deprecated-api-index.html
share/gtk-doc/html/libSystem/home.png
share/gtk-doc/html/libSystem/index.html
share/gtk-doc/html/libSystem/index.sgml
share/gtk-doc/html/libSystem/left.png
share/gtk-doc/html/libSystem/left-insensitive.png
share/gtk-doc/html/libSystem/left.png
share/gtk-doc/html/libSystem/libSystem-array.html
share/gtk-doc/html/libSystem/libSystem-buffer.html
share/gtk-doc/html/libSystem/libSystem-config.html
@ -39,8 +43,10 @@ share/gtk-doc/html/libSystem/libSystem-plugin.html
share/gtk-doc/html/libSystem/libSystem-string.html
share/gtk-doc/html/libSystem/libSystem-token.html
share/gtk-doc/html/libSystem/libSystem.devhelp2
share/gtk-doc/html/libSystem/right.png
share/gtk-doc/html/libSystem/right-insensitive.png
share/gtk-doc/html/libSystem/right.png
share/gtk-doc/html/libSystem/style.css
share/gtk-doc/html/libSystem/up.png
share/gtk-doc/html/libSystem/up-insensitive.png
share/gtk-doc/html/libSystem/up.png
share/man/html1/configctl.html
share/man/man1/configctl.1

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.3 2014/03/21 13:57:42 jperkin Exp $
$NetBSD: distinfo,v 1.4 2014/09/16 19:25:51 khorben Exp $
SHA1 (libSystem-0.1.7.tar.gz) = ba80e9382694b2a08e0a067af5fad941a3ac99ab
RMD160 (libSystem-0.1.7.tar.gz) = 807085177367067e080b92c6b37adef472c5caa1
Size (libSystem-0.1.7.tar.gz) = 42933 bytes
SHA1 (patch-data_pkgconfig.sh) = a70c635d755207d30e45841c64bbe0636a1488fa
SHA1 (libSystem-0.2.0.tar.gz) = c264070ff4034fbdc97aae3f7e694f84e7898365
RMD160 (libSystem-0.2.0.tar.gz) = 8159d1baee58cff3a4adf5f514a1d5c2f45aedbe
Size (libSystem-0.2.0.tar.gz) = 60538 bytes
SHA1 (patch-data_pkgconfig.sh) = 7c40652087c604cff593a320e97259c453633c74
SHA1 (patch-tests_tests.sh) = 530e8a01f2f06876cee5f29e5ba1bdb351d6bda4

View file

@ -1,11 +1,15 @@
$NetBSD: patch-data_pkgconfig.sh,v 1.1 2014/03/21 13:57:42 jperkin Exp $
$NetBSD: patch-data_pkgconfig.sh,v 1.2 2014/09/16 19:25:51 khorben Exp $
Use correct rpath flag on SunOS.
--- data/pkgconfig.sh.orig 2013-02-04 17:28:18.000000000 +0000
--- data/pkgconfig.sh.orig 2014-04-23 15:37:45.000000000 +0000
+++ data/pkgconfig.sh
@@ -114,6 +114,9 @@ while [ $# -gt 0 ]; do
Darwin)
@@ -129,9 +129,12 @@ while [ $# -gt 0 ]; do
if [ "$PREFIX" != "/usr" ]; then
RPATH="-Wl,-rpath-link,\${libdir} -Wl,-rpath,\${libdir}"
case $(uname -s) in
- Darwin|SunOS)
+ Darwin)
RPATH="-Wl,-rpath,\${libdir}"
;;
+ SunOS)

View file

@ -0,0 +1,15 @@
$NetBSD: patch-tests_tests.sh,v 1.1 2014/09/16 19:25:51 khorben Exp $
Avoid building the (experimental) Python binding.
--- tests/tests.sh.orig 2014-08-29 19:23:48.000000000 +0000
+++ tests/tests.sh
@@ -103,7 +103,7 @@ _test "includes"
_test "string"
_test "variable"
echo "Expected failures:" 1>&2
-_fail "python.sh"
+#_fail "python.sh"
if [ -n "$FAILED" ]; then
echo "Failed tests:$FAILED" 1>&2
exit 2