Argh, missed the fact that adam imported the sieve plugin as a separate
dovecot2-pigonhole package. Back out the changes related to this.
This commit is contained in:
parent
b86098fe8b
commit
d7fee69902
5 changed files with 33 additions and 59 deletions
|
@ -1,12 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.3 2010/11/09 15:35:47 ghen Exp $
|
||||
# $NetBSD: Makefile,v 1.4 2010/11/09 15:51:48 ghen Exp $
|
||||
|
||||
DOVECOT_VERSION= 2.0
|
||||
DOVECOT_SUBVERSION= .7
|
||||
SIEVE_VERSION= 0.2.1
|
||||
DISTNAME= dovecot-${DOVECOT_VERSION}${DOVECOT_SUBVERSION}
|
||||
DISTNAME= dovecot-2.0.7
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= http://www.dovecot.org/releases/${DOVECOT_VERSION}/
|
||||
DOVECOT_SIEVE_SITES= http://www.rename-it.nl/dovecot/${DOVECOT_VERSION}/
|
||||
MASTER_SITES= http://www.dovecot.org/releases/2.0/
|
||||
|
||||
MAINTAINER= ghen@NetBSD.org
|
||||
HOMEPAGE= http://www.dovecot.org/
|
||||
|
@ -46,15 +42,6 @@ SUBST_FILES.ssldir= doc/example-config/conf.d/10-ssl.conf
|
|||
SUBST_STAGE.ssldir= pre-configure
|
||||
SUBST_SED.ssldir= -e 's,/etc/ssl,${SSLDIR},'
|
||||
|
||||
SUBST_CLASSES+= egdir
|
||||
SUBST_MESSAGE.egdir= Fixing EGDIR
|
||||
# sieve adds another file here (in options.mk)
|
||||
SUBST_FILES.egdir= doc/example-config/Makefile.in
|
||||
SUBST_FILES.egdir+= doc/example-config/conf.d/Makefile.in
|
||||
SUBST_FILES.egdir+= src/config/Makefile.in
|
||||
SUBST_STAGE.egdir= pre-configure
|
||||
SUBST_SED.egdir= -e 's,^exampledir = .*/example-config,exampledir = ${PREFIX}/share/examples/dovecot,'
|
||||
|
||||
EGDIR= ${PREFIX}/share/examples/dovecot
|
||||
|
||||
CNFS_cmd= ${SED} -ne "s,^share/examples/dovecot/,,p" PLIST
|
||||
|
@ -71,21 +58,12 @@ OWN_DIRS+= ${PKG_SYSCONFDIR}/dovecot/conf.d
|
|||
|
||||
BUILD_DEFS+= VARBASE
|
||||
|
||||
.include "options.mk"
|
||||
|
||||
post-build:
|
||||
.if !empty(PKG_OPTIONS:Mdovecot-sieve)
|
||||
# We need dovecot built in order to be able to configure sieve.
|
||||
cd ${WRKSRC.sieve} \
|
||||
&& env ${CONFIGURE_ENV} ${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS} ${CONFIGURE_ARGS.sieve}
|
||||
cd ${WRKSRC.sieve} \
|
||||
&& env ${MAKE_ENV} ${MAKE_PROGRAM} ${BUILD_MAKE_FLAGS} -f ${MAKE_FILE} ${BUILD_TARGET}
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/dovecot-openssl.cnf ${DESTDIR}${EGDIR}
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/doc/mkcert.sh ${DESTDIR}${EGDIR}
|
||||
|
||||
.include "options.mk"
|
||||
|
||||
.include "../../archivers/bzip2/buildlink3.mk"
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.3 2010/11/09 15:35:47 ghen Exp $
|
||||
$NetBSD: distinfo,v 1.4 2010/11/09 15:51:48 ghen Exp $
|
||||
|
||||
SHA1 (dovecot-2.0-pigeonhole-0.2.1.tar.gz) = ef06d157302576a9276c8f1181a3c5de018e2f36
|
||||
RMD160 (dovecot-2.0-pigeonhole-0.2.1.tar.gz) = a3cd58c13c3de33e6941c94633c580af4406ad85
|
||||
|
@ -6,11 +6,12 @@ Size (dovecot-2.0-pigeonhole-0.2.1.tar.gz) = 1195090 bytes
|
|||
SHA1 (dovecot-2.0.7.tar.gz) = 3aab6cee878bd02e364aebcb70741bf1e4affc0d
|
||||
RMD160 (dovecot-2.0.7.tar.gz) = b284c99630935e87b124f48f132970a14737c985
|
||||
Size (dovecot-2.0.7.tar.gz) = 3174912 bytes
|
||||
SHA1 (patch-aa) = 3f85e3858f451413e07e73916e654cfe81188551
|
||||
SHA1 (patch-aa) = b7e2923ead1ad1eacd3b8b1a37111325794135d2
|
||||
SHA1 (patch-ab) = 43361741cf68d1ad5d6e1073cfb9746acf497868
|
||||
SHA1 (patch-ac) = dc5db4870b14bf2424f0c957f5cf7f1a289fefe6
|
||||
SHA1 (patch-ad) = 5a11ece1ea86ec775d73bd2d305fb927f8669ba5
|
||||
SHA1 (patch-ae) = 51d8cb998cc2ded8bfc767710e465b752c50e656
|
||||
SHA1 (patch-af) = 691cb36fcd5d71e1dea1812da5ed3e93a9ca029a
|
||||
SHA1 (patch-ag) = 1f78984359bb6fcf939c540b54d1dc56317931b4
|
||||
SHA1 (patch-ah) = 2c2ed68bbc475398a0247e08673be5a5db08d3c4
|
||||
SHA1 (patch-ai) = 7ceb18222b47b496099f6634ca4cb4c3edcbf943
|
||||
|
|
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: options.mk,v 1.2 2010/11/09 15:23:11 ghen Exp $
|
||||
# $NetBSD: options.mk,v 1.3 2010/11/09 15:51:48 ghen Exp $
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.dovecot
|
||||
PKG_SUPPORTED_OPTIONS= dovecot-sieve gssapi
|
||||
PKG_SUPPORTED_OPTIONS+= kqueue ldap mysql pam pgsql sqlite
|
||||
PKG_SUPPORTED_OPTIONS= gssapi kqueue ldap mysql pam pgsql sqlite
|
||||
PKG_OPTIONS_OPTIONAL_GROUPS= ssl
|
||||
PKG_OPTIONS_GROUP.ssl= gnutls ssl
|
||||
PKG_SUGGESTED_OPTIONS= ssl
|
||||
|
@ -91,29 +90,3 @@ CONFIGURE_ARGS+= --with-gssapi
|
|||
.else
|
||||
CONFIGURE_ARGS+= --without-gssapi
|
||||
.endif
|
||||
|
||||
###
|
||||
### Pigeonhole Sieve plugin
|
||||
###
|
||||
.if !empty(PKG_OPTIONS:Mdovecot-sieve) || make(distinfo) || make(makesum)
|
||||
# We can't simply use CONFIGURE_DIRS+= and BUILD_DIRS+=
|
||||
# because dovecot must be built before sieve can be configured/built.
|
||||
# So use post-build in Makefile. Sigh.
|
||||
#
|
||||
# Default so we can use += below
|
||||
DISTFILES= ${DEFAULT_DISTFILES}
|
||||
PLIST_SRC= ${PLIST_SRC_DFLT:Q}
|
||||
INSTALL_DIRS= ${WRKSRC}
|
||||
|
||||
DISTFILES+= dovecot-${DOVECOT_VERSION}-pigeonhole-${SIEVE_VERSION}.tar.gz
|
||||
SITES.dovecot-${DOVECOT_VERSION}-pigeonhole-${SIEVE_VERSION}.tar.gz=\
|
||||
${DOVECOT_SIEVE_SITES}
|
||||
WRKSRC.sieve= ${WRKDIR}/dovecot-${DOVECOT_VERSION}-pigeonhole-${SIEVE_VERSION}
|
||||
CONFIGURE_ARGS.sieve= --with-dovecot=${WRKSRC}
|
||||
CONFIGURE_ARGS.sieve+= --docdir=${PREFIX}/share/doc
|
||||
INSTALL_DIRS+= ${WRKSRC.sieve}
|
||||
SUBST_FILES.egdir+= ${WRKSRC.sieve}/doc/example-config/conf.d/Makefile.in
|
||||
PLIST_SRC+= ${PKGDIR}/PLIST.sieve
|
||||
CONF_FILES+= ${EGDIR}/conf.d/20-managesieve.conf ${PKG_SYSCONFDIR}/dovecot/conf.d/20-managesieve.conf
|
||||
CONF_FILES+= ${EGDIR}/conf.d/90-sieve.conf ${PKG_SYSCONFDIR}/dovecot/conf.d/90-sieve.conf
|
||||
.endif # dovecot-sieve
|
||||
|
|
|
@ -1,7 +1,16 @@
|
|||
$NetBSD: patch-aa,v 1.2 2010/11/09 15:23:11 ghen Exp $
|
||||
$NetBSD: patch-aa,v 1.3 2010/11/09 15:51:48 ghen Exp $
|
||||
|
||||
--- doc/example-config/Makefile.in.orig 2010-10-21 17:37:01.000000000 +0000
|
||||
+++ doc/example-config/Makefile.in
|
||||
@@ -280,7 +280,7 @@ top_srcdir = @top_srcdir@
|
||||
SUBDIRS = conf.d
|
||||
pkgsysconfdir = $(sysconfdir)/dovecot
|
||||
nodist_pkgsysconf_DATA = README
|
||||
-exampledir = $(docdir)/example-config
|
||||
+exampledir = $(datadir)/examples/dovecot
|
||||
example_DATA = \
|
||||
dovecot.conf \
|
||||
dovecot-db.conf.ext \
|
||||
@@ -623,8 +623,7 @@ info: info-recursive
|
||||
|
||||
info-am:
|
||||
|
|
13
mail/dovecot2/patches/patch-af
Normal file
13
mail/dovecot2/patches/patch-af
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-af,v 1.3 2010/11/09 15:51:48 ghen Exp $
|
||||
|
||||
--- doc/example-config/conf.d/Makefile.in.orig 2010-11-04 14:32:20.000000000 +0000
|
||||
+++ doc/example-config/conf.d/Makefile.in
|
||||
@@ -237,7 +237,7 @@ top_build_prefix = @top_build_prefix@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
pkgsysconfdir = $(sysconfdir)/dovecot
|
||||
-exampledir = $(docdir)/example-config/conf.d
|
||||
+exampledir = $(datadir)/examples/dovecot/conf.d
|
||||
example_DATA = \
|
||||
auth-checkpassword.conf.ext \
|
||||
auth-deny.conf.ext \
|
Loading…
Reference in a new issue