Update net/couriertcpd to 0.56.0. Changes from version 0.53.2 include:

+ Remove BDB_LIB workaround which should already be handled by the wrapper
  scripts and db1.builtin.mk.
+ Remove unnecessary patch-aa and patch-ab.

* Setting protocol to SSL3 will now disable SSL2.
* Send a dummy EHLO before STARTTLS (gmail wants it).
* Allow setting the max # of connections on a per-IP address basis.
This commit is contained in:
jlam 2007-08-10 17:57:17 +00:00
parent c152764d0e
commit d84da67bc0
4 changed files with 5 additions and 62 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.7 2007/08/02 22:07:32 jlam Exp $
# $NetBSD: Makefile,v 1.8 2007/08/10 17:57:17 jlam Exp $
DISTNAME= courier-${COURIER_VERSION}
PKGNAME= ${DISTNAME:S/-/tcpd-/}
PKGREVISION= 2
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=courier/}
EXTRACT_SUFX= .tar.bz2
@ -47,12 +46,6 @@ BUILD_DEFS+= VARBASE
.include "../../security/openssl/buildlink3.mk"
SUBST_CLASSES+= bdb
SUBST_MESSAGE.bdb= Configuring to use ${BDB_LIBS}
SUBST_STAGE.bdb= post-patch
SUBST_FILES.bdb= configure bdbobj/configure.in bdbobj/configure
SUBST_SED.bdb= -e s,-ldb,${BDB_LIBS:M*:Q},g
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tcpd/couriertcpd \
${PREFIX}/sbin/couriertcpd

View file

@ -1,7 +1,5 @@
$NetBSD: distinfo,v 1.3 2007/02/15 21:51:51 rillig Exp $
$NetBSD: distinfo,v 1.4 2007/08/10 17:57:17 jlam Exp $
SHA1 (courier-0.53.2.tar.bz2) = 89c6a9a57467adf8c1ac815a5ffacf47e5e694a3
RMD160 (courier-0.53.2.tar.bz2) = a6efce3a8d6572923190ea49ed6085906317ebd8
Size (courier-0.53.2.tar.bz2) = 6942557 bytes
SHA1 (patch-aa) = 5e3d549c96a0d25f963ecd08f8bf9f077263cd38
SHA1 (patch-ab) = f0fd449e2784e171ee7ad8c19359d5cb95605e38
SHA1 (courier-0.56.0.tar.bz2) = 536f24db9f33f8d93445c03dd4edb50c7ec2f6b2
RMD160 (courier-0.56.0.tar.bz2) = ce8e2d99f5b7baf500d748c18fbd126df8331398
Size (courier-0.56.0.tar.bz2) = 7022057 bytes

View file

@ -1,35 +0,0 @@
$NetBSD: patch-aa,v 1.1 2006/10/09 01:34:10 ben Exp $
--- bdbobj/Makefile.in.orig 2006-01-29 12:36:19.000000000 -0500
+++ bdbobj/Makefile.in
@@ -225,21 +225,6 @@ all: config.h
.SUFFIXES:
.SUFFIXES: .C .c .lo .o .obj
-am--refresh:
- @:
-$(srcdir)/Makefile.in: $(srcdir)/Makefile.am $(am__configure_deps)
- @for dep in $?; do \
- case '$(am__configure_deps)' in \
- *$$dep*) \
- echo ' cd $(srcdir) && $(AUTOMAKE) --foreign '; \
- cd $(srcdir) && $(AUTOMAKE) --foreign \
- && exit 0; \
- exit 1;; \
- esac; \
- done; \
- echo ' cd $(top_srcdir) && $(AUTOMAKE) --foreign Makefile'; \
- cd $(top_srcdir) && \
- $(AUTOMAKE) --foreign Makefile
.PRECIOUS: Makefile
Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
@case '$?' in \
@@ -618,7 +603,7 @@ ps-am:
uninstall-am: uninstall-info-am
-.PHONY: CTAGS GTAGS all all-am am--refresh check check-am clean \
+.PHONY: CTAGS GTAGS all all-am check check-am clean \
clean-generic clean-libtool clean-noinstLTLIBRARIES \
clean-noinstPROGRAMS ctags dist dist-all dist-bzip2 dist-gzip \
dist-shar dist-tarZ dist-zip distcheck distclean \

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ab,v 1.1 2007/02/15 21:51:52 rillig Exp $
--- courier/courier.c.orig 2005-01-30 06:22:51.000000000 +0100
+++ courier/courier.c 2006-06-25 18:16:00.000000000 +0200
@@ -200,7 +200,7 @@ int main(int argc, char **argv)
#endif
execl( DATADIR "/courierctl.start",
"courierctl.start", (char *)0);
- perror("exec");
+ perror("exec: " DATADIR "/courierctl.start");
_exit(1);
}
_exit(0);