Build the tests when building the gamin package and allow running them.
No visible changes, so no revision bump. Some tests are broken of course. Will investigate later.
This commit is contained in:
parent
656f03a8ad
commit
d865c6e712
4 changed files with 47 additions and 2 deletions
|
@ -1,10 +1,12 @@
|
|||
# $NetBSD: Makefile,v 1.15 2009/03/17 13:34:06 jmcneill Exp $
|
||||
# $NetBSD: Makefile,v 1.16 2010/04/16 22:32:14 jmmv Exp $
|
||||
|
||||
.include "../../sysutils/gamin/Makefile.common"
|
||||
|
||||
PKGREVISION= 2
|
||||
CONFIGURE_ARGS+= --enable-server
|
||||
|
||||
TEST_TARGET= check
|
||||
|
||||
do-install:
|
||||
${INSTALL_LIB_DIR} ${DESTDIR}${PREFIX}/libexec
|
||||
${INSTALL_LIB} ${WRKSRC}/server/gam_server \
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.6 2009/03/17 13:34:06 jmcneill Exp $
|
||||
$NetBSD: distinfo,v 1.7 2010/04/16 22:32:14 jmmv Exp $
|
||||
|
||||
SHA1 (gamin-0.1.10.tar.gz) = f4c6b9fe87757552ef58fef4abef9e42cd3142ac
|
||||
RMD160 (gamin-0.1.10.tar.gz) = fb6ba5ec2d2f49afacf10dda4095f02f5930d686
|
||||
|
@ -10,3 +10,5 @@ SHA1 (patch-ad) = 0ed5da772a0afbce7abf01623c9aebdd67e68537
|
|||
SHA1 (patch-ae) = 954e0d2678193e0bedab7e87b80548a3eef71b0e
|
||||
SHA1 (patch-af) = 7cda705d59206a1fad0c91b56206630f01717adc
|
||||
SHA1 (patch-ag) = 59b35394c29d0cbbf7905df24ef4ba913ebfec46
|
||||
SHA1 (patch-ah) = 79e132b615a6492587a10a550c421fcc91a27761
|
||||
SHA1 (patch-ai) = 54c6d347eef37a97e16c6f00870953fbdba41182
|
||||
|
|
16
sysutils/gamin/patches/patch-ah
Normal file
16
sysutils/gamin/patches/patch-ah
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-ah,v 1.1 2010/04/16 22:32:14 jmmv Exp $
|
||||
|
||||
The server package does not build the libgamin library because it is already
|
||||
installed, so we can trick the package to build the tests.
|
||||
|
||||
--- configure.orig 2010-04-16 22:22:26.000000000 +0000
|
||||
+++ configure
|
||||
@@ -22098,7 +22098,7 @@ fi
|
||||
|
||||
|
||||
enable_tests="no"
|
||||
-if test x$enable_server = xyes && test x$enable_libgamin = xyes ; then
|
||||
+if test x$enable_server = xyes ; then
|
||||
|
||||
pkg_failed=no
|
||||
{ echo "$as_me:$LINENO: checking for TEST" >&5
|
25
sysutils/gamin/patches/patch-ai
Normal file
25
sysutils/gamin/patches/patch-ai
Normal file
|
@ -0,0 +1,25 @@
|
|||
$NetBSD: patch-ai,v 1.1 2010/04/16 22:32:14 jmmv Exp $
|
||||
|
||||
Tests are only built for the server package, which does not build the libgamin
|
||||
library. Link against the installed version.
|
||||
|
||||
--- tests/Makefile.in.orig 2008-11-24 15:25:07.000000000 +0000
|
||||
+++ tests/Makefile.in
|
||||
@@ -69,7 +69,7 @@ CTAGS = ctags
|
||||
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
|
||||
ACLOCAL = @ACLOCAL@
|
||||
AMTAR = @AMTAR@
|
||||
-AM_CFLAGS = @AM_CFLAGS@
|
||||
+AM_CFLAGS = @AM_CFLAGS@ $$(pkg-config --cflags gamin)
|
||||
AR = @AR@
|
||||
AUTOCONF = @AUTOCONF@
|
||||
AUTOHEADER = @AUTOHEADER@
|
||||
@@ -208,7 +208,7 @@ LDADD = $(top_builddir)/libgamin/libgami
|
||||
testgam_SOURCES = testing.c
|
||||
testgam_LDFLAGS =
|
||||
testgam_DEPENDENCIES = $(DEPS)
|
||||
-testgam_LDADD = $(LDADDS) -L$(top_builddir)/libgamin -lgamin-1
|
||||
+testgam_LDADD = $(LDADDS) $$(pkg-config --libs gamin)
|
||||
all: all-am
|
||||
|
||||
.SUFFIXES:
|
Loading…
Reference in a new issue