Fix subversion shared libraries search paths when configuring the
Perl modules. Fix problem like the following and as seen in bulk build logs: $ perl -MSVN::Ra -e '1' /usr/pkg/lib/perl5/vendor_perl/5.8.0/i386-netbsd-thread-multi/auto/SVN/_Ra/_Ra.so: Undefined PLT symbol "svn_ra_init_ra_libs" (symnum = 13) Approved by maintainer. Bump PKGREVISION of the p5-subversion package to 2.
This commit is contained in:
parent
a49cab88f1
commit
d87244a499
3 changed files with 21 additions and 3 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.41 2008/09/06 20:54:32 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.42 2008/09/09 00:14:06 seb Exp $
|
||||
|
||||
PKGNAME= p5-subversion-${SVNVER}
|
||||
PKGREVISION= 1
|
||||
PKGREVISION= 2
|
||||
COMMENT= Perl bindings for Subversion
|
||||
|
||||
PKG_INSTALLATION_TYPES= overwrite pkgviews
|
||||
|
@ -21,6 +21,7 @@ PERL5_PACKLIST= auto/SVN/_Core/.packlist
|
|||
BUILD_TARGET= swig-pl
|
||||
INSTALL_TARGET= install-swig-pl
|
||||
TEST_TARGET= check-swig-pl
|
||||
MAKE_ENV+= SUBVERSION_BASE_PREFIX=${BUILDLINK_PREFIX.subversion-base}
|
||||
|
||||
post-patch:
|
||||
${RM} ${WRKSRC}/build-outputs.mk
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.64 2008/09/06 05:30:57 epg Exp $
|
||||
$NetBSD: distinfo,v 1.65 2008/09/09 00:14:06 seb Exp $
|
||||
|
||||
SHA1 (subversion-1.5.2.tar.gz) = 10274c7c3d3a7bce11d5d470bdf110d4ff3cd6bd
|
||||
RMD160 (subversion-1.5.2.tar.gz) = a5210af327006f15a08f750bdd3a6af2852d8c48
|
||||
Size (subversion-1.5.2.tar.gz) = 6646636 bytes
|
||||
SHA1 (patch-ad) = 52da52e60e4d70266081d98ab0bf4ec312427bd6
|
||||
SHA1 (patch-ae) = 55982ded0a7cbb09a91545c7580021e8ed4947f0
|
||||
|
|
16
devel/subversion/patches/patch-ae
Normal file
16
devel/subversion/patches/patch-ae
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-ae,v 1.17 2008/09/09 00:14:06 seb Exp $
|
||||
|
||||
--- subversion/bindings/swig/perl/native/Makefile.PL.in.orig 2008-03-21 23:44:46.000000000 +0000
|
||||
+++ subversion/bindings/swig/perl/native/Makefile.PL.in
|
||||
@@ -14,9 +14,10 @@ my $svnlib_srcdir = "${top_srcdir}/subve
|
||||
my $svnlib_builddir = "${top_builddir}/subversion";
|
||||
my $swig_srcdir = "${svnlib_srcdir}/bindings/swig";
|
||||
my $swig_builddir = "${svnlib_builddir}/bindings/swig";
|
||||
+my $subversion_base_lib = $ENV{SUBVERSION_BASE_PREFIX} . "/lib";
|
||||
|
||||
my @modules = qw/client delta fs ra repos wc/;
|
||||
-my @ldpaths = ("$swig_builddir/perl/libsvn_swig_perl/.libs",
|
||||
+my @ldpaths = ("$swig_builddir/perl/libsvn_swig_perl/.libs", $subversion_base_lib,
|
||||
map {"$svnlib_builddir/libsvn_$_/.libs"} (@modules, qw/diff subr
|
||||
ra_local
|
||||
ra_svn
|
Loading…
Reference in a new issue