Update php55 to 5.5.20, including security fix.

17 Dec 2014, PHP 5.5.20

- Core:
  . Fixed bug #68091 (Some Zend headers lack appropriate extern "C" blocks).
    (Adam)
  . Fixed bug #68185 ("Inconsistent insteadof definition."- incorrectly
    triggered). (Julien)
  . Fixed bug #68370 ("unset($this)" can make the program crash). (Laruence)
  . Fixed bug #68545 (NULL pointer dereference in unserialize.c). (Anatol)
  . Fixed bug #68594 (Use after free vulnerability in unserialize()).
    (CVE-2014-8142) (Stefan Esser)

- Date:
  . Fixed day_of_week function as it could sometimes return negative values
    internally. (Derick)

- FPM:
  . Fixed bug #68381 (fpm_unix_init_main ignores log_level).
    (David Zuelke, Remi)
  . Fixed bug #68420 (listen=9000 listens to ipv6 localhost instead of all
    addresses). (Remi)
  . Fixed bug #68421 (access.format='%R' doesn't log ipv6 address). (Remi)
  . Fixed bug #68423 (PHP-FPM will no longer load all pools). (Remi)
  . Fixed bug #68428 (listen.allowed_clients is IPv4 only). (Remi)
  . Fixed bug #68452 (php-fpm man page is oudated). (Remi)
  . Fixed request #68458 (Change pm.start_servers default warning to
    notice). (David Zuelke, Remi)
  . Fixed bug #68463 (listen.allowed_clients can silently result
    in no allowed access). (Remi)
  . Fixed request #68391 (php-fpm conf files loading order).
    (Florian Margaine, Remi)
  . Fixed bug #68478 (access.log don't use prefix). (Remi)

- Mcrypt:
  . Fixed possible read after end of buffer and use after free. (Dmitry)

- PDO_pgsql:
  . Fixed bug #66584 (Segmentation fault on statement deallocation) (Matteo)
  . Fixed bug #67462 (PDO_PGSQL::beginTransaction() wrongly throws exception
  when not in transaction) (Matteo)
  . Fixed bug #68351 (PDO::PARAM_BOOL and ATTR_EMULATE_PREPARES misbehaving)
  (Matteo)

- zlib:
  . Fixed bug #53829 (Compiling PHP with large file support will replace
    function gzopen by gzopen64) (Sascha Kettler, Matteo)
This commit is contained in:
taca 2014-12-19 16:10:38 +00:00
parent d0f8d9a4fa
commit d88e5badbc
3 changed files with 14 additions and 11 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: phpversion.mk,v 1.79 2014/12/19 16:08:35 taca Exp $ # $NetBSD: phpversion.mk,v 1.80 2014/12/19 16:10:38 taca Exp $
# #
# This file selects a PHP version, based on the user's preferences and # This file selects a PHP version, based on the user's preferences and
# the installed packages. It does not add a dependency on the PHP # the installed packages. It does not add a dependency on the PHP
@ -83,7 +83,7 @@ PHPVERSION_MK= defined
# Define each PHP's version. # Define each PHP's version.
PHP53_VERSION= 5.3.29 PHP53_VERSION= 5.3.29
PHP54_VERSION= 5.4.36 PHP54_VERSION= 5.4.36
PHP55_VERSION= 5.5.19 PHP55_VERSION= 5.5.20
PHP56_VERSION= 5.6.3 PHP56_VERSION= 5.6.3
# Define initial release of major version. # Define initial release of major version.

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.31 2014/11/15 14:53:12 taca Exp $ $NetBSD: distinfo,v 1.32 2014/12/19 16:10:38 taca Exp $
SHA1 (php-5.5.19.tar.bz2) = 1d22f5ea0fbd4eb0d7df4618990dbbbdd47dd2de SHA1 (php-5.5.20.tar.bz2) = 58acd296969f1b49643c3b70d5f244841fe59abf
RMD160 (php-5.5.19.tar.bz2) = 0fea87a94feaceee50b6b110ab92755dd3a079e0 RMD160 (php-5.5.20.tar.bz2) = 701aef3c54773ce8cc10352f6badd69046bb8d09
Size (php-5.5.19.tar.bz2) = 13280178 bytes Size (php-5.5.20.tar.bz2) = 13240796 bytes
SHA1 (patch-acinclude.m4) = 9e9c433e4cb96e469f7cf14b2064a0f41fc4568a SHA1 (patch-acinclude.m4) = 9e9c433e4cb96e469f7cf14b2064a0f41fc4568a
SHA1 (patch-aclocal.m4) = 46f192351e541453b1e32299acd1b4cfefc93cb2 SHA1 (patch-aclocal.m4) = 46f192351e541453b1e32299acd1b4cfefc93cb2
SHA1 (patch-build_libtool.m4) = 3811edd697fd21eadc4f65cba35c6297141e8ff2 SHA1 (patch-build_libtool.m4) = 3811edd697fd21eadc4f65cba35c6297141e8ff2
@ -13,7 +13,7 @@ SHA1 (patch-ext_mssql_php__mssql.c) = 4ef1837850443e9db2e71620a3ddaed5ab5c435b
SHA1 (patch-ext_opcache_config.m4) = 7c0d98feaeec8a0ca61f6f77a1906aa2d601be3f SHA1 (patch-ext_opcache_config.m4) = 7c0d98feaeec8a0ca61f6f77a1906aa2d601be3f
SHA1 (patch-ext_pdo__mysql_config.m4) = 3526e737da25129710218e7141d5a05ae0a51390 SHA1 (patch-ext_pdo__mysql_config.m4) = 3526e737da25129710218e7141d5a05ae0a51390
SHA1 (patch-ext_pdo_config.m4) = 26a4ad02e5c6b7a54c3c54a6d026a3ccfed62c59 SHA1 (patch-ext_pdo_config.m4) = 26a4ad02e5c6b7a54c3c54a6d026a3ccfed62c59
SHA1 (patch-ext_phar_Makefile.frag) = 1af23d9135557bc7ba2f3627b317d4cbef37aaba SHA1 (patch-ext_phar_Makefile.frag) = f8e3f7b7c3e93765d019e5614a884df6185d0436
SHA1 (patch-ext_phar_phar_phar.php) = 011f2d68048dbc63f5efcab4e23062daa9e8e08c SHA1 (patch-ext_phar_phar_phar.php) = 011f2d68048dbc63f5efcab4e23062daa9e8e08c
SHA1 (patch-ext_sqlite3_libsqlite_sqlite3.c) = b384b9daa466f2a8a3e6cfd4ea6cff81f9342941 SHA1 (patch-ext_sqlite3_libsqlite_sqlite3.c) = b384b9daa466f2a8a3e6cfd4ea6cff81f9342941
SHA1 (patch-ext_standard_basic__functions.c) = f2a44998145306c2cb2d2f3822c0e7cc70c778b4 SHA1 (patch-ext_standard_basic__functions.c) = f2a44998145306c2cb2d2f3822c0e7cc70c778b4

View file

@ -1,6 +1,6 @@
$NetBSD: patch-ext_phar_Makefile.frag,v 1.1 2013/07/29 16:41:02 taca Exp $ $NetBSD: patch-ext_phar_Makefile.frag,v 1.2 2014/12/19 16:10:38 taca Exp $
--- ext/phar/Makefile.frag.orig 2012-05-03 17:10:43.000000000 +0000 --- ext/phar/Makefile.frag.orig 2014-12-17 09:39:40.000000000 +0000
+++ ext/phar/Makefile.frag +++ ext/phar/Makefile.frag
@@ -18,7 +18,7 @@ PHP_PHARCMD_EXECUTABLE = ` \ @@ -18,7 +18,7 @@ PHP_PHARCMD_EXECUTABLE = ` \
else \ else \
@ -11,9 +11,12 @@ $NetBSD: patch-ext_phar_Makefile.frag,v 1.1 2013/07/29 16:41:02 taca Exp $
$(builddir)/phar/phar.inc: $(srcdir)/phar/phar.inc $(builddir)/phar/phar.inc: $(srcdir)/phar/phar.inc
-@test -d $(builddir)/phar || mkdir $(builddir)/phar -@test -d $(builddir)/phar || mkdir $(builddir)/phar
@@ -39,4 +39,4 @@ install-pharcmd: pharcmd @@ -39,7 +39,7 @@ install-pharcmd: pharcmd
-@$(mkinstalldirs) $(INSTALL_ROOT)$(bindir) -@$(mkinstalldirs) $(INSTALL_ROOT)$(bindir)
$(INSTALL) $(builddir)/phar.phar $(INSTALL_ROOT)$(bindir) $(INSTALL) $(builddir)/phar.phar $(INSTALL_ROOT)$(bindir)
-@rm -f $(INSTALL_ROOT)$(bindir)/phar -@rm -f $(INSTALL_ROOT)$(bindir)/phar
- $(LN_S) -f $(bindir)/phar.phar $(INSTALL_ROOT)$(bindir)/phar - $(LN_S) -f $(INSTALL_ROOT)$(bindir)/phar.phar $(INSTALL_ROOT)$(bindir)/phar
+ $(LN_S) -f phar.phar $(INSTALL_ROOT)$(bindir)/phar + $(LN_S) -f phar.phar $(INSTALL_ROOT)$(bindir)/phar
@$(mkinstalldirs) $(INSTALL_ROOT)$(mandir)/man1
@$(INSTALL_DATA) $(builddir)/phar.1 $(INSTALL_ROOT)$(mandir)/man1/phar.1
@$(INSTALL_DATA) $(builddir)/phar.phar.1 $(INSTALL_ROOT)$(mandir)/man1/phar.phar.1