va_list may not be a pointer. Bump revision.

This commit is contained in:
joerg 2015-02-19 22:23:16 +00:00
parent 59e8910a4c
commit d8b4c5a39d
5 changed files with 84 additions and 3 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.33 2014/05/05 00:47:35 ryoon Exp $
# $NetBSD: Makefile,v 1.34 2015/02/19 22:23:16 joerg Exp $
#
DISTNAME= buzztard-0.5.0
PKGREVISION= 29
PKGREVISION= 30
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=buzztard/}

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.1.1.1 2009/09/10 20:16:44 wiz Exp $
$NetBSD: distinfo,v 1.2 2015/02/19 22:23:16 joerg Exp $
SHA1 (buzztard-0.5.0.tar.gz) = cc85a0ca01c336ba6ca592ca4f26985a08a8f7e0
RMD160 (buzztard-0.5.0.tar.gz) = e1b43637f2850b03061f0dce93d1240e40529f90
@ -6,3 +6,6 @@ Size (buzztard-0.5.0.tar.gz) = 2247279 bytes
SHA1 (patch-aa) = 7dafa7d47fa578f3ccbcb02f0ee02c0af20aab69
SHA1 (patch-ac) = 5acdc7173dd17a3fa60cc5d03821ea4cf2b35fc9
SHA1 (patch-ad) = 7e31fd612d6ed3ced50027753dd39bf2e3db2891
SHA1 (patch-src_lib_core_processor-machine.c) = 389b475ee77eeef96ed35aab8384afd9d50b2377
SHA1 (patch-src_lib_core_sink-machine.c) = 070c195918ef10f2ad1b02e4c314a18c5c8c2c16
SHA1 (patch-src_lib_core_source-machine.c) = b8a27aeef7f11bbb1863c175ed808492465c246e

View file

@ -0,0 +1,26 @@
$NetBSD: patch-src_lib_core_processor-machine.c,v 1.1 2015/02/19 22:23:16 joerg Exp $
--- src/lib/core/processor-machine.c.orig 2009-03-23 18:43:53.000000000 +0000
+++ src/lib/core/processor-machine.c
@@ -97,6 +97,12 @@ static xmlNodePtr bt_processor_machine_p
return(node);
}
+static void bt_processor_machine_persistence_load_helper(BtPersistenceInterface *parent_iface, BtPersistence *result, xmlNodePtr node, const BtPersistenceLocation * const location, ...) {
+ va_list ap;
+ va_start(ap, location);
+ parent_iface->load(BT_TYPE_MACHINE,result,node,location,NULL, ap);
+}
+
static BtPersistence *bt_processor_machine_persistence_load(const GType type, const BtPersistence * const persistence, xmlNodePtr node, const BtPersistenceLocation * const location, GError **err, va_list var_args) {
BtProcessorMachine *self;
BtPersistence *result;
@@ -147,7 +153,7 @@ static BtPersistence *bt_processor_machi
// load parent class stuff
parent_iface=g_type_interface_peek_parent(BT_PERSISTENCE_GET_INTERFACE(result));
- parent_iface->load(BT_TYPE_MACHINE,result,node,location,NULL,NULL);
+ bt_processor_machine_persistence_load_helper(parent_iface, result, node, location);
return(result);
}

View file

@ -0,0 +1,26 @@
$NetBSD: patch-src_lib_core_sink-machine.c,v 1.1 2015/02/19 22:23:16 joerg Exp $
--- src/lib/core/sink-machine.c.orig 2015-02-19 20:43:52.000000000 +0000
+++ src/lib/core/sink-machine.c
@@ -123,6 +123,12 @@ static xmlNodePtr bt_sink_machine_persis
return(node);
}
+static void bt_sink_machine_persistence_load_helper(BtPersistenceInterface *parent_iface, BtPersistence *result, xmlNodePtr node, const BtPersistenceLocation * const location, ...) {
+ va_list ap;
+ va_start(ap, location);
+ parent_iface->load(BT_TYPE_MACHINE,result,node,location,NULL, ap);
+}
+
static BtPersistence *bt_sink_machine_persistence_load(const GType type, const BtPersistence * const persistence, xmlNodePtr node, const BtPersistenceLocation * const location, GError **err, va_list var_args) {
BtSinkMachine *self;
BtPersistence *result;
@@ -164,7 +170,7 @@ static BtPersistence *bt_sink_machine_pe
// load parent class stuff
parent_iface=g_type_interface_peek_parent(BT_PERSISTENCE_GET_INTERFACE(result));
- parent_iface->load(BT_TYPE_MACHINE,result,node,location,NULL,NULL);
+ bt_sink_machine_persistence_load_helper(parent_iface, result, node, location);
return(result);
}

View file

@ -0,0 +1,26 @@
$NetBSD: patch-src_lib_core_source-machine.c,v 1.1 2015/02/19 22:23:16 joerg Exp $
--- src/lib/core/source-machine.c.orig 2015-02-19 20:47:08.000000000 +0000
+++ src/lib/core/source-machine.c
@@ -91,6 +91,12 @@ static xmlNodePtr bt_source_machine_pers
return(node);
}
+static void bt_source_machine_persistence_load_helper(BtPersistenceInterface *parent_iface, BtPersistence *result, xmlNodePtr node, const BtPersistenceLocation * const location, ...) {
+ va_list ap;
+ va_start(ap, location);
+ parent_iface->load(BT_TYPE_MACHINE,result,node,location,NULL, ap);
+}
+
static BtPersistence *bt_source_machine_persistence_load(const GType type, const BtPersistence * const persistence, xmlNodePtr node, const BtPersistenceLocation * const location, GError **err, va_list var_args) {
BtSourceMachine *self;
BtPersistence *result;
@@ -133,7 +139,7 @@ static BtPersistence *bt_source_machine_
// load parent class stuff
parent_iface=g_type_interface_peek_parent(BT_PERSISTENCE_GET_INTERFACE(result));
- parent_iface->load(BT_TYPE_MACHINE,result,node,location,NULL,NULL);
+ bt_source_machine_persistence_load_helper(parent_iface, result, node, location);
return(result);
}