Add some NetBSD-specific file systems to the appropriate table in
gnome-vfs's code so that they are properly recognized. More specifically this finally fixes the trash in Nautilus: it didn't show files in the home directory if it was stored in one of these "unknown" file systems. Bump PKGREVISION to 5. Closes PR pkg/30184.
This commit is contained in:
parent
81bb39524e
commit
d8b7e8d485
3 changed files with 42 additions and 3 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.58 2006/03/21 06:00:49 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.59 2006/03/29 20:41:12 jmmv Exp $
|
||||
|
||||
PKGCONFIG_OVERRIDE= gnome-vfs-2.0.pc.in
|
||||
PKGCONFIG_OVERRIDE+= gnome-vfs-module-2.0.pc.in
|
||||
|
@ -20,7 +20,7 @@ LDFLAGS.Darwin+= -lresolv
|
|||
BUILDLINK_DEPENDS.glib2+= glib2>=2.6.0
|
||||
|
||||
.include "Makefile.common"
|
||||
PKGREVISION= 4
|
||||
PKGREVISION= 5
|
||||
|
||||
.include "../../devel/GConf2/schemas.mk"
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.46 2006/01/20 13:29:13 jmmv Exp $
|
||||
$NetBSD: distinfo,v 1.47 2006/03/29 20:41:12 jmmv Exp $
|
||||
|
||||
SHA1 (gnome-vfs-2.12.2.tar.bz2) = fa8248e18cb8b44f617a5b1bb776df37628828ea
|
||||
RMD160 (gnome-vfs-2.12.2.tar.bz2) = 831d83c791631e7273fdebec1047da6055757104
|
||||
|
@ -19,3 +19,4 @@ SHA1 (patch-ar) = 99c99d0d90ed7a0d804b349f532d3a17c780d506
|
|||
SHA1 (patch-au) = e3c681dd445d0774981a50eb22ae14ff4db5902c
|
||||
SHA1 (patch-aw) = 22801eb932f8f7e7256be3863fcd5273a7a5213e
|
||||
SHA1 (patch-ax) = a8bea4b2f4432506e9d4407beaaa2e3655ca6235
|
||||
SHA1 (patch-az) = 50d74fbf4973a5f6366a20b89e17bab450e73784
|
||||
|
|
38
sysutils/gnome-vfs2/patches/patch-az
Normal file
38
sysutils/gnome-vfs2/patches/patch-az
Normal file
|
@ -0,0 +1,38 @@
|
|||
$NetBSD: patch-az,v 1.1 2006/03/29 20:41:12 jmmv Exp $
|
||||
|
||||
http://bugzilla.gnome.org/show_bug.cgi?id=336533
|
||||
|
||||
--- libgnomevfs/gnome-vfs-filesystem-type.c 18 Jul 2005 12:29:56 -0000 1.7
|
||||
+++ libgnomevfs/gnome-vfs-filesystem-type.c 29 Mar 2006 19:36:18 -0000
|
||||
@@ -45,12 +45,15 @@ static struct FSInfo fs_data[] = {
|
||||
{ "ext2fs" , N_("Ext2 Linux Volume"), 1 },
|
||||
{ "ext3" , N_("Ext3 Linux Volume"), 1 },
|
||||
{ "fat" , N_("MSDOS Volume"), 1 },
|
||||
+ { "ffs" , N_("BSD Volume"), 1 },
|
||||
{ "hfs" , N_("MacOS Volume"), 1 },
|
||||
{ "hfsplus" , N_("MacOS Volume"), 0 },
|
||||
{ "iso9660" , N_("CDROM Volume"), 0 },
|
||||
{ "hsfs" , N_("Hsfs CDROM Volume"), 0 },
|
||||
{ "jfs" , N_("JFS Volume"), 1 },
|
||||
{ "hpfs" , N_("Windows NT Volume"), 0 },
|
||||
+ { "kernfs" , N_("System Volume"), 0 },
|
||||
+ { "lfs" , N_("BSD Volume"), 1 },
|
||||
{ "linprocfs", N_("System Volume"), 0 },
|
||||
{ "mfs" , N_("Memory Volume"), 1 },
|
||||
{ "minix" , N_("Minix Volume"), 0 },
|
||||
@@ -61,6 +64,7 @@ static struct FSInfo fs_data[] = {
|
||||
{ "nwfs" , N_("Netware Volume"), 0 },
|
||||
{ "proc" , N_("System Volume"), 0 },
|
||||
{ "procfs" , N_("System Volume"), 0 },
|
||||
+ { "ptyfs" , N_("System Volume"), 0 },
|
||||
{ "reiser4" , N_("Reiser4 Linux Volume"), 1 },
|
||||
{ "reiserfs" , N_("ReiserFS Linux Volume"), 1 },
|
||||
{ "smbfs" , N_("Windows Shared Volume"), 1 },
|
||||
@@ -70,6 +74,7 @@ static struct FSInfo fs_data[] = {
|
||||
{ "udfs" , N_("Udfs Solaris Volume"), 1 },
|
||||
{ "pcfs" , N_("Pcfs Solaris Volume"), 1 },
|
||||
{ "samfs" , N_("Sun SAM-QFS Volume"), 1 },
|
||||
+ { "tmpfs" , N_("Temporary Volume"), 1 },
|
||||
{ "umsdos" , N_("Enhanced DOS Volume"), 0 },
|
||||
{ "vfat" , N_("Windows VFAT Volume"), 1 },
|
||||
{ "xenix" , N_("Xenix Volume"), 0 },
|
Loading…
Reference in a new issue