Update to version 3.0.1.
Changes: 3.0.1: ====== - fixed timeout handling in sftp. - fixed a coredump in case of some network errors. - fixed compilation with gcc-2.95. - fixed compilation with socks. - fixed compilation without ssl. 3.0.0: ====== - sftp protocol support (use `sftp://user@host' URLs). sftp is a protocol implemented as ssh2 subsystem, it is binary and works over a secure channel. - faster directory caching, no re-parsing each time. - ftp now follows RFC2640; FEAT, LANG, UTF8 support; new settings ftp:use-feat and ftp:lang. - ftp can set modification time on remote files using either SITE UTIME or two argument MDTM command (off by default); new settings ftp:use-site-utime and ftp:use-mdtm-overloaded. - ftp can now use MLSD to get machine parseable file listing (ftp:use-mlsd). - charset translation in ftp protocol, new setting ftp:charset. - new mirror option --delete-first to remove old files before transferring new files. By default mirror removes old files after the transfers. - now mirror can replace directories with plain files or symbolic links if --delete (-e) option is specified. - ftp can now use CONNECT method of http proxies (when ftp:use-hftp is false). - mirror open --newer-than can now take time specification like that of at(1) command, like `week ago', `now-7days' or `2004-01-01'. - new mirror options --ignore-size and --only-missing. - new mirror option --use-pget[-n=N] to make mirror use pget to transfer files. - debug output can now include date and time on each line (debug -t). When lftp goes to background, this is turned on by default, along with pid (-p) and context (-c). Try `debug -tcp' and see. - get1 command has now --source-region and --target-position options to get a part of a file. - better handling of ~/.netrc - multiple logins for the same machine are allowed, proper password is taken automatically from netrc if a login matches. - pget has now a progress bar which shows file download state. - new source option -e to execute output of an external program. - chmod -R fixed. - fixed cache invalidation when file name being invalidated ends with a slash.
This commit is contained in:
parent
539fd7b9ca
commit
d8ebd6c10d
4 changed files with 18 additions and 15 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.37 2004/03/29 03:30:33 schmonz Exp $
|
||||
# $NetBSD: Makefile,v 1.38 2004/04/10 23:51:36 salo Exp $
|
||||
#
|
||||
|
||||
DISTNAME= lftp-2.6.12
|
||||
PKGREVISION= 1
|
||||
DISTNAME= lftp-3.0.1
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ftp://ftp.yars.free.net/pub/software/unix/net/ftp/client/lftp/ \
|
||||
ftp://ftp.yars.free.net/pub/software/unix/net/ftp/client/lftp/old/
|
||||
|
|
|
@ -1,12 +1,14 @@
|
|||
@comment $NetBSD: PLIST,v 1.6 2003/12/03 09:06:56 salo Exp $
|
||||
@comment $NetBSD: PLIST,v 1.7 2004/04/10 23:51:36 salo Exp $
|
||||
bin/lftp
|
||||
bin/lftpget
|
||||
lib/lftp/${PKGVERSION}/cmd-mirror.la
|
||||
lib/lftp/${PKGVERSION}/cmd-mirror.so
|
||||
lib/lftp/${PKGVERSION}/cmd-sleep.la
|
||||
lib/lftp/${PKGVERSION}/cmd-sleep.so
|
||||
lib/lftp/${PKGVERSION}/libnetwork.la
|
||||
lib/lftp/${PKGVERSION}/libnetwork.so
|
||||
lib/lftp/${PKGVERSION}/liblftp-network.la
|
||||
lib/lftp/${PKGVERSION}/liblftp-network.so
|
||||
lib/lftp/${PKGVERSION}/liblftp-pty.la
|
||||
lib/lftp/${PKGVERSION}/liblftp-pty.so
|
||||
lib/lftp/${PKGVERSION}/proto-file.la
|
||||
lib/lftp/${PKGVERSION}/proto-file.so
|
||||
lib/lftp/${PKGVERSION}/proto-fish.la
|
||||
|
@ -15,6 +17,8 @@ lib/lftp/${PKGVERSION}/proto-ftp.la
|
|||
lib/lftp/${PKGVERSION}/proto-ftp.so
|
||||
lib/lftp/${PKGVERSION}/proto-http.la
|
||||
lib/lftp/${PKGVERSION}/proto-http.so
|
||||
lib/lftp/${PKGVERSION}/proto-sftp.la
|
||||
lib/lftp/${PKGVERSION}/proto-sftp.so
|
||||
man/man1/lftp.1
|
||||
share/examples/lftp/lftp.conf.default
|
||||
share/lftp/import-ncftp
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.16 2004/01/23 21:38:27 cube Exp $
|
||||
$NetBSD: distinfo,v 1.17 2004/04/10 23:51:36 salo Exp $
|
||||
|
||||
SHA1 (lftp-2.6.12.tar.bz2) = 96b399211a4008ae96f7c1ce44756632250d154e
|
||||
Size (lftp-2.6.12.tar.bz2) = 1188316 bytes
|
||||
SHA1 (patch-aa) = 0b185499b21ec6005630a6045408cc8c4e3c4425
|
||||
SHA1 (lftp-3.0.1.tar.bz2) = 437b657899cc2570b2f977c2d76dcfaf180a9e4f
|
||||
Size (lftp-3.0.1.tar.bz2) = 1213419 bytes
|
||||
SHA1 (patch-aa) = fb0ed7e19b2f1119fa515ee2dc656ee6e1e285ce
|
||||
SHA1 (patch-ab) = 4312c2878b6e553bdadfab8528906f811cd9d381
|
||||
SHA1 (patch-ac) = 6df164610322c4dcfa82b8cb92e6a0845a75aee2
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
$NetBSD: patch-aa,v 1.5 2003/12/23 10:11:23 cube Exp $
|
||||
$NetBSD: patch-aa,v 1.6 2004/04/10 23:51:36 salo Exp $
|
||||
|
||||
--- src/Makefile.in.orig Mon Dec 22 14:56:28 2003
|
||||
+++ src/Makefile.in
|
||||
@@ -821,7 +821,7 @@ check-am: all-am
|
||||
--- src/Makefile.in.orig 2004-04-06 10:28:39.000000000 +0200
|
||||
+++ src/Makefile.in 2004-04-11 01:28:03.000000000 +0200
|
||||
@@ -831,7 +831,7 @@
|
||||
check: check-am
|
||||
all-am: Makefile $(LIBRARIES) $(LTLIBRARIES) $(PROGRAMS) $(SCRIPTS)
|
||||
all-am: Makefile $(LTLIBRARIES) $(PROGRAMS) $(SCRIPTS)
|
||||
installdirs:
|
||||
- $(mkdir_p) $(DESTDIR)$(pkgverlibdir) $(DESTDIR)$(bindir) $(DESTDIR)$(bindir) $(DESTDIR)$(pkgdatadir)
|
||||
+ $(mkdir_p) $(DESTDIR)$(bindir) $(DESTDIR)$(bindir) $(DESTDIR)$(pkgdatadir)
|
||||
|
|
Loading…
Reference in a new issue