Get "make reinstall" to work.
This commit is contained in:
parent
39a37f4d3e
commit
d8faec9a19
2 changed files with 20 additions and 4 deletions
|
@ -3,7 +3,7 @@
|
|||
# Date created: 25 Sep 1994
|
||||
# Whom: swallace
|
||||
#
|
||||
# $NetBSD: Makefile,v 1.6 1998/02/16 12:17:14 agc Exp $
|
||||
# $NetBSD: Makefile,v 1.7 1998/02/16 19:40:11 tron Exp $
|
||||
# FreeBSD Id: Makefile,v 1.14 1997/04/30 23:49:14 asami Exp
|
||||
#
|
||||
|
||||
|
@ -15,6 +15,10 @@ MAINTAINER= agc@netbsd.org
|
|||
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_SCRIPT= Configure
|
||||
|
||||
MAKE_ENV+= INSTALL_MAN="${INSTALL_MAN}" \
|
||||
COPY="${COPY}" STRIPFLAG="${STRIPFLAG}"
|
||||
|
||||
MAN1= top.1
|
||||
|
||||
OPSYS!= uname -s
|
||||
|
@ -36,7 +40,4 @@ pre-configure:
|
|||
.endif
|
||||
chmod a-x ${WRKSRC}/install
|
||||
|
||||
post-install:
|
||||
strip ${PREFIX}/bin/top
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
15
sysutils/top/patches/patch-ac
Normal file
15
sysutils/top/patches/patch-ac
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- Makefile.X.orig Wed Nov 20 03:19:24 1996
|
||||
+++ Makefile.X Mon Feb 16 20:31:17 1998
|
||||
@@ -100,10 +100,10 @@
|
||||
install: top top.1 install-top install-$(MANSTY)
|
||||
|
||||
install-top:
|
||||
- $(INSTALL) -o $(OWNER) -m $(MODE) -g $(GROUP) top $(BINDIR)
|
||||
+ ${INSTALL} ${COPY} ${STRIPFLAG} -o $(OWNER) -m $(MODE) -g $(GROUP) top $(BINDIR)
|
||||
|
||||
install-man:
|
||||
- $(INSTALL) top.1 $(MANDIR)/top.$(MANEXT)
|
||||
+ ${INSTALL_MAN} top.1 $(MANDIR)/top.$(MANEXT)
|
||||
|
||||
install-catman:
|
||||
tbl top.1 | nroff -man > $(MANDIR)/top.$(MANEXT)
|
Loading…
Reference in a new issue