py-passlib: Access actual bcrypt version

Recent bcrypt package no longer has __about__ field, the version is directly
under __version__.

Noticed via:

 python3 -c 'import passlib.apache'

PKGREVISION++
This commit is contained in:
leot 2024-01-01 16:19:57 +00:00
parent fd7812fed2
commit d8fe81d507
3 changed files with 20 additions and 3 deletions

View File

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.10 2022/01/04 20:54:43 wiz Exp $
# $NetBSD: Makefile,v 1.11 2024/01/01 16:19:57 leot Exp $
DISTNAME= passlib-1.7.4
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
PKGREVISION= 1
PKGREVISION= 2
CATEGORIES= security python
MASTER_SITES= ${MASTER_SITE_PYPI:=p/passlib/}

View File

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.9 2021/10/26 11:17:48 nia Exp $
$NetBSD: distinfo,v 1.10 2024/01/01 16:19:57 leot Exp $
BLAKE2s (passlib-1.7.4.tar.gz) = 7007ebe597e6b68cd7a180195629a5531b5a4f80374c00c1166561c030c45084
SHA512 (passlib-1.7.4.tar.gz) = 350bd6da5ac57e6c266ffe8bf9684c8c2cce3fc6b513eb6c7bc1b302d2d8a1b701e9c01c953782520a2ac37b7ec1f6d7bd5855f99f6ee0e2dbbf33f2d49a9530
Size (passlib-1.7.4.tar.gz) = 689844 bytes
SHA1 (patch-passlib_handlers_bcrypt.py) = f67386201a22d37dd502926a26d07741ded1daf1

View File

@ -0,0 +1,16 @@
$NetBSD: patch-passlib_handlers_bcrypt.py,v 1.1 2024/01/01 16:19:57 leot Exp $
Version is available under __version__, __about__ field no longer
exists.
--- passlib/handlers/bcrypt.py.orig 2024-01-01 16:12:38.252193463 +0000
+++ passlib/handlers/bcrypt.py
@@ -617,7 +617,7 @@ class _BcryptBackend(_BcryptCommon):
except ImportError: # pragma: no cover
return False
try:
- version = _bcrypt.__about__.__version__
+ version = _bcrypt.__version__
except:
log.warning("(trapped) error reading bcrypt version", exc_info=True)
version = '<unknown>'