Update AiCA package to 0.81.
- Changes are unknown. - License restriction is removed now. - Try to keep configuration to ${PREFIX}/etc/AiCA.
This commit is contained in:
parent
ccc2ab3869
commit
d96bda51d3
10 changed files with 161 additions and 20 deletions
8
security/AiCA/INSTALL
Normal file
8
security/AiCA/INSTALL
Normal file
|
@ -0,0 +1,8 @@
|
|||
#
|
||||
# $NetBSD
|
||||
|
||||
case ${STAGE} in
|
||||
POST-INSTALL)
|
||||
${PREFIX}/bin/aistore -new
|
||||
;;
|
||||
esac
|
|
@ -1,25 +1,55 @@
|
|||
# $NetBSD: Makefile,v 1.6 2004/11/27 00:26:04 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.7 2004/11/29 17:24:49 taca Exp $
|
||||
#
|
||||
|
||||
DISTNAME= AiCA-0.71.1
|
||||
DISTNAME= AiCA-0.81
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://mars.elcom.nitech.ac.jp/security/
|
||||
|
||||
MAINTAINER= tech-pkg-ja@jp.netbsd.org
|
||||
HOMEPAGE= http://mars.elcom.nitech.ac.jp/security/
|
||||
COMMENT= Manage Certification Authority,PKI viewer/converter/verification
|
||||
COMMENT= Manage Certification Authority and PKI utilities
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_BUILDLINK3= yes
|
||||
USE_BUILDLINK3= yes
|
||||
USE_PKGINSTALL= yes
|
||||
INSTALL_EXTRA_TMPL+= ${.CURDIR}/INSTALL
|
||||
GNU_CONFIGURE= yes
|
||||
WRKSRC= ${WRKDIR}/AiCA
|
||||
|
||||
RESTRICTED= "Source code redistribution is not permitted. consult okuno@mars.elcom.nitech.ac.jp."
|
||||
NO_SRC_ON_FTP= ${RESTRICTED}
|
||||
NO_SRC_ON_CDROM= ${RESTRICTED}
|
||||
CONFDIR= ${PREFIX}/etc/AiCA
|
||||
DOCDIR= ${PREFIX}/share/doc/AiCA
|
||||
EXAMPLESDIR= ${PREFIX}/share/examples/AiCA
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/AiCA
|
||||
${INSTALL_DATA} ${WRKSRC}/COPYRIGHT ${WRKSRC}/README.j \
|
||||
${WRKSRC}/README ${WRKSRC}/sample.list.csv \
|
||||
${PREFIX}/share/doc/AiCA
|
||||
CONF_FILES+= ${EXAMPLESDIR}/aica.cnf ${CONFDIR}/aica.cnf
|
||||
OWN_DIRS+= ${CONFDIR}/store ${MAKE_DIRS}
|
||||
|
||||
COMMANDS= aica/aica bin/aistore bin/asn1view bin/certconv \
|
||||
bin/certreq bin/certvfy bin/certview
|
||||
LIBRARIES= libaica.a libaicrypto.a libaissl.a
|
||||
DOCS= COPYRIGHT README README.j
|
||||
EXAMPLES= lib/aica.cnf sample.csv
|
||||
|
||||
do-install:
|
||||
.for f in ${LIBRARIES}
|
||||
${INSTALL_LIB} ${WRKSRC}/lib/$f ${PREFIX}/lib
|
||||
.endfor
|
||||
.for f in ${COMMANDS}
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/$f ${PREFIX}/bin
|
||||
.endfor
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/bin/newca.sh ${PREFIX}/bin
|
||||
${INSTALL_DATA} ${WRKSRC}/aicrypto/include/*.h ${PREFIX}/include
|
||||
${INSTALL_DATA} ${WRKSRC}/aiconfig.h ${PREFIX}/include
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/certs
|
||||
${CP} ${WRKSRC}/certs/* ${PREFIX}/certs
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/templates
|
||||
${CP} ${WRKSRC}/templates/* ${PREFIX}/templates
|
||||
${INSTALL_DATA_DIR} ${DOCDIR}
|
||||
.for f in ${DOCS}
|
||||
${INSTALL_DATA} ${WRKSRC}/$f ${DOCDIR}
|
||||
.endfor
|
||||
${INSTALL_DATA_DIR} ${EXAMPLESDIR}
|
||||
.for f in ${EXAMPLES}
|
||||
${INSTALL_DATA} ${WRKSRC}/$f ${EXAMPLESDIR}
|
||||
.endfor
|
||||
|
||||
.include "../../security/openssl/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2001/11/01 01:16:25 zuntum Exp $
|
||||
@comment $NetBSD: PLIST,v 1.2 2004/11/29 17:24:49 taca Exp $
|
||||
bin/aica
|
||||
bin/aistore
|
||||
bin/asn1view
|
||||
bin/certconv
|
||||
bin/certreq
|
||||
|
@ -11,6 +12,7 @@ certs/ailab.crl
|
|||
certs/democa.cer
|
||||
certs/democa.crl
|
||||
certs/verify.idx
|
||||
@dirrm certs
|
||||
include/aiconfig.h
|
||||
include/key_type.h
|
||||
include/large_num.h
|
||||
|
@ -18,7 +20,9 @@ include/large_prime.h
|
|||
include/md_global.h
|
||||
include/ok_asn1.h
|
||||
include/ok_base64.h
|
||||
include/ok_cmp.h
|
||||
include/ok_des.h
|
||||
include/ok_dsa.h
|
||||
include/ok_ecc.h
|
||||
include/ok_ecdsa.h
|
||||
include/ok_err.h
|
||||
|
@ -38,16 +42,31 @@ include/ok_rc4.h
|
|||
include/ok_rsa.h
|
||||
include/ok_sha1.h
|
||||
include/ok_ssl.h
|
||||
include/ok_store.h
|
||||
include/ok_tool.h
|
||||
include/ok_uconv.h
|
||||
include/ok_wincry.h
|
||||
include/ok_x509.h
|
||||
include/ok_x509ext.h
|
||||
lib/aica.cnf
|
||||
include/unicode11.h
|
||||
lib/libaica.a
|
||||
lib/libaicrypto.a
|
||||
lib/libaissl.a
|
||||
share/doc/AiCA/COPYRIGHT
|
||||
share/doc/AiCA/README
|
||||
share/doc/AiCA/README.j
|
||||
share/doc/AiCA/sample.list.csv
|
||||
@dirrm share/doc/AiCA
|
||||
@dirrm certs
|
||||
share/examples/AiCA/aica.cnf
|
||||
share/examples/AiCA/sample.csv
|
||||
@dirrm share/examples/AiCA
|
||||
templates/ARL Profile template.lpi
|
||||
templates/CRL Profile template.lpi
|
||||
templates/CRL-All Profile template.lpi
|
||||
templates/Cross Cert Profile template.cpi
|
||||
templates/Empty Profile template.cpi
|
||||
templates/IPSEC Profile template.cpi
|
||||
templates/SMIME user Profile template.cpi
|
||||
templates/SSL client Profile template.cpi
|
||||
templates/SSL server Profile template.cpi
|
||||
templates/Sub-CA Profile template.cpi
|
||||
@dirrm templates
|
||||
|
|
|
@ -1,4 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.2 2001/04/19 15:40:29 agc Exp $
|
||||
$NetBSD: distinfo,v 1.3 2004/11/29 17:24:49 taca Exp $
|
||||
|
||||
SHA1 (AiCA-0.71.1.tar.gz) = e38627414f9938975b710d008e9b376142ac1242
|
||||
Size (AiCA-0.71.1.tar.gz) = 488560 bytes
|
||||
SHA1 (AiCA-0.81.tar.gz) = aa74edda60b29f21cca17ff6b09b07509705db18
|
||||
Size (AiCA-0.81.tar.gz) = 703433 bytes
|
||||
SHA1 (patch-aa) = e05d26c1a8248ac757e5f98da2fcc643629bc440
|
||||
SHA1 (patch-ab) = 0a94ee9e5c434c34980f6f8798e689c647bc9cd5
|
||||
SHA1 (patch-ac) = 5b9d8ca4ceeb1319e72bc46b0b31e43def1bb9b1
|
||||
SHA1 (patch-ad) = 05985ad03ae87440ee45490d02e2d1ad3cde9be4
|
||||
SHA1 (patch-ae) = 0dde826a366e8dbaf664d83e517e6c4d9b7a9e77
|
||||
SHA1 (patch-af) = 36ce280f9c19f5fadd9675acfbd826a4fdfbb2f5
|
||||
|
|
13
security/AiCA/patches/patch-aa
Normal file
13
security/AiCA/patches/patch-aa
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.1 2004/11/29 17:24:49 taca Exp $
|
||||
|
||||
--- README.j.orig 2002-11-04 23:21:08.000000000 +0900
|
||||
+++ README.j
|
||||
@@ -96,7 +96,7 @@
|
||||
発行された証明書をディレクトリの中に、自分でコピーをして下さい。
|
||||
|
||||
2.3 aica.cnfの設定
|
||||
- AiCAをインストールすると、そのインストールディレクトリに libディレクトリ
|
||||
+ AiCAをインストールすると、PREFIX/etcディレクトリにAiCAディレクトリ
|
||||
が作成されます。この中に、AiCAの動作設定をする aica.cnf があります。
|
||||
|
||||
2.3.1 default CAの設定
|
13
security/AiCA/patches/patch-ab
Normal file
13
security/AiCA/patches/patch-ab
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ab,v 1.1 2004/11/29 17:24:49 taca Exp $
|
||||
|
||||
--- README.orig 2002-11-04 23:21:08.000000000 +0900
|
||||
+++ README
|
||||
@@ -103,7 +103,7 @@
|
||||
operations.
|
||||
|
||||
2.3 Settings of aica.cnf
|
||||
- After installation of the AiCA, "PREFIX/lib/aica.cnf" file will be
|
||||
+ After installation of the AiCA, "PREFIX/etc/AiCA/aica.cnf" file will be
|
||||
created for command configuration. ("PREFIX" means install directory)
|
||||
|
||||
2.3.1 Settings of "default CA"
|
13
security/AiCA/patches/patch-ac
Normal file
13
security/AiCA/patches/patch-ac
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ac,v 1.1 2004/11/29 17:24:49 taca Exp $
|
||||
|
||||
--- aica/Makefile.in.orig 2002-11-04 23:21:09.000000000 +0900
|
||||
+++ aica/Makefile.in
|
||||
@@ -13,7 +13,7 @@
|
||||
|
||||
CC= @CC@
|
||||
PREFIX= @prefix@
|
||||
-CFLAGS= -O2 -I../ -I../include -I../aicrypto/include -DAICONFIG=\"$(PREFIX)/lib/aica.cnf\" -DPREFIX=\"$(PREFIX)\"
|
||||
+CFLAGS= -O2 -I../ -I../include -I../aicrypto/include -DAICONFIG=\"$(PREFIX)/etc/AiCA/aica.cnf\" -DPREFIX=\"$(PREFIX)\"
|
||||
|
||||
|
||||
OBJ= aica.o aica_file.o aica_print.o aica_setext.o aica_pol.o \
|
13
security/AiCA/patches/patch-ad
Normal file
13
security/AiCA/patches/patch-ad
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ad,v 1.1 2004/11/29 17:24:49 taca Exp $
|
||||
|
||||
--- aicrypto/configure.orig 2002-11-04 23:21:10.000000000 +0900
|
||||
+++ aicrypto/configure
|
||||
@@ -633,7 +633,7 @@ EOF
|
||||
#define UC_LOCAL_JCODE 3
|
||||
EOF
|
||||
;;
|
||||
- freebsd*)
|
||||
+ freebsd*|netbsd*|openbsd*)
|
||||
cat >> confdefs.h <<\EOF
|
||||
#define __BSD__ 1
|
||||
EOF
|
13
security/AiCA/patches/patch-ae
Normal file
13
security/AiCA/patches/patch-ae
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ae,v 1.1 2004/11/29 17:24:49 taca Exp $
|
||||
|
||||
--- apps/Makefile.in.orig 2002-11-04 23:21:38.000000000 +0900
|
||||
+++ apps/Makefile.in
|
||||
@@ -13,7 +13,7 @@
|
||||
|
||||
CC= @CC@
|
||||
PREFIX= @prefix@
|
||||
-CFLAGS= -O2 -I../ -I../aicrypto/include -I../include -DAICONFIG=\"$(PREFIX)/lib/aica.cnf\" -DPREFIX=\"$(PREFIX)\"
|
||||
+CFLAGS= -O2 -I../ -I../aicrypto/include -I../include -DAICONFIG=\"$(PREFIX)/etc/AiCA/aica.cnf\" -DPREFIX=\"$(PREFIX)\"
|
||||
|
||||
|
||||
ASN1VW= asn1view.o p12.o
|
13
security/AiCA/patches/patch-af
Normal file
13
security/AiCA/patches/patch-af
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-af,v 1.1 2004/11/29 17:24:49 taca Exp $
|
||||
|
||||
--- lib/aica.cnf.in.orig 2002-11-04 23:21:40.000000000 +0900
|
||||
+++ lib/aica.cnf.in
|
||||
@@ -1,7 +1,7 @@
|
||||
# AiCA configure file.
|
||||
# default certificate store directory
|
||||
[general info]
|
||||
-store_dir =@prefix@/store
|
||||
+store_dir =@prefix@/etc/AiCA/store
|
||||
|
||||
[general info end]
|
||||
|
Loading…
Reference in a new issue