Import amtterm-1.2 as sysutils/amtterm.
Based on PR#44884 by YAMAMOTO Takeshi. Additionaly, some improvements by me. Active Management Technology (AMT) tools descriptions from man pages: amttool - remotely control Intel AMT managed machines. amtterm - Intel AMT serial-over-lan (sol) client. from amt-howto(7): What is AMT and why I should care? AMT stands for "Active Management Technology". It provides some remote management facilities. They are handled by the hardware and firmware, thus they work independant from the operation system. Means: It works before Linux bootet up to the point where it activated the network interface. It works even when your most recent test kernel deadlocked the machine. Which makes it quite useful for development machines ... Intel AMT is part of the vPro Platform. Recent intel-chipset based business machines should have it. My fairly new Intel SDV machine has it too.
This commit is contained in:
parent
1a1ee1adf2
commit
d9db54cf6a
7 changed files with 110 additions and 0 deletions
20
sysutils/amtterm/DESCR
Normal file
20
sysutils/amtterm/DESCR
Normal file
|
@ -0,0 +1,20 @@
|
|||
Active Management Technology (AMT) tools
|
||||
|
||||
descriptions from man pages:
|
||||
|
||||
amttool - remotely control Intel AMT managed machines.
|
||||
amtterm - Intel AMT serial-over-lan (sol) client.
|
||||
|
||||
from amt-howto(7):
|
||||
|
||||
What is AMT and why I should care?
|
||||
AMT stands for "Active Management Technology". It provides some remote
|
||||
management facilities. They are handled by the hardware and firmware,
|
||||
thus they work independant from the operation system. Means: It works
|
||||
before Linux bootet up to the point where it activated the network
|
||||
interface. It works even when your most recent test kernel deadlocked
|
||||
the machine. Which makes it quite useful for development machines ...
|
||||
|
||||
Intel AMT is part of the vPro Platform. Recent intel-chipset based
|
||||
business machines should have it. My fairly new Intel SDV machine has
|
||||
it too.
|
26
sysutils/amtterm/Makefile
Normal file
26
sysutils/amtterm/Makefile
Normal file
|
@ -0,0 +1,26 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2011/05/13 13:24:01 obache Exp $
|
||||
#
|
||||
|
||||
DISTNAME= amtterm-1.2
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= http://www.kraxel.org/releases/amtterm/
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= # empty
|
||||
COMMENT= Active Management Technology (AMT) tools
|
||||
LICENSE= gnu-gpl-v2
|
||||
|
||||
DEPENDS+= p5-SOAP-Lite-[0-9]*:../../net/p5-SOAP-Lite
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
USE_TOOLS+= gmake pkg-config perl:run
|
||||
|
||||
MAKE_FILE= GNUmakefile
|
||||
MAKE_FLAGS+= prefix=${PREFIX}
|
||||
|
||||
REPLACE_PERL+= amttool
|
||||
|
||||
.include "options.mk"
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
9
sysutils/amtterm/PLIST
Normal file
9
sysutils/amtterm/PLIST
Normal file
|
@ -0,0 +1,9 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2011/05/13 13:24:01 obache Exp $
|
||||
bin/amtterm
|
||||
${PLIST.gamt}bin/gamt
|
||||
bin/amttool
|
||||
man/man1/amtterm.1
|
||||
man/man1/amttool.1
|
||||
${PLIST.gamt}man/man1/gamt.1
|
||||
man/man7/amt-howto.7
|
||||
${PLIST.gamt}share/applications/gamt.desktop
|
7
sysutils/amtterm/distinfo
Normal file
7
sysutils/amtterm/distinfo
Normal file
|
@ -0,0 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2011/05/13 13:24:01 obache Exp $
|
||||
|
||||
SHA1 (amtterm-1.2.tar.gz) = 7459a2817cdd5886d6e2f208af28de5af3937b9d
|
||||
RMD160 (amtterm-1.2.tar.gz) = 1a37c6f857d5e12dbda4a005838c31c19738db7a
|
||||
Size (amtterm-1.2.tar.gz) = 37225 bytes
|
||||
SHA1 (patch-GNUmakefile) = f0ff91d80b01ea9d4b42ea752b786ce16a698c7d
|
||||
SHA1 (patch-mk_Variables.mk) = cb2d2fae3c0e650386308bd9290fa62c64a137f7
|
16
sysutils/amtterm/options.mk
Normal file
16
sysutils/amtterm/options.mk
Normal file
|
@ -0,0 +1,16 @@
|
|||
# $NetBSD: options.mk,v 1.1.1.1 2011/05/13 13:24:01 obache Exp $
|
||||
#
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.amtterm
|
||||
PKG_SUPPORTED_OPTIONS= amtterm-gamt
|
||||
|
||||
.include "../../mk/bsd.options.mk"
|
||||
|
||||
PLIST_VARS+= gamt
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mamtterm-gamt)
|
||||
.include "../../x11/gtk2/buildlink3.mk"
|
||||
.include "../../x11/vte/buildlink3.mk"
|
||||
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
|
||||
PLIST.gamt= yes
|
||||
.endif
|
17
sysutils/amtterm/patches/patch-GNUmakefile
Normal file
17
sysutils/amtterm/patches/patch-GNUmakefile
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-GNUmakefile,v 1.1.1.1 2011/05/13 13:24:01 obache Exp $
|
||||
|
||||
* not to install gamt related files if it is off.
|
||||
|
||||
--- GNUmakefile.orig 2008-10-30 09:59:57.000000000 +0000
|
||||
+++ GNUmakefile
|
||||
@@ -43,8 +43,10 @@ install: build
|
||||
$(INSTALL_DIR) $(bindir) $(appdir) $(mandir)/man1 $(mandir)/man7
|
||||
$(INSTALL_BINARY) $(TARGETS) $(bindir)
|
||||
$(INSTALL_SCRIPT) amttool $(bindir)
|
||||
+ifeq ($(HAVE_GTK)$(HAVE_VTE),yesyes)
|
||||
$(INSTALL_DATA) $(DESKTOP) $(appdir)
|
||||
$(INSTALL_DATA) gamt.man $(mandir)/man1/gamt.1
|
||||
+endif
|
||||
$(INSTALL_DATA) amtterm.man $(mandir)/man1/amtterm.1
|
||||
$(INSTALL_DATA) amttool.man $(mandir)/man1/amttool.1
|
||||
$(INSTALL_DATA) amt-howto.man $(mandir)/man7/amt-howto.7
|
15
sysutils/amtterm/patches/patch-mk_Variables.mk
Normal file
15
sysutils/amtterm/patches/patch-mk_Variables.mk
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-mk_Variables.mk,v 1.1.1.1 2011/05/13 13:24:01 obache Exp $
|
||||
|
||||
* honor PKGMANDIR
|
||||
|
||||
--- mk/Variables.mk.orig 2008-10-30 09:29:19.000000000 +0000
|
||||
+++ mk/Variables.mk
|
||||
@@ -9,7 +9,7 @@ bindir = $(DESTDIR)$(prefix)/bin
|
||||
sbindir = $(DESTDIR)$(prefix)/sbin
|
||||
libdir = $(DESTDIR)$(prefix)/$(LIB)
|
||||
shrdir = $(DESTDIR)$(prefix)/share
|
||||
-mandir = $(shrdir)/man
|
||||
+mandir = $(DESTDIR)$(prefix)/${PKGMANDIR}
|
||||
locdir = $(shrdir)/locale
|
||||
appdir = $(shrdir)/applications
|
||||
|
Loading…
Reference in a new issue