Update to 1.9.17 and drop maintainership (never used it, really).

1.9.17
	bug fix, when saving hnb DTD, I also saved the text attribute
	removed the format names from prefs.c,.. now the string specified is
	used instead, (makes extending easier)
	improved the tokenizer for libcli, it now acts almost exactly as bash,
	even the hooks for understanding $variable_expansion is included in the
	code, uses a single malloc
	various bug fixes
	cleanups and merging of commands, e.g. go_root, go_recurse, and
	go_backrecurse are now go <root|backrecurse|recurse|up|down|left|right>
	search now is a single command taking direction and query as arguments.
	changed escape to be the key used to bring up the menu,.. and remapped
	^Q to be quit (again)
1.9.16
	attempts to fix the compile on OSX
		renaming mergesort to node_mergesort due to nameclash
		only compiling the static lib
	made indent and outdent only work when there is no data typed already,
	(thus making > and < allowed typed in navigation mode as long as
	they're not the first character typed.
	removed errors appearing with -pedantic (at least here)
	removing all macros with variable arguments replacing them with va_list
		removing inline statements from libcli
	created an utility function for string replacements, that I inserted
	into all the various import/export filters.
	added a function "insert_cal <month> <year>" which inserts the
	specified month/year in a fashion that makes hnb useable as a simple
	timeplanner as well. (when I get around to adding support for clones,
	this might be interesting)
	allowing the user to use <,>,+ and - when typing in new data without
	erratic behavior, and not the need to enter edit mode. (except if it is
	the first char of the data)
	fixed an issue with creating the first child, and pressing insert, and
	various other commands,..
	added rpm spec file from Asgeir Nilsen
	made file_opml and file_hnb interpret all attributes
	implemented buffered reading for the xml tokenizer
	changed the function prototype for functions that register with libcli,
	they must now register with an int (int argc, char **argv, void *data)
	function
		overhauled hnb to use this API, some more refinement might be
		needed in someplaces, but it seems to work OK for now.
	added a menu that is accesed from F9
1.9.15
	outdent fixed to be more efficient and work as intended
	added export context
	changed all import/export functions to use the query variable if
	filename passed is *
1.9.14
	bugfix: The new sort and shuffle functions could result in dataloss
	when saved.
	new feature: expand/collapse and expand_all/collapse_all are new
	bindable functions, expand/collapse is bound to +/- in the default
	config file, they force portions of the tree to stay open even when you
	leave it.
1.9.13
	Apparently I broke the nasty quick-sort I had implemented, when I
	changed the way the tree was stored. Implemented a Merge-sort which is
	faster anyways.
	Improved the behavior of non fixed navigation when the whole tree is
	displayed.
	Added a shuffle function (not currently bound), I used it while
	developing the new mergesort, but someone might find it useful.
1.9.12
	Changed the datastructure to use a "assosciation list" for storing the
	actual data. Will move all tags, like checkbox to this structure.
		Should actually make it possible to do the addition of start
		end date and other "columns" a breeze, perhaps even automatic
		for some export/import formats
	modified tree_duplicate to use the new node_duplicate function, and a
	modified version of the import_node which takes a single node with data
	set as input.
	added import_node_text which disregards all other data items
1.9.11
	changed node_swap to only swap relational pointers, thus making it
	easier to extend the data stored in Node later
		thus also changing and move node, indent/out-dent and sort to
		accommodate for a truer swap
	fixed a bug with editing of newly introduced child
		note: should perhaps move ui_action_edit into a built-in
		command that is handled specially since it now needs special
		attention by being a subcommand to ui_action_command
1.9.4-1.9.10 feb 2003
	re-implementation of positioning of selection bar in non fixed mode
	massive code cleanup and separation
	separation of variables from prefs.* to static variables in the code
	modules where they belonged
	integration with spell checker (Ispell, but through prefs it could
	easily be made Aspell instead)
	new preferences format
	ability to execute commands and running mail-client / web-browser if a
	node or it's children contain url's / mail addresses
	OPML import and export
	postscript export
	htmlcss export
	save_state and restore_state for single level undo where needed
	new XML tokenizer
	cut/paste functionality
1.9.3 jan 2003
	stabilising of the code
	ability to use default terminal colours, (patch from NN)
1.9.1 oct 2002
	option to remember current position in hnb file when saving/loading
	cleaned up most of the help-system code
	further code separation
1.9.0 oct 2002
	fixed the movement behaviour when going to the parent node,.. the
	screen jumped too much
	separated the various export and load filters into own files
	used my new libcli for the cli code, and as "glue" in some code spots
	reverted to a manual makefile instead of autoconf/automake
	improvements to dynamic key-bindings, multiple key-bindings for each
	action, all key-bindings in various context got their own choice in the
	preferences.
	The first of the actual key-bindings shown as help
	added some more bindings for the node editor, (skip word and bskip
	word, hooks for even more)
This commit is contained in:
jmmv 2004-12-05 08:28:45 +00:00
parent a779f7204c
commit d9e0a998a2
4 changed files with 17 additions and 78 deletions

View file

@ -1,21 +1,27 @@
# $NetBSD: Makefile,v 1.13 2004/10/03 00:14:38 tv Exp $
# $NetBSD: Makefile,v 1.14 2004/12/05 08:28:45 jmmv Exp $
#
DISTNAME= hnb-1.8.1
PKGREVISION= 5
DISTNAME= hnb-1.9.17
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=hnb/}
MAINTAINER= jmmv@NetBSD.org
MAINTAINER= tech-pkg@NetBSD.org
HOMEPAGE= http://hnb.sourceforge.net/
COMMENT= Hierarchical data organizer
INCOMPAT_CURSES= NetBSD-1.5* NetBSD-1.6[-_.]* NetBSD-1.6[A-U]-*
GNU_CONFIGURE= yes
USE_BUILDLINK3= yes
USE_GNU_TOOLS+= make
USE_BUILDLINK3= yes
USE_GNU_TOOLS+= make
BUILD_DIRS= ${WRKSRC}/src
BUILD_TARGET= hnb
INSTALLATION_DIRS= bin man/man1
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/hnb ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/doc/hnb.1 ${PREFIX}/man/man1
.include "../../devel/ncurses/buildlink3.mk"
.include "../../textproc/libxml2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2002/11/29 20:17:24 jmmv Exp $
$NetBSD: distinfo,v 1.2 2004/12/05 08:28:45 jmmv Exp $
SHA1 (hnb-1.8.1.tar.gz) = 4232b30e213f15ee67c5bfcfe7018161d37e3d12
Size (hnb-1.8.1.tar.gz) = 109899 bytes
SHA1 (hnb-1.9.17.tar.gz) = b5204a9bda13b42ef04921e71f52e5bfe5412f13
Size (hnb-1.9.17.tar.gz) = 143700 bytes
SHA1 (patch-aa) = 4d31ebd576721b634b0fed30b1cb391843958045
SHA1 (patch-ab) = 989ddf14f27de4ea8db2905679ec301ad94e09b6

View file

@ -1,15 +0,0 @@
$NetBSD: patch-aa,v 1.1.1.1 2002/11/29 20:17:25 jmmv Exp $
--- configure.in.orig Sun Sep 8 15:41:48 2002
+++ configure.in Sun Sep 8 15:41:58 2002
@@ -6,8 +6,8 @@
AC_PROG_INSTALL
dnl Checks for libraries.
-dnl Replace `main' with a function in -lcurses:
-AC_CHECK_LIB(curses, move)
+dnl Replace `main' with a function in -lncurses:
+AC_CHECK_LIB(ncurses, move)
AC_HAVE_LIBRARY(xml2)

View file

@ -1,52 +0,0 @@
$NetBSD: patch-ab,v 1.1.1.1 2002/11/29 20:17:25 jmmv Exp $
--- configure.orig Sun Sep 8 15:42:06 2002
+++ configure Sun Sep 8 15:42:32 2002
@@ -1925,13 +1925,13 @@
test -z "$INSTALL_DATA" && INSTALL_DATA='${INSTALL} -m 644'
-echo "$as_me:1928: checking for move in -lcurses" >&5
-echo $ECHO_N "checking for move in -lcurses... $ECHO_C" >&6
-if test "${ac_cv_lib_curses_move+set}" = set; then
+echo "$as_me:1928: checking for move in -lncurses" >&5
+echo $ECHO_N "checking for move in -lncurses... $ECHO_C" >&6
+if test "${ac_cv_lib_ncurses_move+set}" = set; then
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_check_lib_save_LIBS=$LIBS
-LIBS="-lcurses $LIBS"
+LIBS="-lncurses $LIBS"
cat >conftest.$ac_ext <<_ACEOF
#line 1936 "configure"
#include "confdefs.h"
@@ -1963,23 +1963,23 @@
ac_status=$?
echo "$as_me:1964: \$? = $ac_status" >&5
(exit $ac_status); }; }; then
- ac_cv_lib_curses_move=yes
+ ac_cv_lib_ncurses_move=yes
else
echo "$as_me: failed program was:" >&5
cat conftest.$ac_ext >&5
-ac_cv_lib_curses_move=no
+ac_cv_lib_ncurses_move=no
fi
rm -f conftest.$ac_objext conftest$ac_exeext conftest.$ac_ext
LIBS=$ac_check_lib_save_LIBS
fi
-echo "$as_me:1975: result: $ac_cv_lib_curses_move" >&5
-echo "${ECHO_T}$ac_cv_lib_curses_move" >&6
-if test $ac_cv_lib_curses_move = yes; then
+echo "$as_me:1975: result: $ac_cv_lib_ncurses_move" >&5
+echo "${ECHO_T}$ac_cv_lib_ncurses_move" >&6
+if test $ac_cv_lib_ncurses_move = yes; then
cat >>confdefs.h <<EOF
#define HAVE_LIBCURSES 1
EOF
- LIBS="-lcurses $LIBS"
+ LIBS="-lncurses $LIBS"
fi