fix grammar to make bison happy

This commit is contained in:
tnn 2009-11-23 15:30:29 +00:00
parent 3366facca7
commit da10d0fd8f
2 changed files with 19 additions and 1 deletions

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.22 2009/11/22 21:19:19 tnn Exp $
$NetBSD: distinfo,v 1.23 2009/11/23 15:30:29 tnn Exp $
SHA1 (f2c-20090411.tar.gz) = 949e832b84aaa912a99471a95c6fd449898d50e0
RMD160 (f2c-20090411.tar.gz) = e86ff3de4564267a57f508a5a68e81af2b1a9468
Size (f2c-20090411.tar.gz) = 1045385 bytes
SHA1 (patch-aa) = f1224ff17cdc96f083a247dce88b690e8b939eb0
SHA1 (patch-ad) = 7f204a45891e3632589ea8fb0e4e379a0a792dea
SHA1 (patch-ai) = d8c1f731c18394e0953b6128d0bd597986ab910f

17
lang/f2c/patches/patch-aa Normal file
View file

@ -0,0 +1,17 @@
$NetBSD: patch-aa,v 1.20 2009/11/23 15:30:29 tnn Exp $
--- src/gram.expr.orig 2003-02-11 13:53:48.000000000 +0100
+++ src/gram.expr
@@ -99,9 +99,9 @@ simple: name
simple_const: STRUE { $$ = mklogcon(1); }
| SFALSE { $$ = mklogcon(0); }
| SHOLLERITH { $$ = mkstrcon(toklen, token); }
- | SICON = { $$ = mkintqcon(toklen, token); }
- | SRCON = { $$ = mkrealcon(tyreal, token); }
- | SDCON = { $$ = mkrealcon(TYDREAL, token); }
+ | SICON { $$ = mkintqcon(toklen, token); }
+ | SRCON { $$ = mkrealcon(tyreal, token); }
+ | SDCON { $$ = mkrealcon(TYDREAL, token); }
| bit_const
;