Correctly fix the ctype usage. Don't overwrite our CFLAGS.
Bump revision.
This commit is contained in:
parent
b9bc982628
commit
da1c4fc539
6 changed files with 31 additions and 12 deletions
|
@ -1,7 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.11 2013/08/01 20:19:55 shattered Exp $
|
||||
# $NetBSD: Makefile,v 1.12 2013/08/30 16:53:45 joerg Exp $
|
||||
#
|
||||
|
||||
DISTNAME= ripmime-1.4.0.10
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= http://www.pldaniels.com/ripmime/
|
||||
|
||||
|
@ -14,6 +15,11 @@ MAKE_ENV+= LIBS=${BUILDLINK_LDADD.iconv}
|
|||
|
||||
INSTALLATION_DIRS= bin ${PKGMANDIR}/man1
|
||||
|
||||
.include "../../mk/compiler.mk"
|
||||
.if !empty(PKGSRC_COMPILER:Mclang)
|
||||
CFLAGS+= -Wno-error=tautological-compare
|
||||
.endif
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/ripmime ${DESTDIR}${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/ripmime.1 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1
|
||||
|
|
|
@ -1,8 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.6 2013/08/01 20:19:55 shattered Exp $
|
||||
$NetBSD: distinfo,v 1.7 2013/08/30 16:53:45 joerg Exp $
|
||||
|
||||
SHA1 (ripmime-1.4.0.10.tar.gz) = 296f657f2f664b713751178fb589d5c64dc7b6ae
|
||||
RMD160 (ripmime-1.4.0.10.tar.gz) = 312f6ca37e73a5a024dd8cf07e6b969b6d7a952d
|
||||
Size (ripmime-1.4.0.10.tar.gz) = 174610 bytes
|
||||
SHA1 (patch-aa) = 9fc681acd369555f17027a6ea1e84566e36b18c1
|
||||
SHA1 (patch-ab) = 08d4cb2519f4f0dd062ca717185b597e4edd09f9
|
||||
SHA1 (patch-ac) = 188092463ece3302806952fec1efc06000391e36
|
||||
SHA1 (patch-aa) = b2e0bbabbf58307458c830cbd816685c14565546
|
||||
SHA1 (patch-ab) = cde9aed0e6df4540b4e563953a77fae69944facc
|
||||
SHA1 (patch-ac) = 71fe6aaaf08c2b2c79f5d554be8a37fd26cdf796
|
||||
SHA1 (patch-ripOLE_Makefile) = 50af6c9f8ee0a93efdfe03ef6fc2bc7b5c9f03f8
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-aa,v 1.5 2013/08/01 20:19:55 shattered Exp $
|
||||
$NetBSD: patch-aa,v 1.6 2013/08/30 16:53:45 joerg Exp $
|
||||
|
||||
--- Makefile.orig 2011-12-05 08:46:23.000000000 +0000
|
||||
+++ Makefile
|
||||
|
@ -7,7 +7,7 @@ $NetBSD: patch-aa,v 1.5 2013/08/01 20:19:55 shattered Exp $
|
|||
#CFLAGS ?= -Wall -g -O2 -Werror $(CPU_OPTS)
|
||||
#CFLAGS=-Wall -g -O2 -Wundef -Wshadow -Wsign-compare -I.
|
||||
-CFLAGS=-Wall -g -I. -O2 -Werror
|
||||
+CFLAGS?=-Wall -g -I. -O2 -Werror
|
||||
+#CFLAGS=-Wall -g -I. -O2 -Werror
|
||||
|
||||
# OLE decoding is still considered to be 'beta' mode - so it
|
||||
# disabled in the stable release of ripMIME for now
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-ab,v 1.1 2013/07/21 10:58:49 shattered Exp $
|
||||
$NetBSD: patch-ab,v 1.2 2013/08/30 16:53:45 joerg Exp $
|
||||
|
||||
Avoid compiler warning.
|
||||
|
||||
|
@ -9,7 +9,7 @@ Avoid compiler warning.
|
|||
for (j = current_byte -31; j <=current_byte; j++)
|
||||
{
|
||||
- if (isalnum(*(sector +j))) printf("%c",*(sector+j));
|
||||
+ if (isalnum((int)*(sector +j))) printf("%c",*(sector+j));
|
||||
+ if (isalnum((unsigned char)*(sector +j))) printf("%c",*(sector+j));
|
||||
else printf(".");
|
||||
}
|
||||
printf("\n");
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-ac,v 1.1 2013/07/21 10:58:49 shattered Exp $
|
||||
$NetBSD: patch-ac,v 1.2 2013/08/30 16:53:45 joerg Exp $
|
||||
|
||||
Avoid compiler warning.
|
||||
|
||||
|
@ -10,8 +10,8 @@ Avoid compiler warning.
|
|||
{
|
||||
- c1 = tolower(*ds1);
|
||||
- c2 = tolower(*ds2);
|
||||
+ c1 = tolower((int)*ds1);
|
||||
+ c2 = tolower((int)*ds2);
|
||||
+ c1 = tolower((unsigned char)*ds1);
|
||||
+ c2 = tolower((unsigned char)*ds2);
|
||||
|
||||
if (c1 == c2)
|
||||
{
|
||||
|
|
12
mail/ripmime/patches/patch-ripOLE_Makefile
Normal file
12
mail/ripmime/patches/patch-ripOLE_Makefile
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-ripOLE_Makefile,v 1.1 2013/08/30 16:53:45 joerg Exp $
|
||||
|
||||
--- ripOLE/Makefile.orig 2013-08-30 14:11:54.000000000 +0000
|
||||
+++ ripOLE/Makefile
|
||||
@@ -1,6 +1,6 @@
|
||||
|
||||
OBJS= ole.o olestream-unwrap.o bytedecoders.o logger.o pldstr.o bt-int.o
|
||||
-CFLAGS=-Wall -g -O2 -I. -Werror
|
||||
+#CFLAGS=-Wall -g -O2 -I. -Werror
|
||||
|
||||
|
||||
.c.o:
|
Loading…
Reference in a new issue