Changes 4.4.2:
* FIX color specification "lc N" * FIX clipping error in filled curves * FIX segfault if "refresh" command follows an interrupted replot Changes 4.4.1: * NEW Support the "%s" format specifier in strftime() * NEW Optional 6th data column in candlesticks style to specific box width * NEW If integer arithmetic i*j or i**j would overflow, return value as a real * NEW "set style circle radius <default-radius>" * FIX autoconfiguration of readline support in OSX * FIX font problems in win terminal * FIX Protect against runaway recursion by limiting depth of nested functions * FIX metapost terminal: Fix inheritance of line thickness by text strings * FIX cairo terminals could segfault on certain enhanced text strings * FIX pdfcairo output to stdout now works * FIX font ",size" in non-enhanced mode postscript terminals * FIX Do a better job of estimating the width of UTF-8 encoded strings * FIX baseline bug in canvas terminal rotation of enhanced text * FIX Allow "with labels" to work for binary input data * FIX update user GPVAL variables after plot in table mode * CHANGE depth-sorting of pm3d surfaces now applies jointly to all in the plot * CHANGE 3D impulses are now always drawn from z=0 * CHANGE Enable HIDDEN_QUADTREE by default * CHANGE Enable "set fit errorvariables" by default * CHANGE Regardless of current timefmt, read time from binary files as a binary * CHANGE do not limit 3D rotation to 0<rotx<180
This commit is contained in:
parent
eb008a17f7
commit
da69bfdd48
10 changed files with 164 additions and 127 deletions
|
@ -1,13 +1,51 @@
|
||||||
# $NetBSD: Makefile,v 1.52 2011/01/13 13:38:05 wiz Exp $
|
# $NetBSD: Makefile,v 1.53 2011/02/08 13:13:41 adam Exp $
|
||||||
|
|
||||||
CATEGORIES+= x11
|
DISTNAME= gnuplot-4.4.2
|
||||||
PKGREVISION= 4
|
CATEGORIES+= graphics
|
||||||
|
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=gnuplot/}
|
||||||
|
|
||||||
|
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||||
|
HOMEPAGE= http://gnuplot.sourceforge.net/
|
||||||
|
COMMENT= Portable interactive, function plotting utility
|
||||||
|
|
||||||
CONFLICTS+= gnuplot-nox11-[0-9]*
|
CONFLICTS+= gnuplot-nox11-[0-9]*
|
||||||
|
|
||||||
.include "../../graphics/gnuplot/Makefile.common"
|
PATCHDIR= ${.CURDIR}/../../graphics/gnuplot/patches
|
||||||
.include "../../graphics/gnuplot/options.mk"
|
DISTINFO_FILE= ${.CURDIR}/../../graphics/gnuplot/distinfo
|
||||||
|
|
||||||
|
PKG_INSTALLATION_TYPES= overwrite pkgviews
|
||||||
|
PKG_DESTDIR_SUPPORT= user-destdir
|
||||||
|
|
||||||
|
USE_TOOLS+= makeinfo pkg-config
|
||||||
|
GNU_CONFIGURE= yes
|
||||||
|
#CONFIGURE_ARGS+= --enable-history-file
|
||||||
|
CONFIGURE_ARGS+= --with-plot=${PREFIX}
|
||||||
|
CONFIGURE_ARGS+= --without-latex
|
||||||
|
CONFIGURE_ARGS+= --without-lisp-files
|
||||||
|
CONFIGURE_ARGS+= --without-tutorial
|
||||||
|
INFO_FILES= yes
|
||||||
|
|
||||||
|
# Use BSD editline wherever possible:
|
||||||
|
.include "../../mk/bsd.prefs.mk"
|
||||||
|
|
||||||
|
.if !empty(OPSYS:M*BSD) || ${OPSYS} == "DragonFly" || ${OPSYS} == "Darwin"
|
||||||
|
CONFIGURE_ARGS+= --with-readline=bsd
|
||||||
|
.include "../../mk/curses.buildlink3.mk"
|
||||||
|
.else
|
||||||
|
CONFIGURE_ARGS+= --with-readline=${BUILDLINK_PREFIX.readline}
|
||||||
|
.include "../../devel/readline/buildlink3.mk"
|
||||||
|
.endif
|
||||||
|
|
||||||
|
# Make this available to patch-ah so the font path can include pkgsrc fonts.
|
||||||
|
SUBST_CLASSES+= fontpath
|
||||||
|
SUBST_STAGE.fontpath= pre-configure
|
||||||
|
SUBST_MESSAGE.fontpath= Fixing font path.
|
||||||
|
SUBST_FILES.fontpath= src/variable.c
|
||||||
|
SUBST_SED.fontpath= -e 's,@PKGSRC_PREFIX@,"${PREFIX}",'
|
||||||
|
|
||||||
|
.include "options.mk"
|
||||||
|
|
||||||
|
.include "../../devel/pango/buildlink3.mk"
|
||||||
|
.include "../../graphics/cairo/buildlink3.mk"
|
||||||
.include "../../graphics/plotutils/buildlink3.mk"
|
.include "../../graphics/plotutils/buildlink3.mk"
|
||||||
.include "../../x11/libXaw/buildlink3.mk"
|
|
||||||
.include "../../mk/bsd.pkg.mk"
|
.include "../../mk/bsd.pkg.mk"
|
||||||
|
|
|
@ -1,41 +0,0 @@
|
||||||
# $NetBSD: Makefile.common,v 1.21 2011/01/06 07:03:55 dholland Exp $
|
|
||||||
# used by graphics/gnuplot/Makefile
|
|
||||||
# used by graphics/gnuplot-nox11/Makefile
|
|
||||||
|
|
||||||
DISTNAME= gnuplot-4.2.6
|
|
||||||
CATEGORIES+= graphics
|
|
||||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=gnuplot/}
|
|
||||||
|
|
||||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
|
||||||
HOMEPAGE= http://gnuplot.sourceforge.net/
|
|
||||||
COMMENT= Portable interactive, function plotting utility
|
|
||||||
|
|
||||||
PATCHDIR= ${.CURDIR}/../../graphics/gnuplot/patches
|
|
||||||
DISTINFO_FILE= ${.CURDIR}/../../graphics/gnuplot/distinfo
|
|
||||||
|
|
||||||
PKG_INSTALLATION_TYPES= overwrite pkgviews
|
|
||||||
PKG_DESTDIR_SUPPORT= user-destdir
|
|
||||||
|
|
||||||
GNU_CONFIGURE= YES
|
|
||||||
|
|
||||||
USE_TOOLS+= makeinfo
|
|
||||||
INFO_FILES= # PLIST
|
|
||||||
|
|
||||||
CONFIGURE_ARGS+= --enable-history-file
|
|
||||||
CONFIGURE_ARGS+= --with-plot=${PREFIX:Q}
|
|
||||||
CONFIGURE_ARGS+= --without-lisp-files
|
|
||||||
CONFIGURE_ARGS+= --without-tutorial
|
|
||||||
|
|
||||||
# Use BSD editline wherever possible:
|
|
||||||
.include "../../mk/bsd.prefs.mk"
|
|
||||||
|
|
||||||
.if !empty(OPSYS:M*BSD) || ${OPSYS} == "DragonFly" || ${OPSYS} == "Darwin"
|
|
||||||
CONFIGURE_ARGS+= --with-readline=bsd
|
|
||||||
.include "../../mk/curses.buildlink3.mk"
|
|
||||||
.else
|
|
||||||
CONFIGURE_ARGS+= --with-readline=${BUILDLINK_PREFIX.readline}
|
|
||||||
.include "../../devel/readline/buildlink3.mk"
|
|
||||||
.endif
|
|
||||||
|
|
||||||
# Make this available to patch-ah so the font path can include pkgsrc fonts.
|
|
||||||
CFLAGS+=-DPKGSRC_PREFIX=\"${PREFIX}\"
|
|
|
@ -1,17 +1,32 @@
|
||||||
@comment $NetBSD: PLIST,v 1.12 2009/06/14 17:59:15 joerg Exp $
|
@comment $NetBSD: PLIST,v 1.13 2011/02/08 13:13:41 adam Exp $
|
||||||
bin/gnuplot
|
bin/gnuplot
|
||||||
info/gnuplot.info
|
info/gnuplot.info
|
||||||
lib/X11/app-defaults/Gnuplot
|
${PLIST.x11}libexec/gnuplot/4.4/gnuplot_x11
|
||||||
libexec/gnuplot/4.2/gnuplot_x11
|
|
||||||
man/man1/gnuplot.1
|
man/man1/gnuplot.1
|
||||||
share/gnuplot/4.2/PostScript/8859-1.ps
|
share/gnuplot/4.4/PostScript/8859-1.ps
|
||||||
share/gnuplot/4.2/PostScript/8859-15.ps
|
share/gnuplot/4.4/PostScript/8859-15.ps
|
||||||
share/gnuplot/4.2/PostScript/8859-2.ps
|
share/gnuplot/4.4/PostScript/8859-2.ps
|
||||||
share/gnuplot/4.2/PostScript/cp1250.ps
|
share/gnuplot/4.4/PostScript/8859-9.ps
|
||||||
share/gnuplot/4.2/PostScript/cp437.ps
|
share/gnuplot/4.4/PostScript/aglfn.txt
|
||||||
share/gnuplot/4.2/PostScript/cp850.ps
|
share/gnuplot/4.4/PostScript/cp1250.ps
|
||||||
share/gnuplot/4.2/PostScript/cp852.ps
|
share/gnuplot/4.4/PostScript/cp437.ps
|
||||||
share/gnuplot/4.2/PostScript/koi8r.ps
|
share/gnuplot/4.4/PostScript/cp850.ps
|
||||||
share/gnuplot/4.2/PostScript/koi8u.ps
|
share/gnuplot/4.4/PostScript/cp852.ps
|
||||||
share/gnuplot/4.2/PostScript/prologue.ps
|
share/gnuplot/4.4/PostScript/koi8r.ps
|
||||||
share/gnuplot/4.2/gnuplot.gih
|
share/gnuplot/4.4/PostScript/koi8u.ps
|
||||||
|
share/gnuplot/4.4/PostScript/prologue.ps
|
||||||
|
share/gnuplot/4.4/PostScript/utf-8.ps
|
||||||
|
${PLIST.x11}share/gnuplot/4.4/app-defaults/Gnuplot
|
||||||
|
share/gnuplot/4.4/gnuplot.gih
|
||||||
|
share/gnuplot/4.4/js/README
|
||||||
|
share/gnuplot/4.4/js/canvasmath.js
|
||||||
|
share/gnuplot/4.4/js/canvastext.js
|
||||||
|
share/gnuplot/4.4/js/gnuplot_common.js
|
||||||
|
share/gnuplot/4.4/js/gnuplot_mouse.css
|
||||||
|
share/gnuplot/4.4/js/gnuplot_mouse.js
|
||||||
|
share/gnuplot/4.4/js/grid.png
|
||||||
|
share/gnuplot/4.4/js/help.png
|
||||||
|
share/gnuplot/4.4/js/nextzoom.png
|
||||||
|
share/gnuplot/4.4/js/previouszoom.png
|
||||||
|
share/gnuplot/4.4/js/textzoom.png
|
||||||
|
share/gnuplot/4.4/lua/gnuplot-tikz.lua
|
||||||
|
|
|
@ -1,13 +1,12 @@
|
||||||
$NetBSD: distinfo,v 1.15 2011/01/06 07:03:55 dholland Exp $
|
$NetBSD: distinfo,v 1.16 2011/02/08 13:13:41 adam Exp $
|
||||||
|
|
||||||
SHA1 (gnuplot-4.2.6.tar.gz) = d11fdde8218bee98597ee836cbc17e4bf6093b70
|
SHA1 (gnuplot-4.4.2.tar.gz) = 35666be22e877ade5e272199d3d81555c141cef5
|
||||||
RMD160 (gnuplot-4.2.6.tar.gz) = 3b1726e5327b17bb7b528198e62a12b9fe3e5a76
|
RMD160 (gnuplot-4.4.2.tar.gz) = 077d6d353e0370d1f8463693380030722f5789af
|
||||||
Size (gnuplot-4.2.6.tar.gz) = 2936753 bytes
|
Size (gnuplot-4.4.2.tar.gz) = 3299690 bytes
|
||||||
SHA1 (patch-aa) = a6f67cc9ef3dc1cac2dc5bd9d0ecc634b9b70a92
|
SHA1 (patch-aa) = a6f67cc9ef3dc1cac2dc5bd9d0ecc634b9b70a92
|
||||||
SHA1 (patch-ab) = f64716b79fbdab9b85fb7df89c9c24a6db313d26
|
|
||||||
SHA1 (patch-ac) = 36bbe7654e581d7323dfe2a0c358c0f99aae2c6f
|
SHA1 (patch-ac) = 36bbe7654e581d7323dfe2a0c358c0f99aae2c6f
|
||||||
SHA1 (patch-ad) = 5165374c6e8275f2f030659daa45051851e98413
|
SHA1 (patch-ad) = 5165374c6e8275f2f030659daa45051851e98413
|
||||||
SHA1 (patch-ae) = 622630495587a963fe713ca18d871b5b51aafadc
|
SHA1 (patch-ae) = ce2a89ebcdcae1b1945563b48e6ebb6974d3a048
|
||||||
SHA1 (patch-af) = 02a661965a9af633f9a4dc6ef74f8ad312610362
|
SHA1 (patch-af) = b6c7dafd61efcee89cc1323202bf76df7ee20936
|
||||||
SHA1 (patch-ag) = 22354c38ac2a8a85c804c269bbfa8da03ae55708
|
SHA1 (patch-ag) = 8c1f4a4a94cf136d94b0019954453553c17be7b2
|
||||||
SHA1 (patch-ah) = 43303314778c4e921e9f9457c34e564acfcd1e69
|
SHA1 (patch-ah) = e4024ebbc039d7b5e741aa109259de6269b03765
|
||||||
|
|
|
@ -1,16 +1,25 @@
|
||||||
# $NetBSD: options.mk,v 1.1 2010/02/19 14:09:58 asau Exp $
|
# $NetBSD: options.mk,v 1.2 2011/02/08 13:13:41 adam Exp $
|
||||||
|
|
||||||
PKG_OPTIONS_VAR= PKG_OPTIONS.gnuplot
|
PKG_OPTIONS_VAR= PKG_OPTIONS.gnuplot
|
||||||
PKG_SUPPORTED_OPTIONS= gd pdf
|
PKG_SUPPORTED_OPTIONS= gd pdf x11
|
||||||
PKG_SUGGESTED_OPTIONS= gd pdf
|
PKG_SUGGESTED_OPTIONS= gd pdf x11
|
||||||
|
|
||||||
.include "../../mk/bsd.options.mk"
|
.include "../../mk/bsd.options.mk"
|
||||||
|
|
||||||
.if !empty(PKG_OPTIONS:Mpdf)
|
PLIST_VARS+= x11
|
||||||
CONFIGURE_ARGS+= --with-pdf
|
|
||||||
.include "../../print/pdflib/buildlink3.mk"
|
|
||||||
.endif
|
|
||||||
|
|
||||||
.if !empty(PKG_OPTIONS:Mgd)
|
.if !empty(PKG_OPTIONS:Mgd)
|
||||||
.include "../../graphics/gd/buildlink3.mk"
|
.include "../../graphics/gd/buildlink3.mk"
|
||||||
.endif
|
.endif
|
||||||
|
|
||||||
|
.if !empty(PKG_OPTIONS:Mpdf)
|
||||||
|
CONFIGURE_ARGS+= --with-pdf
|
||||||
|
.include "../../print/pdflib-lite/buildlink3.mk"
|
||||||
|
.endif
|
||||||
|
|
||||||
|
.if !empty(PKG_OPTIONS:Mx11)
|
||||||
|
PLIST.x11= yes
|
||||||
|
.include "../../x11/libXaw/buildlink3.mk"
|
||||||
|
.else
|
||||||
|
CONFIGURE_ARGS+= --without-x
|
||||||
|
.endif
|
||||||
|
|
|
@ -1,32 +0,0 @@
|
||||||
$NetBSD: patch-ab,v 1.11 2009/09/14 18:52:03 asau Exp $
|
|
||||||
|
|
||||||
--- share/Makefile.in.orig 2009-03-29 00:24:51.000000000 +0300
|
|
||||||
+++ share/Makefile.in 2009-09-14 16:20:30.000000000 +0400
|
|
||||||
@@ -193,7 +193,7 @@
|
|
||||||
top_srcdir = @top_srcdir@
|
|
||||||
AUTOMAKE_OPTIONS = foreign 1.2h
|
|
||||||
EXTRA_DIST = Gnuplot.app-defaults
|
|
||||||
-SUBDIRS = LaTeX
|
|
||||||
+SUBDIRS =
|
|
||||||
appdefaultdir = $(libdir)/X11/app-defaults
|
|
||||||
APPDEFAULTFILES = Gnuplot
|
|
||||||
appdefault_DATA = $(APPDEFAULTFILES)
|
|
||||||
@@ -232,13 +232,15 @@
|
|
||||||
cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
|
|
||||||
install-appdefaultDATA: $(appdefault_DATA)
|
|
||||||
@$(NORMAL_INSTALL)
|
|
||||||
- test -z "$(appdefaultdir)" || $(MKDIR_P) "$(DESTDIR)$(appdefaultdir)"
|
|
||||||
- @list='$(appdefault_DATA)'; for p in $$list; do \
|
|
||||||
+ if test $${INSTALL_XRESOURCE_DATA:-yes} = yes; then \
|
|
||||||
+ test -z "$(appdefaultdir)" || $(mkdir_p) "$(DESTDIR)$(appdefaultdir)"; \
|
|
||||||
+ list='$(appdefault_DATA)'; for p in $$list; do \
|
|
||||||
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
|
||||||
f=$(am__strip_dir) \
|
|
||||||
echo " $(appdefaultDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(appdefaultdir)/$$f'"; \
|
|
||||||
$(appdefaultDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(appdefaultdir)/$$f"; \
|
|
||||||
- done
|
|
||||||
+ done; \
|
|
||||||
+ fi
|
|
||||||
|
|
||||||
uninstall-appdefaultDATA:
|
|
||||||
@$(NORMAL_UNINSTALL)
|
|
|
@ -1,11 +1,11 @@
|
||||||
$NetBSD: patch-ae,v 1.1 2009/09/14 18:52:03 asau Exp $
|
$NetBSD: patch-ae,v 1.2 2011/02/08 13:13:41 adam Exp $
|
||||||
|
|
||||||
NetBSD editline keeps header files in "readline", not "editline".
|
NetBSD editline keeps header files in "readline", not "editline".
|
||||||
Same applies to DragonFly.
|
Same applies to DragonFly.
|
||||||
|
|
||||||
--- src/plot.c.orig 2008-12-15 07:18:36.000000000 +0300
|
--- src/plot.c.orig 2008-12-15 07:18:36.000000000 +0300
|
||||||
+++ src/plot.c 2009-09-14 17:22:09.000000000 +0400
|
+++ src/plot.c 2009-09-14 17:22:09.000000000 +0400
|
||||||
@@ -120,7 +120,7 @@
|
@@ -118,7 +118,7 @@
|
||||||
/* BSD editline
|
/* BSD editline
|
||||||
*/
|
*/
|
||||||
#ifdef HAVE_LIBEDITLINE
|
#ifdef HAVE_LIBEDITLINE
|
||||||
|
|
|
@ -1,11 +1,11 @@
|
||||||
$NetBSD: patch-af,v 1.1 2009/09/14 18:52:03 asau Exp $
|
$NetBSD: patch-af,v 1.2 2011/02/08 13:13:41 adam Exp $
|
||||||
|
|
||||||
NetBSD editline keeps header files in "readline", not "editline".
|
NetBSD editline keeps header files in "readline", not "editline".
|
||||||
Same applies to DragonFly.
|
Same applies to DragonFly.
|
||||||
|
|
||||||
--- configure.in.orig 2009-03-15 06:39:15.000000000 +0300
|
--- configure.in.orig 2009-03-15 06:39:15.000000000 +0300
|
||||||
+++ configure.in 2009-09-14 17:35:06.000000000 +0400
|
+++ configure.in 2009-09-14 17:35:06.000000000 +0400
|
||||||
@@ -305,7 +305,7 @@
|
@@ -339,7 +339,7 @@
|
||||||
if test "$ac_cv_lib_edit_readline" = yes; then
|
if test "$ac_cv_lib_edit_readline" = yes; then
|
||||||
AC_DEFINE(HAVE_LIBEDITLINE,1,
|
AC_DEFINE(HAVE_LIBEDITLINE,1,
|
||||||
[ Define if you are using the BSD editline library. ])
|
[ Define if you are using the BSD editline library. ])
|
||||||
|
|
|
@ -1,16 +1,65 @@
|
||||||
$NetBSD: patch-ag,v 1.2 2009/10/27 20:48:07 asau Exp $
|
$NetBSD: patch-ag,v 1.3 2011/02/08 13:13:41 adam Exp $
|
||||||
|
|
||||||
NetBSD editline keeps header files in "readline", not "editline".
|
NetBSD editline keeps header files in "readline", not "editline".
|
||||||
Same applies to DragonFly.
|
Same applies to DragonFly.
|
||||||
|
|
||||||
--- configure.orig 2009-10-27 23:40:36.000000000 +0300
|
--- configure.orig 2010-09-23 04:22:39.000000000 +0000
|
||||||
+++ configure 2009-10-27 23:42:16.000000000 +0300
|
+++ configure
|
||||||
@@ -9584,7 +9584,7 @@
|
@@ -7119,9 +7119,9 @@ fi
|
||||||
_ACEOF
|
|
||||||
|
|
||||||
|
$as_echo "#define HAVE_LIBEDITLINE 1" >>confdefs.h
|
||||||
|
|
||||||
-for ac_header in editline/readline.h
|
- for ac_header in editline/readline.h
|
||||||
+for ac_header in readline/readline.h
|
+ for ac_header in readline/readline.h
|
||||||
do
|
do :
|
||||||
as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
|
- ac_fn_c_check_header_mongrel "$LINENO" "editline/readline.h" "ac_cv_header_editline_readline_h" "$ac_includes_default"
|
||||||
if { as_var=$as_ac_Header; eval "test \"\${$as_var+set}\" = set"; }; then
|
+ ac_fn_c_check_header_mongrel "$LINENO" "readline/readline.h" "ac_cv_header_editline_readline_h" "$ac_includes_default"
|
||||||
|
if test "x$ac_cv_header_editline_readline_h" = x""yes; then :
|
||||||
|
cat >>confdefs.h <<_ACEOF
|
||||||
|
#define HAVE_EDITLINE_READLINE_H 1
|
||||||
|
@@ -7381,7 +7381,7 @@ _ACEOF
|
||||||
|
|
||||||
|
fi
|
||||||
|
|
||||||
|
- if test "$ac_cv_lib_readline_rl_ding" == no; then
|
||||||
|
+ if test "$ac_cv_lib_readline_rl_ding" = no; then
|
||||||
|
|
||||||
|
$as_echo "#define MISSING_RL_DING 1" >>confdefs.h
|
||||||
|
|
||||||
|
@@ -7431,7 +7431,7 @@ _ACEOF
|
||||||
|
|
||||||
|
fi
|
||||||
|
|
||||||
|
- if test "$ac_cv_lib_readline_rl_forced_update_display" == no; then
|
||||||
|
+ if test "$ac_cv_lib_readline_rl_forced_update_display" = no; then
|
||||||
|
|
||||||
|
$as_echo "#define MISSING_RL_FORCED_UPDATE_DISPLAY 1" >>confdefs.h
|
||||||
|
|
||||||
|
@@ -7481,7 +7481,7 @@ _ACEOF
|
||||||
|
|
||||||
|
fi
|
||||||
|
|
||||||
|
- if test "$ac_cv_lib_readline_rl_reset_after_signal" == yes; then
|
||||||
|
+ if test "$ac_cv_lib_readline_rl_reset_after_signal" = yes; then
|
||||||
|
|
||||||
|
$as_echo "#define HAVE_READLINE_RESET 1" >>confdefs.h
|
||||||
|
|
||||||
|
@@ -7533,7 +7533,7 @@ _ACEOF
|
||||||
|
|
||||||
|
fi
|
||||||
|
|
||||||
|
- if test "$ac_cv_lib_readline_rl_complete_with_tilde_expansion" == no; then
|
||||||
|
+ if test "$ac_cv_lib_readline_rl_complete_with_tilde_expansion" = no; then
|
||||||
|
|
||||||
|
$as_echo "#define MISSING_RL_TILDE_EXPANSION 1" >>confdefs.h
|
||||||
|
|
||||||
|
@@ -7662,7 +7662,9 @@ else
|
||||||
|
if test -d $withval/lib; then
|
||||||
|
LDFLAGS="$LDFLAGS -L$withval/lib"
|
||||||
|
fi
|
||||||
|
+ if test "x$with_x" = xyes; then
|
||||||
|
TERMXLIBS="$X_LIBS -lXaw -lXmu -lXt -lXext -lX11"
|
||||||
|
+ fi
|
||||||
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for pl_textangle in -lplot" >&5
|
||||||
|
$as_echo_n "checking for pl_textangle in -lplot... " >&6; }
|
||||||
|
if test "${ac_cv_lib_plot_pl_textangle+set}" = set; then :
|
||||||
|
|
|
@ -1,17 +1,17 @@
|
||||||
$NetBSD: patch-ah,v 1.1 2011/01/06 07:03:55 dholland Exp $
|
$NetBSD: patch-ah,v 1.2 2011/02/08 13:13:41 adam Exp $
|
||||||
|
|
||||||
Add NetBSD native X and pkgsrc modular X directories to the candidate
|
Add NetBSD native X and pkgsrc modular X directories to the candidate
|
||||||
font path list.
|
font path list.
|
||||||
|
|
||||||
--- src/variable.c.orig 2008-12-15 04:18:36.000000000 +0000
|
--- src/variable.c.orig 2008-12-15 04:18:36.000000000 +0000
|
||||||
+++ src/variable.c
|
+++ src/variable.c
|
||||||
@@ -262,6 +262,12 @@ static const struct path_table fontpath_
|
@@ -275,6 +275,12 @@ static const struct path_table fontpath_
|
||||||
{ "$`kpsexpand '$TEXMFMAIN'`/fonts/type1!" },
|
{ "$`kpsexpand '$TEXMFMAIN'`/fonts/type1!" },
|
||||||
{ "$`kpsexpand '$TEXMFDIST'`/fonts/type1!" },
|
{ "$`kpsexpand '$TEXMFDIST'`/fonts/type1!" },
|
||||||
#endif
|
#endif
|
||||||
+ /* NetBSD pkgsrc X.org */
|
+ /* NetBSD pkgsrc X.org */
|
||||||
+ { PKGSRC_PREFIX "/lib/X11/fonts/Type1" },
|
+ { @PKGSRC_PREFIX@ "/lib/X11/fonts/Type1" },
|
||||||
+ { PKGSRC_PREFIX "/lib/X11/fonts/truetype" },
|
+ { @PKGSRC_PREFIX@ "/lib/X11/fonts/truetype" },
|
||||||
+ /* NetBSD native X.org */
|
+ /* NetBSD native X.org */
|
||||||
+ { "/usr/X11R7/lib/X11/fonts/Type1" },
|
+ { "/usr/X11R7/lib/X11/fonts/Type1" },
|
||||||
+ { "/usr/X11R7/lib/X11/fonts/truetype" },
|
+ { "/usr/X11R7/lib/X11/fonts/truetype" },
|
||||||
|
|
Loading…
Reference in a new issue