DESTDIR safe. Fix build on NetBSD-current.

This commit is contained in:
joerg 2008-03-15 15:09:54 +00:00
parent fc164c693c
commit da7cb9c9a1
3 changed files with 20 additions and 2 deletions

View file

@ -1,9 +1,11 @@
# $NetBSD: Makefile,v 1.16 2008/01/04 20:05:11 jmmv Exp $
# $NetBSD: Makefile,v 1.17 2008/03/15 15:09:54 joerg Exp $
PKGNAME= gnuradio-core-${VERSION}
PKGREVISION= 1
COMMENT= Runtime system and DSP blocks for GNU Radio
PKG_DESTDIR_SUPPORT= user-destdir
.include "../../meta-pkgs/gnuradio/Makefile.common"
PATCHDIR= ${.CURDIR}/../../ham/gnuradio-core/patches

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.9 2007/08/08 03:05:05 wulf Exp $
$NetBSD: distinfo,v 1.10 2008/03/15 15:09:54 joerg Exp $
SHA1 (gnuradio-3.0.4.tar.gz) = ce2d0bd4c5217cdda8c675c80a446ca38f274121
RMD160 (gnuradio-3.0.4.tar.gz) = a1d4ae0495f51c5b7349dd8d1305b4bfb16056dc
@ -9,3 +9,4 @@ SHA1 (patch-ac) = 348898e1e0d58c03295183ce8ce0ee4baf91bddb
SHA1 (patch-ad) = af8bc66ee7c9856e31673e765a52a2fc56e35ebb
SHA1 (patch-ae) = 63e3c4d08162c023efc4c0c97f2141366abc21d5
SHA1 (patch-af) = c65df8f0d4ace5a5d5acb1450940aebdf896b00b
SHA1 (patch-ag) = 988cc6e88ed88c4de910aafbb4e1d66a2ffead70

View file

@ -0,0 +1,15 @@
$NetBSD: patch-ag,v 1.3 2008/03/15 15:09:54 joerg Exp $
--- gnuradio-core/src/lib/general/random.h.orig 2008-03-15 15:34:46.000000000 +0100
+++ gnuradio-core/src/lib/general/random.h
@@ -24,8 +24,9 @@
#define _RANDOM_H_
// we use this because some systems (solaris) define RAND_MAX as 32767
-
+#ifndef RANDOM_MAX
static const int RANDOM_MAX = 2147483647;
+#endif
#include <stdlib.h>