Fix on (at least) SunOS by passing proper LDFLAGS. Bump PKGREVISION.

This commit is contained in:
fhajny 2013-09-13 14:24:28 +00:00
parent 0c4598e463
commit da8f06c1f8
4 changed files with 33 additions and 2 deletions

View file

@ -1,8 +1,9 @@
# $NetBSD: Makefile,v 1.4 2013/09/01 04:45:58 ryoon Exp $
# $NetBSD: Makefile,v 1.5 2013/09/13 14:24:28 fhajny Exp $
#
DISTNAME= luasocket-3.0-rc1
PKGNAME= ${LUA_PKGPREFIX}-${DISTNAME:S/lua//:S/-rc/rc/}
PKGREVISION= 1
CATEGORIES= net
MASTER_SITES= -https://github.com/diegonehab/luasocket/archive/v3.0-rc1.tar.gz

View file

@ -1,5 +1,7 @@
$NetBSD: distinfo,v 1.2 2013/09/01 04:45:58 ryoon Exp $
$NetBSD: distinfo,v 1.3 2013/09/13 14:24:28 fhajny Exp $
SHA1 (luasocket-3.0-rc1.tar.gz) = aff9122b26c01487c06a32133df78c1506af350f
RMD160 (luasocket-3.0-rc1.tar.gz) = 27357eee7e52f091609f45a0b0fb7e04e9ea2bd8
Size (luasocket-3.0-rc1.tar.gz) = 328598 bytes
SHA1 (patch-makefile) = 2a6380adfa8f7ef63e70e0de9ef4eb4e76eff334
SHA1 (patch-src_makefile) = e62f5f133a5c17e6563aefe8de335b93899b2f64

View file

@ -0,0 +1,14 @@
$NetBSD: patch-makefile,v 1.1 2013/09/13 14:24:28 fhajny Exp $
Pass our LDFLAGS.
--- makefile.orig 2013-06-14 11:27:32.000000000 +0000
+++ makefile
@@ -15,7 +15,7 @@ PLATS= macosx linux win32 mingw
all: $(PLAT)
$(PLATS) none install install-unix local clean:
- $(MAKE) -C src $@
+ $(MAKE) -C src $@ MYLDFLAGS="$(LDFLAGS)"
print:
$(MAKE) -C src $@

View file

@ -0,0 +1,14 @@
$NetBSD: patch-src_makefile,v 1.1 2013/09/13 14:24:28 fhajny Exp $
Pass our LDFLAGS.
--- src/makefile.orig 2013-06-14 11:27:32.000000000 +0000
+++ src/makefile
@@ -151,7 +151,7 @@ DEF_linux=-DLUASOCKET_$(DEBUG) -DLUA_$(C
-DMIME_API='__attribute__((visibility("default")))'
CFLAGS_linux= -I$(LUAINC) $(DEF) -pedantic -Wall -Wshadow -Wextra \
-Wimplicit -O2 -ggdb3 -fpic -fvisibility=hidden
-LDFLAGS_linux=-O -shared -fpic -o
+LDFLAGS_linux=-O -shared -fpic $(MYLDFLAGS) -o
LD_linux=gcc
SOCKET_linux=usocket.o