Fixes for non-dri build:

+ Build the x11 version libGL.so with version numbering major 1 and minor 2,
  the same a the glx version of libGL (simplifies PLIST handling).
+ PLIST changes.
This commit is contained in:
sbd 2013-05-20 06:59:18 +00:00
parent a9e008210b
commit daa6b71712
3 changed files with 21 additions and 3 deletions

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.25 2013/05/16 05:22:02 richard Exp $
@comment $NetBSD: PLIST,v 1.26 2013/05/20 06:59:18 sbd Exp $
include/GL/GLwDrawA.h
include/GL/GLwDrawAP.h
include/GL/GLwMDrawA.h
@ -10,7 +10,7 @@ include/GL/glfbdev.h
include/GL/glx.h
include/GL/glx_mangle.h
include/GL/glxext.h
include/GL/internal/dri_interface.h
${PLIST.dri}include/GL/internal/dri_interface.h
include/GL/mesa_wgl.h
include/GL/osmesa.h
include/GL/vms_x_fix.h
@ -24,6 +24,7 @@ lib/libGLw.so.1
lib/libGLw.so.1.0.0
${PLIST.nodri}lib/libOSMesa.so
${PLIST.nodri}lib/libOSMesa.so.7
${PLIST.nodri}lib/libOSMesa.so.7.11.0
${PLIST.dri}lib/dri/i810_dri.so
${PLIST.dri}lib/dri/i915_dri.so
${PLIST.dri}lib/dri/i965_dri.so

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.76 2013/05/19 02:03:57 obache Exp $
$NetBSD: distinfo,v 1.77 2013/05/20 06:59:18 sbd Exp $
SHA1 (Mesa-7.11.2/MesaGLUT-7.11.2.tar.bz2) = 2e6e730204800a0748b301a5f58b86332699788b
RMD160 (Mesa-7.11.2/MesaGLUT-7.11.2.tar.bz2) = bb2b140375aa13df79fcdb60a7ad0a63622dc531
@ -25,6 +25,7 @@ SHA1 (patch-src_mesa_drivers_dri_i965_intel__batchbuffer.c) = 653c87e1123ce9a27b
SHA1 (patch-src_mesa_drivers_dri_intel_intel__context.c) = 21d3c08a27817a6358b88101f889120869eebcce
SHA1 (patch-src_mesa_drivers_dri_intel_intel__context.h) = 6d394e704636134768a6cb5a200ebcc7bc3f52ed
SHA1 (patch-src_mesa_drivers_dri_mach64_mach64__context.h) = fe95c6610de4c1482c568463aca82f53ed0df900
SHA1 (patch-src_mesa_drivers_x11_Makefile) = 17b72d2b74d89fbd8db05491cfcf253bb856b139
SHA1 (patch-src_mesa_main_compiler.h) = 88acf55488d74675f16e851012e23c129e679722
SHA1 (patch-src_mesa_main_imports.c) = d0c50004c749e4c5c136ac2ed50a6989ca90065f
SHA1 (patch-src_mesa_main_imports.h) = f5a96195b3a14294ca3389c9fe17a6076c46db8a

View file

@ -0,0 +1,16 @@
$NetBSD: patch-src_mesa_drivers_x11_Makefile,v 1.1 2013/05/20 06:59:18 sbd Exp $
Build the x11 version libGL.so with version numbering major 1 and minor 2,
the same a the glx version of libGL (simplifies PLIST handling).
--- src/mesa/drivers/x11/Makefile.orig 2011-10-15 00:43:58.000000000 +0000
+++ src/mesa/drivers/x11/Makefile
@@ -61,7 +61,7 @@ default: $(TOP)/$(LIB_DIR)/$(GL_LIB_NAME
$(TOP)/$(LIB_DIR)/$(GL_LIB_NAME): $(OBJECTS) $(CORE_MESA)
@ $(MKLIB) -o $(GL_LIB) -linker '$(CXX)' -ldflags '$(LDFLAGS)' \
- -major $(GL_MAJOR) -minor $(GL_MINOR) -patch $(GL_TINY) \
+ -major 1 -minor 2 \
-install $(TOP)/$(LIB_DIR) \
-cplusplus $(MKLIB_OPTIONS) \
-id $(INSTALL_LIB_DIR)/lib$(GL_LIB).$(GL_MAJOR).dylib \